summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-11-19 08:29:42 +0100
committerRemi Collet <fedora@famillecollet.com>2015-11-19 08:29:42 +0100
commit8407d64734e833027cf10db21fccd9205031c238 (patch)
tree96ca133cb9debad0f76e551e54fc4a8c356d1bf2
parentedd01bb2c8390c4c621917d7bf7c6fff5af08d84 (diff)
php-zendframework-zend-*: run test suite with PHP 7 when available
-rw-r--r--php-zendframework-zend-test.spec5
1 files changed, 5 insertions, 0 deletions
diff --git a/php-zendframework-zend-test.spec b/php-zendframework-zend-test.spec
index 5137c50..dc75aa0 100644
--- a/php-zendframework-zend-test.spec
+++ b/php-zendframework-zend-test.spec
@@ -150,7 +150,12 @@ Zend\Loader\AutoloaderFactory::factory(array(
))));
require_once '%{php_home}/Zend/autoload.php';
EOF
+
%{_bindir}/phpunit --include-path=%{buildroot}%{php_home}
+
+if which php70; then
+ php70 %{_bindir}/phpunit --include-path=%{buildroot}%{php_home}
+fi
%else
: Test suite disabled
%endif