summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-02-04 16:15:10 +0100
committerRemi Collet <fedora@famillecollet.com>2016-02-04 16:15:10 +0100
commit45bfbf260c618b8797a883517535f5b119b80347 (patch)
treec04f1aebf112908b6e854ae62930d7f1bac9d00d
parent4d0cabc142a1664c7e51793c04846d2d6ebd0b07 (diff)
php-zendframework-zend-tag: 2.6.1
-rw-r--r--php-zendframework-zend-tag.spec44
1 files changed, 24 insertions, 20 deletions
diff --git a/php-zendframework-zend-tag.spec b/php-zendframework-zend-tag.spec
index e7f07f0..da26aa2 100644
--- a/php-zendframework-zend-tag.spec
+++ b/php-zendframework-zend-tag.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 08661ac808e848d1aea1796af01230c2814855b4
+%global gh_commit 4429ca5016361f12eff920370170391a0f4adbff
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-tag
@@ -20,7 +20,7 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.5.1
+Version: 2.6.1
Release: 1%{?dist}
Summary: Zend Framework %{library} component
@@ -34,33 +34,31 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.3.23
+BuildRequires: php(language) >= 5.5
BuildRequires: php-pcre
BuildRequires: php-spl
BuildRequires: php-composer(%{gh_owner}/zend-escaper) >= 2.5
-BuildRequires: php-composer(%{gh_owner}/zend-stdlib) >= 2.5
+BuildRequires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7
# From composer, "require-dev": {
-# "zendframework/zend-config": "~2.5",
-# "zendframework/zend-servicemanager": "~2.5",
+# "zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3",
# "fabpot/php-cs-fixer": "1.7.*",
# "phpunit/PHPUnit": "~4.0"
-BuildRequires: php-composer(%{gh_owner}/zend-config) >= 2.5
-BuildRequires: php-composer(%{gh_owner}/zend-servicemanager) >= 2.5
+BuildRequires: php-composer(%{gh_owner}/zend-servicemanager) >= 2.7.5
BuildRequires: php-composer(phpunit/phpunit) >= 4.0
# Autoloader
BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
%endif
# From composer, "require": {
-# "php": ">=5.3.23",
-# "zendframework/zend-escaper": "~2.5",
-# "zendframework/zend-stdlib": "~2.5"
-Requires: php(language) >= 5.3.23
+# "php": "^5.5 || ^7.0",
+# "zendframework/zend-escaper": "^2.5",
+# "zendframework/zend-stdlib": "^2.7 || ^3.0"
+Requires: php(language) >= 5.5
%if ! %{bootstrap}
Requires: php-composer(%{gh_owner}/zend-escaper) >= 2.5
Requires: php-composer(%{gh_owner}/zend-escaper) < 3
-Requires: php-composer(%{gh_owner}/zend-stdlib) >= 2.5
-Requires: php-composer(%{gh_owner}/zend-stdlib) < 3
+Requires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7
+Requires: php-composer(%{gh_owner}/zend-stdlib) < 4
# From composer, "suggest": {
# "zendframework/zend-servicemanager": "Zend\\ServiceManager component"
%if 0%{?fedora} >= 21
@@ -102,14 +100,14 @@ cp -pr src %{buildroot}%{php_home}/Zend/%{library}
%check
%if %{with_tests}
mkdir vendor
-cat << EOF | tee vendor/autoload.php
+cat << 'EOF' | tee vendor/autoload.php
<?php
require_once '%{php_home}/Zend/Loader/AutoloaderFactory.php';
-Zend\\Loader\\AutoloaderFactory::factory(array(
- 'Zend\\Loader\\StandardAutoloader' => array(
+Zend\Loader\AutoloaderFactory::factory(array(
+ 'Zend\Loader\StandardAutoloader' => array(
'namespaces' => array(
- 'ZendTest\\\\%{library}' => dirname(__DIR__).'/test/',
- 'Zend\\\\%{library}' => '%{buildroot}%{php_home}/Zend/%{library}'
+ 'ZendTest\\%{library}' => dirname(__DIR__).'/test/',
+ 'Zend\\%{library}' => '%{buildroot}%{php_home}/Zend/%{library}'
))));
require_once '%{php_home}/Zend/autoload.php';
EOF
@@ -138,5 +136,11 @@ rm -rf %{buildroot}
%changelog
+* Thu Feb 4 2016 Remi Collet <remi@fedoraproject.org> - 2.6.1-1
+- update to 2.6.1
+- raise dependency on PHP >= 5.5
+- raise dependency on zend_stdlib ~2.7
+- raise build dependency on zend-servicemanager ~2.7.5
+
* Tue Aug 4 2015 Remi Collet <remi@fedoraproject.org> - 2.5.1-1
-- initial package \ No newline at end of file
+- initial package