summaryrefslogtreecommitdiffstats
path: root/php-zendframework-zend-stdlib.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-zendframework-zend-stdlib.spec')
-rw-r--r--php-zendframework-zend-stdlib.spec21
1 files changed, 11 insertions, 10 deletions
diff --git a/php-zendframework-zend-stdlib.spec b/php-zendframework-zend-stdlib.spec
index d0318a8..cebeff3 100644
--- a/php-zendframework-zend-stdlib.spec
+++ b/php-zendframework-zend-stdlib.spec
@@ -1,13 +1,13 @@
# remirepo/Fedora spec file for php-zendframework-zend-stdlib
#
-# Copyright (c) 2015-2017 Remi Collet
+# Copyright (c) 2015-2018 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit debedcfc373a293f9250cc9aa03cf121428c8e78
+%global gh_commit 10ef03144902d1955f935fff5346ed52f7d99bcc
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-stdlib
@@ -20,8 +20,8 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 3.1.0
-Release: 6%{?dist}
+Version: 3.1.1
+Release: 1%{?dist}
Summary: Zend Framework %{library} component
Group: Development/Libraries
@@ -30,8 +30,6 @@ URL: https://zendframework.github.io/%{gh_project}/
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
-Patch0: https://patch-diff.githubusercontent.com/raw/zendframework/zend-stdlib/pull/81.patch
-
BuildArch: noarch
# Tests
%if %{with_tests}
@@ -46,7 +44,7 @@ BuildRequires: php-spl
# "athletic/athletic": "~0.1",
# "fabpot/php-cs-fixer": "1.7.*",
# "phpunit/PHPUnit": "~4.0",
-# "squizlabs/php_codesniffer": "^2.6.2"
+# "zendframework/zend-coding-standard": "~1.0.0"
BuildRequires: php-composer(phpunit/phpunit) >= 4.0
# Autoloader
BuildRequires: php-fedora-autoloader-devel
@@ -86,7 +84,6 @@ Documentation: https://zendframework.github.io/%{gh_project}/
%prep
%setup -q -n %{gh_project}-%{gh_commit}
-%patch0 -p1
mv LICENSE.md LICENSE
@@ -106,11 +103,11 @@ mkdir vendor
cat << 'EOF' | tee vendor/autoload.php
<?php
require_once '%{buildroot}%{php_home}/Zend/%{library}/autoload.php';
-\Fedora\Autoloader\Autoload::addPsr4('ZendTest\\Stdlib\\', dirname(__DIR__) . '/test');
+\Fedora\Autoloader\Autoload::addPsr4('ZendTest\\%{library}\\', dirname(__DIR__) . '/test');
EOF
ret=0
-for cmd in php php56 php70 php71 php72; do
+for cmd in php php70 php71 php72; do
if which $cmd; then
$cmd %{_bindir}/phpunit --verbose || ret=1
fi
@@ -126,10 +123,14 @@ exit $ret
%license LICENSE
%doc *.md
%doc composer.json
+%dir %{php_home}/Zend
%{php_home}/Zend/%{library}
%changelog
+* Mon Apr 16 2018 Remi Collet <remi@remirepo.net> - 3.1.1-1
+- update to 3.1.1
+
* Thu Nov 23 2017 Remi Collet <remi@fedoraproject.org> - 3.1.0-6
- provide php-autoloader(zendframework/zend-stdlib)