summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--93.patch23
-rw-r--r--php-zendframework-zend-stdlib.spec12
2 files changed, 6 insertions, 29 deletions
diff --git a/93.patch b/93.patch
deleted file mode 100644
index 06143be..0000000
--- a/93.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-From 70667fe80d193e1da2975356ecbff0287830d7b8 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Mon, 27 Aug 2018 08:15:06 +0200
-Subject: [PATCH] Fix PHP 7.3 warning: "continue" targeting switch is
- equivalent to "break". Did you mean to use "continue 2"?
-
----
- src/ArrayObject.php | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/ArrayObject.php b/src/ArrayObject.php
-index 926ff6ea..8c77c620 100644
---- a/src/ArrayObject.php
-+++ b/src/ArrayObject.php
-@@ -425,7 +425,7 @@ public function unserialize($data)
- $this->setIteratorClass($v);
- break;
- case 'protectedProperties':
-- continue;
-+ break;
- default:
- $this->__set($k, $v);
- }
diff --git a/php-zendframework-zend-stdlib.spec b/php-zendframework-zend-stdlib.spec
index 2c57677..c9e36c2 100644
--- a/php-zendframework-zend-stdlib.spec
+++ b/php-zendframework-zend-stdlib.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit cd164b4a18b5d1aeb69be2c26db035b5ed6925ae
+%global gh_commit 66536006722aff9e62d1b331025089b7ec71c065
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-stdlib
@@ -20,8 +20,8 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 3.2.0
-Release: 2%{?dist}
+Version: 3.2.1
+Release: 1%{?dist}
Summary: Zend Framework %{library} component
Group: Development/Libraries
@@ -30,8 +30,6 @@ URL: https://zendframework.github.io/%{gh_project}/
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
-Patch0: https://patch-diff.githubusercontent.com/raw/zendframework/zend-stdlib/pull/93.patch
-
BuildArch: noarch
# Tests
%if %{with_tests}
@@ -93,7 +91,6 @@ Documentation: https://zendframework.github.io/%{gh_project}/
%prep
%setup -q -n %{gh_project}-%{gh_commit}
-%patch0 -p1
mv LICENSE.md LICENSE
@@ -139,6 +136,9 @@ exit $ret
%changelog
+* Wed Aug 29 2018 Remi Collet <remi@remirepo.net> - 3.2.1-1
+- update to 3.2.1
+
* Mon Aug 27 2018 Remi Collet <remi@remirepo.net> - 3.2.0-2
- add patch for PHP 7.3 from
https://github.com/zendframework/zend-stdlib/pull/93