summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-11-19 08:29:42 +0100
committerRemi Collet <fedora@famillecollet.com>2015-11-19 08:29:42 +0100
commit9bd4742468b2b7bdf1634fc4df9d7db4cec9214c (patch)
treeceb9af9b06a922f5fbc0e10001cae1264164aca1
parent96ef0fdec47d3ca650531639fccef61262385c60 (diff)
php-zendframework-zend-*: run test suite with PHP 7 when available
-rw-r--r--php-zendframework-zend-stdlib.spec6
1 files changed, 5 insertions, 1 deletions
diff --git a/php-zendframework-zend-stdlib.spec b/php-zendframework-zend-stdlib.spec
index cd4b17b..58e03d3 100644
--- a/php-zendframework-zend-stdlib.spec
+++ b/php-zendframework-zend-stdlib.spec
@@ -134,8 +134,12 @@ Zend\\Loader\\AutoloaderFactory::factory(array(
))));
require_once '%{php_home}/Zend/autoload.php';
EOF
-%{_bindir}/php -r 'require "vendor/autoload.php"; var_dump(Zend\Loader\AutoloaderFactory::getRegisteredAutoloaders());'
+
%{_bindir}/phpunit --include-path=%{buildroot}%{php_home}
+
+if which php70; then
+ php70 %{_bindir}/phpunit --include-path=%{buildroot}%{php_home}
+fi
%else
: Test suite disabled
%endif