summaryrefslogtreecommitdiffstats
path: root/php-zendframework-zend-soap.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-zendframework-zend-soap.spec')
-rw-r--r--php-zendframework-zend-soap.spec20
1 files changed, 7 insertions, 13 deletions
diff --git a/php-zendframework-zend-soap.spec b/php-zendframework-zend-soap.spec
index d5b1401..e28fae7 100644
--- a/php-zendframework-zend-soap.spec
+++ b/php-zendframework-zend-soap.spec
@@ -30,7 +30,6 @@ URL: https://zendframework.github.io/%{gh_project}/
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
# Tests
%if %{with_tests}
@@ -106,8 +105,6 @@ mv LICENSE.md LICENSE
%install
-rm -rf %{buildroot}
-
mkdir -p %{buildroot}%{php_home}/Zend/
cp -pr src %{buildroot}%{php_home}/Zend/%{library}
@@ -129,22 +126,19 @@ require_once 'test/TestAsset/commontypes.php';
require_once 'test/TestAsset/call_user_func.php';
EOF
-%{_bindir}/phpunit --include-path=%{buildroot}%{php_home}
-
-if which php70; then
- php70 %{_bindir}/phpunit --include-path=%{buildroot}%{php_home} || : ignore
-fi
+ret=0
+for cmd in php php56 php70 php71 php72; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit || ret=1
+ fi
+done
+exit $ret
%else
: Test suite disabled
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md