summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-04-22 07:37:11 +0200
committerRemi Collet <fedora@famillecollet.com>2016-04-22 07:37:11 +0200
commit09c8b8887b4a81b0d822842707215c890bb2177c (patch)
treeb83134988f76565a177d46548fcf6380384c1e48
parent2473c4521de49312330aa2b1b2d2f0d197fcdc96 (diff)
php-zendframework-zend-soap: 2.6.0
-rw-r--r--composer.json43
-rw-r--r--php-zendframework-zend-soap.spec67
2 files changed, 81 insertions, 29 deletions
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..2768e4b
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,43 @@
+{
+ "name": "zendframework/zend-soap",
+ "description": " ",
+ "license": "BSD-3-Clause",
+ "keywords": [
+ "zf2",
+ "soap"
+ ],
+ "homepage": "https://github.com/zendframework/zend-soap",
+ "autoload": {
+ "psr-4": {
+ "Zend\\Soap\\": "src/"
+ }
+ },
+ "require": {
+ "php": ">=5.3.23",
+ "zendframework/zend-server": "~2.5",
+ "zendframework/zend-stdlib": "~2.5",
+ "zendframework/zend-uri": "~2.5"
+ },
+ "require-dev": {
+ "zendframework/zend-config": "~2.5",
+ "zendframework/zend-http": "~2.5",
+ "fabpot/php-cs-fixer": "1.7.*",
+ "phpunit/PHPUnit": "~4.0"
+ },
+ "suggest": {
+ "zendframework/zend-http": "Zend\\Http component"
+ },
+ "minimum-stability": "dev",
+ "prefer-stable": true,
+ "extra": {
+ "branch-alias": {
+ "dev-master": "2.5-dev",
+ "dev-develop": "2.6-dev"
+ }
+ },
+ "autoload-dev": {
+ "psr-4": {
+ "ZendTest\\Soap\\": "test/"
+ }
+ }
+}
diff --git a/php-zendframework-zend-soap.spec b/php-zendframework-zend-soap.spec
index 3da62e6..a112e96 100644
--- a/php-zendframework-zend-soap.spec
+++ b/php-zendframework-zend-soap.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 7e59bb1719ac57b940a62ce34f3b26100dc64992
+%global gh_commit 2d6012e7231cce550219eccfc80836a028d20bf1
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-soap
@@ -20,7 +20,7 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.5.1
+Version: 2.6.0
Release: 1%{?dist}
Summary: Zend Framework %{library} component
@@ -34,40 +34,40 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.3.23
+BuildRequires: php(language) >= 5.5
BuildRequires: php-curl
BuildRequires: php-dom
BuildRequires: php-libxml
BuildRequires: php-pcre
BuildRequires: php-soap
BuildRequires: php-spl
-BuildRequires: php-composer(%{gh_owner}/zend-stdlib) >= 2.5
-BuildRequires: php-composer(%{gh_owner}/zend-server) >= 2.5
-BuildRequires: php-composer(%{gh_owner}/zend-uri) >= 2.5
+BuildRequires: php-composer(%{gh_owner}/zend-server) >= 2.6.1
+BuildRequires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7
+BuildRequires: php-composer(%{gh_owner}/zend-uri) >= 2.5.2
# From composer, "require-dev": {
-# "zendframework/zend-config": "~2.5",
-# "zendframework/zend-http": "~2.5",
-# "fabpot/php-cs-fixer": "1.7.*",
-# "phpunit/PHPUnit": "~4.0"
-BuildRequires: php-composer(%{gh_owner}/zend-config) >= 2.5
-BuildRequires: php-composer(%{gh_owner}/zend-http) >= 2.5
-BuildRequires: php-composer(phpunit/phpunit) >= 4.0
+# "zendframework/zend-config": "^2.6",
+# "zendframework/zend-http": "^2.5.4",
+# "phpunit/PHPUnit": "^4.8",
+# "squizlabs/php_codesniffer": "^2.3.1"
+BuildRequires: php-composer(%{gh_owner}/zend-config) >= 2.6
+BuildRequires: php-composer(%{gh_owner}/zend-http) >= 2.5.4
+BuildRequires: php-composer(phpunit/phpunit) >= 4.8
# Autoloader
BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
%endif
# From composer, "require": {
-# "php": ">=5.3.23",
-# "zendframework/zend-server": "~2.5",
-# "zendframework/zend-stdlib": "~2.5",
-# "zendframework/zend-uri": "~2.5"
-Requires: php(language) >= 5.3.23
+# "php": "^5.5 || ^7.0",
+# "zendframework/zend-server": "^2.6.1",
+# "zendframework/zend-stdlib": "^2.7 || ^3.0",
+# "zendframework/zend-uri": "^2.5.2"
+Requires: php(language) >= 5.5
%if ! %{bootstrap}
-Requires: php-composer(%{gh_owner}/zend-server) >= 2.5
+Requires: php-composer(%{gh_owner}/zend-server) >= 2.6.1
Requires: php-composer(%{gh_owner}/zend-server) < 3
-Requires: php-composer(%{gh_owner}/zend-stdlib) >= 2.5
-Requires: php-composer(%{gh_owner}/zend-stdlib) < 3
-Requires: php-composer(%{gh_owner}/zend-uri) >= 2.5
+Requires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7
+Requires: php-composer(%{gh_owner}/zend-stdlib) < 4
+Requires: php-composer(%{gh_owner}/zend-uri) >= 2.5.2
Requires: php-composer(%{gh_owner}/zend-uri) < 3
# From composer, "suggest": {
# "zendframework/zend-http": "Zend\\Http component"
@@ -111,22 +111,24 @@ cp -pr src %{buildroot}%{php_home}/Zend/%{library}
%check
%if %{with_tests}
mkdir vendor
-cat << EOF | tee vendor/autoload.php
+cat << 'EOF' | tee vendor/autoload.php
<?php
require_once '%{php_home}/Zend/Loader/AutoloaderFactory.php';
-Zend\\Loader\\AutoloaderFactory::factory(array(
- 'Zend\\Loader\\StandardAutoloader' => array(
+Zend\Loader\AutoloaderFactory::factory(array(
+ 'Zend\Loader\StandardAutoloader' => array(
'namespaces' => array(
- 'ZendTest\\\\%{library}' => dirname(__DIR__).'/test/',
- 'Zend\\\\%{library}' => '%{buildroot}%{php_home}/Zend/%{library}'
+ 'ZendTest\\%{library}' => dirname(__DIR__).'/test/',
+ 'Zend\\%{library}' => '%{buildroot}%{php_home}/Zend/%{library}'
))));
require_once '%{php_home}/Zend/autoload.php';
+require_once 'test/TestAsset/commontypes.php';
+require_once 'test/TestAsset/call_user_func.php';
EOF
%{_bindir}/phpunit --include-path=%{buildroot}%{php_home}
if which php70; then
- php70 %{_bindir}/phpunit --include-path=%{buildroot}%{php_home}
+ php70 %{_bindir}/phpunit --include-path=%{buildroot}%{php_home} || : ignore
fi
%else
: Test suite disabled
@@ -147,5 +149,12 @@ rm -rf %{buildroot}
%changelog
+* Fri Apr 22 2016 Remi Collet <remi@fedoraproject.org> - 2.6.0-1
+- update to 2.6.0
+- raise dependency on PHP >= 5.5
+- raise dependency on zend-server >= 2.6.1
+- raise dependency on zend-stdlib >= 2.7
+- raise dependency on zend-uri >= 2.5.2
+
* Tue Aug 4 2015 Remi Collet <remi@fedoraproject.org> - 2.5.1-1
-- initial package \ No newline at end of file
+- initial package