summaryrefslogtreecommitdiffstats
path: root/php-zendframework-zend-session.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-zendframework-zend-session.spec')
-rw-r--r--php-zendframework-zend-session.spec26
1 files changed, 19 insertions, 7 deletions
diff --git a/php-zendframework-zend-session.spec b/php-zendframework-zend-session.spec
index d88b199..4f78375 100644
--- a/php-zendframework-zend-session.spec
+++ b/php-zendframework-zend-session.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 2cfd90e1a2f6b066b9f908599251d8f64f07021b
+%global gh_commit 8e67629ba7ddc67e3b03157615156317535bffa7
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-session
@@ -20,8 +20,8 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.8.5
-Release: 3%{?dist}
+Version: 2.8.6
+Release: 2%{?dist}
Summary: Zend Framework %{library} component
License: BSD
@@ -38,8 +38,17 @@ BuildRequires: php-hash
BuildRequires: php-pcre
BuildRequires: php-session
BuildRequires: php-spl
-BuildRequires: php-autoloader(%{gh_owner}/zend-eventmanager) >= 2.5
-BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) >= 2.5
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (php-autoloader(%{gh_owner}/zend-eventmanager) >= 2.6.2 with php-autoloader(%{gh_owner}/zend-eventmanager) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7 with php-autoloader(%{gh_owner}/zend-stdlib) < 4)
+# remirepo:6
+%else
+BuildRequires: php-autoloader(%{gh_owner}/zend-eventmanager) < 4
+BuildRequires: php-autoloader(%{gh_owner}/zend-eventmanager) >= 2.6.2
+BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) < 4
+BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7
+%endif
# From composer, "require-dev": {
# "container-interop/container-interop": "^1.1",
# "mongodb/mongodb": "^1.0.1",
@@ -61,7 +70,7 @@ BuildRequires: (php-autoloader(%{gh_owner}/zend-servicemanager) >= 2.7.5 wit
BuildRequires: (php-autoloader(%{gh_owner}/zend-validator) >= 2.6 with php-autoloader(%{gh_owner}/zend-validator) < 3)
# remirepo:9
%else
-BuildRequires: php-composer(container-interop/container-interop) < 2
+BuildRequires: php-composer(container-interop/container-interop) < 2
BuildRequires: php-composer(container-interop/container-interop) >= 1.1
BuildRequires: php-autoloader(%{gh_owner}/zend-cache) >= 2.6.1
BuildRequires: php-autoloader(%{gh_owner}/zend-db) >= 2.7
@@ -177,7 +186,7 @@ require_once __DIR__ . '/../test/autoload.php';
EOF
ret=0
-for cmd in php php70 php71 php72; do
+for cmd in php php71 php72 php73 php74; do
if which $cmd; then
$cmd %{_bindir}/phpunit6 --verbose || ret=1
fi
@@ -197,6 +206,9 @@ exit $ret
%changelog
+* Tue Aug 20 2019 Remi Collet <remi@remirepo.net> - 2.8.6-2
+- update to 2.8.6
+
* Thu Dec 6 2018 Remi Collet <remi@remirepo.net> - 2.8.5-3
- cleanup for EL-8