summaryrefslogtreecommitdiffstats
path: root/php-zendframework-zend-session.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-06-20 07:11:02 +0200
committerRemi Collet <remi@remirepo.net>2017-06-20 07:11:02 +0200
commit35eaafee1fbe114517ded99073a9a0495944d3cd (patch)
treeccca248e11fda95651bb4eb0074d3d454e449a8f /php-zendframework-zend-session.spec
parentdee9bac5e564a2c673242057194ca540744b9e9d (diff)
v2.8.0
Diffstat (limited to 'php-zendframework-zend-session.spec')
-rw-r--r--php-zendframework-zend-session.spec83
1 files changed, 34 insertions, 49 deletions
diff --git a/php-zendframework-zend-session.spec b/php-zendframework-zend-session.spec
index 2623059..eeb2ba4 100644
--- a/php-zendframework-zend-session.spec
+++ b/php-zendframework-zend-session.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 346e9709657b81a5d53d70ce754730a26d1f02f2
+%global gh_commit b1486c382decc241de8b1c7778eaf2f0a884f67d
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-session
@@ -20,8 +20,8 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.7.3
-Release: 2%{?dist}
+Version: 2.8.0
+Release: 1%{?dist}
Summary: Zend Framework %{library} component
Group: Development/Libraries
@@ -30,11 +30,10 @@ URL: https://zendframework.github.io/%{gh_project}/
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.5
+BuildRequires: php(language) >= 5.6
BuildRequires: php-date
BuildRequires: php-hash
BuildRequires: php-pcre
@@ -43,60 +42,63 @@ BuildRequires: php-spl
BuildRequires: php-composer(%{gh_owner}/zend-eventmanager) >= 2.5
BuildRequires: php-composer(%{gh_owner}/zend-stdlib) >= 2.5
# From composer, "require-dev": {
+# "container-interop/container-interop": "^1.1",
+# "mongodb/mongodb": "^1.0.1",
+# "phpunit/phpunit": "^6.0.8 || ^5.7.15",
# "zendframework/zend-cache": "^2.6.1",
+# "zendframework/zend-coding-standard": "~1.0.0",
# "zendframework/zend-db": "^2.7",
# "zendframework/zend-http": "^2.5.4",
# "zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3",
-# "zendframework/zend-validator": "^2.6",
-# "container-interop/container-interop": "^1.1",
-# "mongodb/mongodb": "^1.0.1",
-# "fabpot/php-cs-fixer": "1.7.*",
-# "phpunit/PHPUnit": "~4.0"
+# "zendframework/zend-validator": "^2.6"
+BuildRequires: php-composer(container-interop/container-interop) >= 1.1
BuildRequires: php-composer(%{gh_owner}/zend-cache) >= 2.6.1
BuildRequires: php-composer(%{gh_owner}/zend-db) >= 2.7
BuildRequires: php-composer(%{gh_owner}/zend-http) >= 2.5.4
BuildRequires: php-composer(%{gh_owner}/zend-servicemanager) >= 2.7.5
BuildRequires: php-composer(%{gh_owner}/zend-validator) >= 2.6
-BuildRequires: php-composer(container-interop/container-interop) >= 1.1
-BuildRequires: php-composer(phpunit/phpunit) >= 4.0
+%if 0%{?fedora} >= 26
+%global phpunit %{_bindir}/phpunit6
+%else
+%global phpunit %{_bindir}/phpunit
+%endif
+BuildRequires: %{phpunit}
# Autoloader
BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
%endif
# From composer, "require": {
-# "php": "^5.5 || ^7.0",
+# "php": "^7.0 || ^5.6",
# "zendframework/zend-eventmanager": "^2.6.2 || ^3.0",
# "zendframework/zend-stdlib": "^2.7 || ^3.0"
-Requires: php(language) >= 5.5
+Requires: php(language) >= 5.6
%if ! %{bootstrap}
Requires: php-composer(%{gh_owner}/zend-eventmanager) >= 2.6.2
Requires: php-composer(%{gh_owner}/zend-eventmanager) < 4
Requires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7
Requires: php-composer(%{gh_owner}/zend-stdlib) < 4
# From composer, "suggest": {
+# "mongodb/mongodb": "If you want to use the MongoDB session save handler"
# "zendframework/zend-cache": "Zend\\Cache component",
# "zendframework/zend-db": "Zend\\Db component",
# "zendframework/zend-http": "Zend\\Http component",
# "zendframework/zend-servicemanager": "Zend\\ServiceManager component",
# "zendframework/zend-validator": "Zend\\Validator component"
-# "zendframework/zend-validator": "Zend\\Validator component",
-# "mongodb/mongodb": "If you want to use the MongoDB session save handler"
%if 0%{?fedora} >= 21
+Suggests: php-composer(mongodb/mongodb)
Suggests: php-composer(%{gh_owner}/zend-cache)
Suggests: php-composer(%{gh_owner}/zend-db)
Suggests: php-composer(%{gh_owner}/zend-http)
Suggests: php-composer(%{gh_owner}/zend-servicemanager)
Suggests: php-composer(%{gh_owner}/zend-validator)
-Suggests: php-composer(mongodb/mongodb)
%endif
%endif
-# From phpcompatinfo report for version 2.5.2
+# From phpcompatinfo report for version 2.8.0
Requires: php-date
Requires: php-hash
Requires: php-pcre
Requires: php-session
Requires: php-spl
-# Mongo is optional
Obsoletes: php-ZendFramework2-%{library} < 2.5
Provides: php-ZendFramework2-%{library} = %{version}
@@ -121,8 +123,6 @@ mv LICENSE.md LICENSE
%install
-rm -rf %{buildroot}
-
mkdir -p %{buildroot}%{php_home}/Zend/
cp -pr src %{buildroot}%{php_home}/Zend/%{library}
@@ -143,44 +143,24 @@ Zend\Loader\AutoloaderFactory::factory(array(
'Zend\\%{library}' => '%{buildroot}%{php_home}/Zend/%{library}'
))));
require_once '%{php_home}/Zend/autoload.php';
+require_once __DIR__ . '/../test/autoload.php';
EOF
-# ignore failed test with PHP 7.1
-# see https://github.com/zendframework/zend-session/issues/68
-rm test/Config/SessionConfigTest.php
-
-# remirepo:16
-%if 0%{?rhel} == 5
-# sqlite is too old
-rm test/SaveHandler/DbTableGatewayTest.php
-%endif
-
-run=0
+# PHP 7.2: ini_set(): Cannot set 'user' save handler by ini_set() or session_module_name()
ret=0
-if which php56; then
- php56 %{_bindir}/phpunit || ret=1
- run=1
-fi
-if which php71; then
- php71 %{_bindir}/phpunit || ret=1
- run=1
-fi
-if [ $run -eq 0 ]; then
-%{_bindir}/phpunit --verbose
-# remirepo:2
-fi
+for cmd in "php %{phpunit}" "php56 %{_bindir}/phpunit" php70 php71; do
+ if which $cmd; then
+ set $cmd
+ $1 ${2:-%{_bindir}/phpunit6} --verbose || ret=1
+ fi
+done
exit $ret
%else
: Test suite disabled
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md
@@ -189,6 +169,11 @@ rm -rf %{buildroot}
%changelog
+* Tue Jun 20 2017 Remi Collet <remi@remirepo.net> - 2.8.0-1
+- Update to 2.8.0
+- raise dependency on PHP 5.6
+- use phpunit6 on F26+
+
* Wed Nov 30 2016 Remi Collet <remi@fedoraproject.org> - 2.7.3-2
- fix FTBFS, ignore failed test with PHP 7.1
open https://github.com/zendframework/zend-session/issues/68