summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-02-23 06:30:25 +0100
committerRemi Collet <remi@remirepo.net>2018-02-23 06:30:25 +0100
commit706a2e464ee7d09c940028a1877a1a9fb1efb1a2 (patch)
treebecab82ec23b5ae54b0f0cc34189c4ba4669941b
parente602ce069cf3ed5c78e5323044c03cb1c3832706 (diff)
Update to 2.8.5 (no change)
use range dependencies
-rw-r--r--composer.json5
-rw-r--r--php-zendframework-zend-session.spec36
2 files changed, 19 insertions, 22 deletions
diff --git a/composer.json b/composer.json
index 37f3d21..31d420b 100644
--- a/composer.json
+++ b/composer.json
@@ -24,7 +24,7 @@
"container-interop/container-interop": "^1.1",
"mongodb/mongodb": "^1.0.1",
"php-mock/php-mock-phpunit": "^1.1.2 || ^2.0",
- "phpunit/phpunit": "^5.7.5 || ^6.0.13",
+ "phpunit/phpunit": "^5.7.5 || >=6.0.13 <6.5.0",
"zendframework/zend-cache": "^2.6.1",
"zendframework/zend-coding-standard": "~1.0.0",
"zendframework/zend-db": "^2.7",
@@ -32,9 +32,6 @@
"zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3",
"zendframework/zend-validator": "^2.6"
},
- "conflict": {
- "phpunit/phpunit": ">=6.5.0"
- },
"suggest": {
"mongodb/mongodb": "If you want to use the MongoDB session save handler",
"zendframework/zend-cache": "Zend\\Cache component",
diff --git a/php-zendframework-zend-session.spec b/php-zendframework-zend-session.spec
index e0366f9..1dabce5 100644
--- a/php-zendframework-zend-session.spec
+++ b/php-zendframework-zend-session.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 9338f1ae483bcc18cc3b6c0347c8ba4f448b3e2a
+%global gh_commit 2cfd90e1a2f6b066b9f908599251d8f64f07021b
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-session
@@ -20,8 +20,8 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.8.4
-Release: 2%{?dist}
+Version: 2.8.5
+Release: 1%{?dist}
Summary: Zend Framework %{library} component
Group: Development/Libraries
@@ -45,25 +45,23 @@ BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) >= 2.5
# "container-interop/container-interop": "^1.1",
# "mongodb/mongodb": "^1.0.1",
# "php-mock/php-mock-phpunit": "^1.1.2 || ^2.0",
-# "phpunit/phpunit": "^5.7.5 || ^6.0.13",
+# "phpunit/phpunit": "^5.7.5 || >=6.0.13 <6.5.0",
# "zendframework/zend-cache": "^2.6.1",
# "zendframework/zend-coding-standard": "~1.0.0",
# "zendframework/zend-db": "^2.7",
# "zendframework/zend-http": "^2.5.4",
# "zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3",
# "zendframework/zend-validator": "^2.6"
-BuildRequires: php-composer(container-interop/container-interop) < 2
-BuildRequires: php-composer(container-interop/container-interop) >= 1.1
+BuildRequires: (php-composer(container-interop/container-interop) >= 1.1 with php-composer(container-interop/container-interop) < 2)
# v2 doesn't exist yet in repository
# TODO only PHPUnit 5 as php-mock v2 required by PHPUnit 6
-BuildRequires: php-composer(php-mock/php-mock-phpunit) < 2
-BuildRequires: php-composer(php-mock/php-mock-phpunit) >= 1.1.2
-BuildRequires: php-composer(phpunit/phpunit) >= 5.7.15
-BuildRequires: php-autoloader(%{gh_owner}/zend-cache) >= 2.6.1
-BuildRequires: php-autoloader(%{gh_owner}/zend-db) >= 2.7
-BuildRequires: php-autoloader(%{gh_owner}/zend-http) >= 2.5.4
-BuildRequires: php-autoloader(%{gh_owner}/zend-servicemanager) >= 2.7.5
-BuildRequires: php-autoloader(%{gh_owner}/zend-validator) >= 2.6
+BuildRequires: (php-composer(php-mock/php-mock-phpunit) >= 1.1.2 with php-composer(php-mock/php-mock-phpunit) < 2)
+BuildRequires: php-composer(phpunit/phpunit) >= 5.7.15
+BuildRequires: (php-autoloader(%{gh_owner}/zend-cache) >= 2.6.1 with php-autoloader(%{gh_owner}/zend-cache) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-db) >= 2.7 with php-autoloader(%{gh_owner}/zend-db) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-http) >= 2.5.4 with php-autoloader(%{gh_owner}/zend-http) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-servicemanager) >= 2.7.5 with php-autoloader(%{gh_owner}/zend-servicemanager) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-validator) >= 2.6 with php-autoloader(%{gh_owner}/zend-validator) < 3)
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
@@ -74,10 +72,8 @@ BuildRequires: php-fedora-autoloader-devel
# "zendframework/zend-stdlib": "^2.7 || ^3.0"
Requires: php(language) >= 5.6
%if ! %{bootstrap}
-Requires: php-autoloader(%{gh_owner}/zend-eventmanager) >= 2.6.2
-Requires: php-autoloader(%{gh_owner}/zend-eventmanager) < 4
-Requires: php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7
-Requires: php-autoloader(%{gh_owner}/zend-stdlib) < 4
+Requires: (php-autoloader(%{gh_owner}/zend-eventmanager) >= 2.6.2 with php-autoloader(%{gh_owner}/zend-eventmanager) < 4)
+Requires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7 with php-autoloader(%{gh_owner}/zend-stdlib) < 4)
# From composer, "suggest": {
# "mongodb/mongodb": "If you want to use the MongoDB session save handler"
# "zendframework/zend-cache": "Zend\\Cache component",
@@ -183,6 +179,10 @@ exit $ret
%changelog
+* Fri Feb 23 2018 Remi Collet <remi@remirepo.net> - 2.8.5-1
+- Update to 2.8.5 (no change)
+- use range dependencies
+
* Thu Feb 1 2018 Remi Collet <remi@remirepo.net> - 2.8.4-1
- Update to 2.8.4