summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-09-29 07:43:10 +0200
committerRemi Collet <remi@remirepo.net>2017-09-29 07:43:10 +0200
commit03820074d7eb75dfbcf878455fff51df0b3f20e6 (patch)
tree60aa0d1b41f284ca368f0467b1eb86a60b21f4fb
parente10edf70e32eb7e6774297d8311b1361c580fe3f (diff)
-rw-r--r--.gitignore8
-rw-r--r--composer.json6
-rw-r--r--php-zendframework-zend-servicemanager-di.spec38
3 files changed, 23 insertions, 29 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..fc9aa8c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+clog
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/composer.json b/composer.json
index 606e581..3c3f123 100644
--- a/composer.json
+++ b/composer.json
@@ -14,8 +14,8 @@
"zendframework/zend-servicemanager": "^3.0.3"
},
"require-dev": {
- "squizlabs/php_codesniffer": "^2.3.1",
- "phpunit/phpunit": "^4.5"
+ "phpunit/phpunit": "^4.5",
+ "zendframework/zend-coding-standard": "~1.0.0"
},
"conflict": {
"zendframework/zend-servicemanager": "<3.0"
@@ -45,7 +45,7 @@
"@cs-check",
"@test"
],
- "upload-coverage": "coveralls",
+ "upload-coverage": "coveralls -v",
"cs-check": "phpcs",
"cs-fix": "phpcbf fix -v",
"test": "phpunit",
diff --git a/php-zendframework-zend-servicemanager-di.spec b/php-zendframework-zend-servicemanager-di.spec
index e03349b..eef6714 100644
--- a/php-zendframework-zend-servicemanager-di.spec
+++ b/php-zendframework-zend-servicemanager-di.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit cfd313ed3b3b55532961f1d4e903b0b871de193f
+%global gh_commit 655253928da5ca15d14ce037d8195b1fb594897d
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-servicemanager-di
@@ -20,7 +20,7 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 1.1.0
+Version: 1.1.1
Release: 1%{?dist}
Summary: Zend Framework ServiceManager-%{library} component
@@ -30,7 +30,6 @@ URL: https://zendframework.github.io/%{gh_project}/
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
# Tests
%if %{with_tests}
@@ -40,8 +39,8 @@ BuildRequires: php-composer(%{gh_owner}/zend-di) >= 2.6
BuildRequires: php-composer(%{gh_owner}/zend-servicemanager) >= 3.0.3
BuildRequires: php-spl
# From composer, "require-dev": {
-# "squizlabs/php_codesniffer": "^2.3.1",
-# "phpunit/phpunit": "^4.5"
+# "phpunit/phpunit": "^4.5",
+# "zendframework/zend-coding-standard": "~1.0.0"
BuildRequires: php-composer(phpunit/phpunit) >= 4.0
# Autoloader
BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
@@ -95,8 +94,6 @@ EOF
%install
-rm -rf %{buildroot}
-
mkdir -p %{buildroot}%{php_home}/Zend/ServiceManager
cp -pr src %{buildroot}%{php_home}/Zend/ServiceManager/%{library}
@@ -120,33 +117,19 @@ Zend\Loader\AutoloaderFactory::factory(array(
require_once '%{php_home}/Zend/autoload.php';
EOF
-# remirepo:11
-run=0
ret=0
-if which php56; then
- php56 %{_bindir}/phpunit --include-path=%{buildroot}%{php_home} || ret=1
- run=1
-fi
-if which php71; then
- php70 %{_bindir}/phpunit --include-path=%{buildroot}%{php_home} || ret=1
- run=1
-fi
-if [ $run -eq 0 ]; then
-%{_bindir}/phpunit --include-path=%{buildroot}%{php_home} --verbose
-# remirepo:2
-fi
+for cmd in php php56 php70 php71 php72; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit --include-path=%{buildroot}%{php_home} --verbose || ret=1
+ fi
+done
exit $ret
%else
: Test suite disabled
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md
@@ -156,6 +139,9 @@ rm -rf %{buildroot}
%changelog
+* Fri Sep 29 2017 Remi Collet <remi@remirepo.net> - 1.1.1-1
+- Update to 1.1.1
+
* Wed Jun 29 2016 Remi Collet <remi@fedoraproject.org> - 1.1.0-1
- update to 1.1.0 for ZendFramework 3