summaryrefslogtreecommitdiffstats
path: root/php-zendframework-zend-server.spec
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-01-28 09:04:31 +0100
committerRemi Collet <fedora@famillecollet.com>2016-01-28 09:04:31 +0100
commit433a1de4cbafc346ec0f0f8de9af8dfc9091552b (patch)
treeadf5c04d85ee6cf0b0cffa94aa7acb035e15d92c /php-zendframework-zend-server.spec
parent4165729115109e3d712cfea1f9c49d72fd30519f (diff)
php-zendframework-zend-server: 2.6.0
Diffstat (limited to 'php-zendframework-zend-server.spec')
-rw-r--r--php-zendframework-zend-server.spec26
1 files changed, 15 insertions, 11 deletions
diff --git a/php-zendframework-zend-server.spec b/php-zendframework-zend-server.spec
index 19cc9c5..1be5918 100644
--- a/php-zendframework-zend-server.spec
+++ b/php-zendframework-zend-server.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 560289d8e760d3783238644da83eebdff53be2c7
+%global gh_commit 5c62e2c1ac21d1174a25ac63182659365fe73fbb
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-server
@@ -20,7 +20,7 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.5.1
+Version: 2.6.0
Release: 1%{?dist}
Summary: Zend Framework %{library} component
@@ -34,7 +34,7 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.3.23
+BuildRequires: php(language) >= 5.6
BuildRequires: php-pcre
BuildRequires: php-spl
BuildRequires: php-reflection
@@ -49,17 +49,17 @@ BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
%endif
# From composer, "require": {
-# "php": ">=5.3.23",
+# "php": "^5.5 || ^7.0",
# "zendframework/zend-stdlib": "~2.5",
# "zendframework/zend-code": "~2.5"
-Requires: php(language) >= 5.3.23
+Requires: php(language) >= 5.5
%if ! %{bootstrap}
Requires: php-composer(%{gh_owner}/zend-stdlib) >= 2.5
Requires: php-composer(%{gh_owner}/zend-stdlib) < 3
Requires: php-composer(%{gh_owner}/zend-code) >= 2.5
Requires: php-composer(%{gh_owner}/zend-code) < 3
%endif
-# From phpcompatinfo report for version 2.5.1
+# From phpcompatinfo report for version 2.6.0
Requires: php-pcre
Requires: php-reflection
Requires: php-spl
@@ -95,14 +95,14 @@ cp -pr src %{buildroot}%{php_home}/Zend/%{library}
%check
%if %{with_tests}
mkdir vendor
-cat << EOF | tee vendor/autoload.php
+cat << 'EOF' | tee vendor/autoload.php
<?php
require_once '%{php_home}/Zend/Loader/AutoloaderFactory.php';
-Zend\\Loader\\AutoloaderFactory::factory(array(
- 'Zend\\Loader\\StandardAutoloader' => array(
+Zend\Loader\AutoloaderFactory::factory(array(
+ 'Zend\Loader\StandardAutoloader' => array(
'namespaces' => array(
- 'ZendTest\\\\%{library}' => dirname(__DIR__).'/test/',
- 'Zend\\\\%{library}' => '%{buildroot}%{php_home}/Zend/%{library}'
+ 'ZendTest\\%{library}' => dirname(__DIR__).'/test/',
+ 'Zend\\%{library}' => '%{buildroot}%{php_home}/Zend/%{library}'
))));
require_once '%{php_home}/Zend/autoload.php';
EOF
@@ -131,5 +131,9 @@ rm -rf %{buildroot}
%changelog
+* Thu Jan 28 2016 Remi Collet <remi@fedoraproject.org> - 2.6.0-1
+- update to 2.6.0
+- raise minimal php version to 5.5
+
* Tue Aug 4 2015 Remi Collet <remi@fedoraproject.org> - 2.5.1-1
- initial package \ No newline at end of file