summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-12-05 16:00:49 +0100
committerRemi Collet <remi@remirepo.net>2017-12-05 16:00:49 +0100
commit88bf1e22d73ac2be17346ee39265fd9ae8165dab (patch)
tree1d2e2e4ce0d49b16a7557f6ce16d0a35471bdd3c
parent909756663c9804ecfe290c1308b482712436d342 (diff)
cleanup
-rw-r--r--.gitignore8
-rw-r--r--php-zendframework-zend-server.spec20
2 files changed, 15 insertions, 13 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..fc9aa8c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+clog
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/php-zendframework-zend-server.spec b/php-zendframework-zend-server.spec
index f2153e9..cc3f284 100644
--- a/php-zendframework-zend-server.spec
+++ b/php-zendframework-zend-server.spec
@@ -30,7 +30,6 @@ URL: https://zendframework.github.io/%{gh_project}/
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
# Tests
%if %{with_tests}
@@ -90,8 +89,6 @@ mv LICENSE.md LICENSE
%install
-rm -rf %{buildroot}
-
mkdir -p %{buildroot}%{php_home}/Zend/
cp -pr src %{buildroot}%{php_home}/Zend/%{library}
@@ -112,22 +109,19 @@ require_once '%{php_home}/Zend/autoload.php';
require_once 'test/TestAsset/reflectionTestFunction.php';
EOF
-%{_bindir}/phpunit --include-path=%{buildroot}%{php_home}
-
-if which php71; then
- php71 %{_bindir}/phpunit --include-path=%{buildroot}%{php_home}
-fi
+ret=0
+for cmd in php php56 php70 php71 php72; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit --verbose || ret=1
+ fi
+done
+exit $ret
%else
: Test suite disabled
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md