summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-06-21 08:29:58 +0200
committerRemi Collet <fedora@famillecollet.com>2016-06-21 08:29:58 +0200
commit030a86e95dda3c730e0c6e2ed75c6b7ff707692d (patch)
tree725162e1d7ff0519cfc7cb905f3ee02c51742a76
parent0d426d8bba9d36e6d8a8a6fc4bcd3fc8fef6cccd (diff)
php-zendframework-zend-server: 2.7.0
-rw-r--r--composer.json38
-rw-r--r--php-zendframework-zend-server.spec29
2 files changed, 55 insertions, 12 deletions
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..34058fd
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,38 @@
+{
+ "name": "zendframework/zend-server",
+ "description": " ",
+ "license": "BSD-3-Clause",
+ "keywords": [
+ "zf2",
+ "server"
+ ],
+ "homepage": "https://github.com/zendframework/zend-server",
+ "extra": {
+ "branch-alias": {
+ "dev-master": "2.7-dev",
+ "dev-develop": "2.8-dev"
+ }
+ },
+ "require": {
+ "php": "^5.6 || ^7.0",
+ "zendframework/zend-stdlib": "^2.5 || ^3.0",
+ "zendframework/zend-code": "^2.5 || ^3.0"
+ },
+ "require-dev": {
+ "phpunit/phpUnit": "^4.8",
+ "squizlabs/php_codesniffer": "^2.3.1"
+ },
+ "autoload": {
+ "psr-4": {
+ "Zend\\Server\\": "src/"
+ }
+ },
+ "autoload-dev": {
+ "psr-4": {
+ "ZendTest\\Server\\": "test/"
+ },
+ "files": [
+ "test/TestAsset/reflectionTestFunction.php"
+ ]
+ }
+}
diff --git a/php-zendframework-zend-server.spec b/php-zendframework-zend-server.spec
index 5901e0d..388af88 100644
--- a/php-zendframework-zend-server.spec
+++ b/php-zendframework-zend-server.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit d70b5e345a531a6b5138418cd6e9a13036d8f3da
+%global gh_commit 7cb617ca3e9b24579f544a244ee79ae61f480914
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-server
@@ -20,7 +20,7 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.6.1
+Version: 2.7.0
Release: 1%{?dist}
Summary: Zend Framework %{library} component
@@ -34,30 +34,30 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.5
+BuildRequires: php(language) >= 5.6
BuildRequires: php-pcre
BuildRequires: php-spl
BuildRequires: php-reflection
BuildRequires: php-composer(%{gh_owner}/zend-stdlib) >= 2.5
BuildRequires: php-composer(%{gh_owner}/zend-code) >= 2.5
# From composer, "require-dev": {
-# "fabpot/php-cs-fixer": "1.7.*",
-# "phpunit/PHPUnit": "~4.0"
-BuildRequires: php-composer(phpunit/phpunit) >= 4.0
+# "phpunit/phpUnit": "^4.8",
+# "squizlabs/php_codesniffer": "^2.3.1"
+BuildRequires: php-composer(phpunit/phpunit) >= 4.8
# Autoloader
BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
%endif
# From composer, "require": {
-# "php": "^5.5 || ^7.0",
+# "php": "^5.6 || ^7.0",
# "zendframework/zend-stdlib": "^2.5 || ^3.0",
-# "zendframework/zend-code": "~2.5"
-Requires: php(language) >= 5.5
+# "zendframework/zend-code": "^2.5 || ^3.0"
+Requires: php(language) >= 5.6
%if ! %{bootstrap}
Requires: php-composer(%{gh_owner}/zend-stdlib) >= 2.5
Requires: php-composer(%{gh_owner}/zend-stdlib) < 4
Requires: php-composer(%{gh_owner}/zend-code) >= 2.5
-Requires: php-composer(%{gh_owner}/zend-code) < 3
+Requires: php-composer(%{gh_owner}/zend-code) < 4
%endif
# From phpcompatinfo report for version 2.6.0
Requires: php-pcre
@@ -105,12 +105,13 @@ Zend\Loader\AutoloaderFactory::factory(array(
'Zend\\%{library}' => '%{buildroot}%{php_home}/Zend/%{library}'
))));
require_once '%{php_home}/Zend/autoload.php';
+require_once 'test/TestAsset/reflectionTestFunction.php';
EOF
%{_bindir}/phpunit --include-path=%{buildroot}%{php_home}
-if which php70; then
- php70 %{_bindir}/phpunit --include-path=%{buildroot}%{php_home}
+if which php71; then
+ php71 %{_bindir}/phpunit --include-path=%{buildroot}%{php_home}
fi
%else
: Test suite disabled
@@ -131,6 +132,10 @@ rm -rf %{buildroot}
%changelog
+* Tue Jun 21 2016 Remi Collet <remi@fedoraproject.org> - 2.7.0-1
+- update to 2.7.0
+- raise dependency on PHP 5.6
+
* Fri Feb 5 2016 Remi Collet <remi@fedoraproject.org> - 2.6.1-1
- update to 2.6.1