summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-05-03 09:51:38 +0200
committerRemi Collet <remi@remirepo.net>2018-05-03 09:51:38 +0200
commita3da82b2b6f6dc463cb01e001cb87e8caef537ab (patch)
treee5d30bd271e3578fd4c490f5bcf371c8cccbf444
parent88bf1e22d73ac2be17346ee39265fd9ae8165dab (diff)
-rw-r--r--composer.json45
-rw-r--r--php-zendframework-zend-server.spec17
2 files changed, 43 insertions, 19 deletions
diff --git a/composer.json b/composer.json
index 34058fd..dd5d1ad 100644
--- a/composer.json
+++ b/composer.json
@@ -1,26 +1,28 @@
{
"name": "zendframework/zend-server",
- "description": " ",
+ "description": "Create Reflection-based RPC servers",
"license": "BSD-3-Clause",
"keywords": [
- "zf2",
+ "zf",
+ "zendframework",
"server"
],
- "homepage": "https://github.com/zendframework/zend-server",
- "extra": {
- "branch-alias": {
- "dev-master": "2.7-dev",
- "dev-develop": "2.8-dev"
- }
+ "support": {
+ "docs": "https://docs.zendframework.com/zend-server/",
+ "issues": "https://github.com/zendframework/zend-server/issues",
+ "source": "https://github.com/zendframework/zend-server",
+ "rss": "https://github.com/zendframework/zend-server/releases.atom",
+ "chat": "https://zendframework-slack.herokuapp.com",
+ "forum": "https://discourse.zendframework.com/c/questions/components"
},
"require": {
"php": "^5.6 || ^7.0",
- "zendframework/zend-stdlib": "^2.5 || ^3.0",
- "zendframework/zend-code": "^2.5 || ^3.0"
+ "zendframework/zend-code": "^2.5 || ^3.0",
+ "zendframework/zend-stdlib": "^2.5 || ^3.0"
},
"require-dev": {
- "phpunit/phpUnit": "^4.8",
- "squizlabs/php_codesniffer": "^2.3.1"
+ "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.4",
+ "zendframework/zend-coding-standard": "~1.0.0"
},
"autoload": {
"psr-4": {
@@ -34,5 +36,24 @@
"files": [
"test/TestAsset/reflectionTestFunction.php"
]
+ },
+ "config": {
+ "sort-packages": true
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "2.8.x-dev",
+ "dev-develop": "2.9.x-dev"
+ }
+ },
+ "scripts": {
+ "check": [
+ "@cs-check",
+ "@test"
+ ],
+ "cs-check": "phpcs",
+ "cs-fix": "phpcbf",
+ "test": "phpunit --colors=always",
+ "test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
}
}
diff --git a/php-zendframework-zend-server.spec b/php-zendframework-zend-server.spec
index cc3f284..886e37e 100644
--- a/php-zendframework-zend-server.spec
+++ b/php-zendframework-zend-server.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 7cb617ca3e9b24579f544a244ee79ae61f480914
+%global gh_commit 23a2e9a5599c83c05da831cb7c649e8a7809595e
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-server
@@ -20,7 +20,7 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.7.0
+Version: 2.8.0
Release: 1%{?dist}
Summary: Zend Framework %{library} component
@@ -40,17 +40,17 @@ BuildRequires: php-reflection
BuildRequires: php-composer(%{gh_owner}/zend-stdlib) >= 2.5
BuildRequires: php-composer(%{gh_owner}/zend-code) >= 2.5
# From composer, "require-dev": {
-# "phpunit/phpUnit": "^4.8",
-# "squizlabs/php_codesniffer": "^2.3.1"
-BuildRequires: php-composer(phpunit/phpunit) >= 4.8
+# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.4",
+# "zendframework/zend-coding-standard": "~1.0.0"
+BuildRequires: php-composer(phpunit/phpunit) >= 5.7.27
# Autoloader
BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
%endif
# From composer, "require": {
# "php": "^5.6 || ^7.0",
-# "zendframework/zend-stdlib": "^2.5 || ^3.0",
# "zendframework/zend-code": "^2.5 || ^3.0"
+# "zendframework/zend-stdlib": "^2.5 || ^3.0",
Requires: php(language) >= 5.6
%if ! %{bootstrap}
Requires: php-composer(%{gh_owner}/zend-stdlib) >= 2.5
@@ -110,7 +110,7 @@ require_once 'test/TestAsset/reflectionTestFunction.php';
EOF
ret=0
-for cmd in php php56 php70 php71 php72; do
+for cmd in php php71 php72; do
if which $cmd; then
$cmd %{_bindir}/phpunit --verbose || ret=1
fi
@@ -130,6 +130,9 @@ exit $ret
%changelog
+* Thu May 3 2018 Remi Collet <remi@remirepo.net> - 2.8.0-1
+- update to 2.8.0
+
* Tue Jun 21 2016 Remi Collet <remi@fedoraproject.org> - 2.7.0-1
- update to 2.7.0
- raise dependency on PHP 5.6