summaryrefslogtreecommitdiffstats
path: root/php-zendframework-zend-serializer.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-05-15 08:19:41 +0200
committerRemi Collet <remi@remirepo.net>2018-05-15 08:19:41 +0200
commite731a9da5ba88697dc6773e8485852ba777afbda (patch)
treee8dd75f9ce8975bdb817c3b77196fb826f4413b1 /php-zendframework-zend-serializer.spec
parentfee6c2f78150bd5fd9fabb9eb580c67a027f9863 (diff)
update to 2.9.0
use range dependencies on F27+ switch to phpunit6
Diffstat (limited to 'php-zendframework-zend-serializer.spec')
-rw-r--r--php-zendframework-zend-serializer.spec64
1 files changed, 43 insertions, 21 deletions
diff --git a/php-zendframework-zend-serializer.spec b/php-zendframework-zend-serializer.spec
index e3f5fb8..a761f5a 100644
--- a/php-zendframework-zend-serializer.spec
+++ b/php-zendframework-zend-serializer.spec
@@ -1,13 +1,13 @@
# remirepo/Fedora spec file for php-zendframework-zend-serializer
#
-# Copyright (c) 2015-2017 Remi Collet
+# Copyright (c) 2015-2018 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 7ac42b9a47e9cb23895173a3096bc3b3fb7ac580
+%global gh_commit 0172690db48d8935edaf625c4cba38b79719892c
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-serializer
@@ -20,7 +20,7 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.8.1
+Version: 2.9.0
Release: 2%{?dist}
Summary: Zend Framework %{library} component
@@ -32,7 +32,7 @@ Source1: makesrc.sh
# remirepo:3
# For test build on all available arch
-#global debug_package %{nil}
+#global debug_package %%{nil}
#global __debug_install_post /bin/true
BuildArch: noarch
# Tests
@@ -43,41 +43,58 @@ BuildRequires: php-libxml
BuildRequires: php-pcre
BuildRequires: php-simplexml
BuildRequires: php-spl
-BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7
-BuildRequires: php-autoloader(%{gh_owner}/zend-json) >= 2.5
# From composer, "require-dev": {
-# "zendframework/zend-math": "^2.6",
-# "zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3",
-# "phpunit/phpunit": "^5.5",
+# "phpunit/phpunit": "^5.7.25 || ^6.4.4",
# "zendframework/zend-coding-standard": "~1.0.0",
-# "doctrine/instantiator": "1.0.*"
+# "zendframework/zend-math": "^2.6 || ^3.0",
+# "zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3"
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7 with php-autoloader(%{gh_owner}/zend-stdlib) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-json) >= 2.5 with php-autoloader(%{gh_owner}/zend-json) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-math) >= 2.6 with php-autoloader(%{gh_owner}/zend-math) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-servicemanager) >= 2.7.5 with php-autoloader(%{gh_owner}/zend-servicemanager) < 4)
+# remirepo:10
+%else
+BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) < 4
+BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7
+BuildRequires: php-autoloader(%{gh_owner}/zend-json) < 4
+BuildRequires: php-autoloader(%{gh_owner}/zend-json) >= 2.5
+BuildRequires: php-autoloader(%{gh_owner}/zend-math) < 4
BuildRequires: php-autoloader(%{gh_owner}/zend-math) >= 2.6
+BuildRequires: php-autoloader(%{gh_owner}/zend-servicemanager) < 4
BuildRequires: php-autoloader(%{gh_owner}/zend-servicemanager) >= 2.7.5
-BuildRequires: php-composer(phpunit/phpunit) >= 5.5
+%endif
+BuildRequires: phpunit6 >= 6.4.4
+%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
-%endif
# From composer, "require": {
# "php": "^5.6 || ^7.0",
-# "zendframework/zend-stdlib": "^2.7 || ^3.0",
# "zendframework/zend-json": "^2.5 || ^3.0"
+# "zendframework/zend-stdlib": "^2.7 || ^3.0",
Requires: php(language) >= 5.6
%if ! %{bootstrap}
-Requires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7
-Requires: php-composer(%{gh_owner}/zend-stdlib) < 4
-Requires: php-composer(%{gh_owner}/zend-json) >= 2.5
-Requires: php-composer(%{gh_owner}/zend-json) < 4
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Requires: (php-autoloader(%{gh_owner}/zend-json) >= 2.5 with php-autoloader(%{gh_owner}/zend-json) < 4)
+Requires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7 with php-autoloader(%{gh_owner}/zend-stdlib) < 4)
+# remirepo:6
+%else
+Requires: php-autoloader(%{gh_owner}/zend-json) < 4
+Requires: php-autoloader(%{gh_owner}/zend-json) >= 2.5
+Requires: php-autoloader(%{gh_owner}/zend-stdlib) < 4
+Requires: php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7
+%endif
# From composer, "suggest": {
# "zendframework/zend-math": "(^2.6 || ^3.0) To support Python Pickle serialization",
# "zendframework/zend-servicemanager": "(^2.7.5 || ^3.0.3) To support plugin manager support"
-%if 0%{?fedora} >= 21
Suggests: php-composer(%{gh_owner}/zend-math)
Suggests: php-composer(%{gh_owner}/zend-servicemanager)
Suggests: php-pecl(igbinary)
Suggests: php-pecl(msgpack)
%endif
-%endif
# From phpcompatinfo report for version 2.5.1
Requires: php-dom
Requires: php-libxml
@@ -136,9 +153,9 @@ require_once '%{buildroot}%{php_home}/Zend/%{library}/autoload.php';
EOF
ret=0
-for cmd in php php56 php70 php71 php72; do
+for cmd in php php70 php71 php72; do
if which $cmd; then
- $cmd %{_bindir}/phpunit --verbose || ret=1
+ $cmd %{_bindir}/phpunit6 --verbose || ret=1
fi
done
exit $ret
@@ -156,6 +173,11 @@ exit $ret
%changelog
+* Tue May 15 2018 Remi Collet <remi@remirepo.net> - 2.9.0-2
+- update to 2.9.0
+- use range dependencies on F27+
+- switch to phpunit6
+
* Thu Nov 23 2017 Remi Collet <remi@remirepo.net> - 2.8.1-2
- switch from zend-loader to fedora/autoloader