summaryrefslogtreecommitdiffstats
path: root/php-zendframework-zend-serializer.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-11-08 08:17:24 +0100
committerRemi Collet <remi@remirepo.net>2017-11-08 08:17:24 +0100
commit7661d1937ceb47cdc8486276c29a53b02e467042 (patch)
tree36a06f833a82434760e7801b124c49f7ba41caeb /php-zendframework-zend-serializer.spec
parentb3334fd9bc910b3411d0129fc0a62cac0eed5920 (diff)
test build
Diffstat (limited to 'php-zendframework-zend-serializer.spec')
-rw-r--r--php-zendframework-zend-serializer.spec32
1 files changed, 18 insertions, 14 deletions
diff --git a/php-zendframework-zend-serializer.spec b/php-zendframework-zend-serializer.spec
index d0a85a7..32799ed 100644
--- a/php-zendframework-zend-serializer.spec
+++ b/php-zendframework-zend-serializer.spec
@@ -19,9 +19,12 @@
%global with_tests 0%{!?_without_tests:1}
%endif
+#global debug_package %{nil}
+#global __debug_install_post /bin/true
+
Name: php-%{gh_owner}-%{gh_project}
Version: 2.8.0
-Release: 1%{?dist}
+Release: 4%{?dist}
Summary: Zend Framework %{library} component
Group: Development/Libraries
@@ -30,7 +33,8 @@ URL: https://zendframework.github.io/%{gh_project}/
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
+Patch0: https://patch-diff.githubusercontent.com/raw/zendframework/zend-serializer/pull/31.patch
+
BuildArch: noarch
# Tests
%if %{with_tests}
@@ -96,6 +100,7 @@ Documentation: https://zendframework.github.io/%{gh_project}/
%prep
%setup -q -n %{gh_project}-%{gh_commit}
+%patch0 -p1
mv LICENSE.md LICENSE
@@ -105,8 +110,6 @@ mv LICENSE.md LICENSE
%install
-rm -rf %{buildroot}
-
mkdir -p %{buildroot}%{php_home}/Zend/
cp -pr src %{buildroot}%{php_home}/Zend/%{library}
@@ -126,22 +129,19 @@ Zend\Loader\AutoloaderFactory::factory(array(
require_once '%{php_home}/Zend/autoload.php';
EOF
-%{_bindir}/phpunit --include-path=%{buildroot}%{php_home}
-
-if which php70; then
- php70 %{_bindir}/phpunit --include-path=%{buildroot}%{php_home} || :
-fi
+ret=0
+for cmd in php php56 php70 php71 php72; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit || ret=1
+ fi
+done
+exit $ret
%else
: Test suite disabled
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md
@@ -150,6 +150,10 @@ rm -rf %{buildroot}
%changelog
+* Wed Nov 8 2017 Remi Collet <remi@fedoraproject.org> - 2.8.0-4
+- test build: fix FTBFS from Koschei, add patch for bigendian from
+ https://github.com/zendframework/zend-serializer/pull/31
+
* Tue Jun 21 2016 Remi Collet <remi@fedoraproject.org> - 2.8.0-1
- update to 2.8.0
- raise dependency on PHP 5.6