summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-05-11 19:51:55 +0200
committerRemi Collet <fedora@famillecollet.com>2016-05-11 19:51:55 +0200
commit5c00d44694a09bb47798523590c9864a6e071a1b (patch)
tree1ac492f4835267f4a673529d1f22d4f65cfa496e
parent59144900358784237e0183ed198459367d5f888a (diff)
php-zendframework-zend-serializer: 2.7.2
-rw-r--r--composer.json5
-rw-r--r--php-zendframework-zend-serializer.spec17
2 files changed, 13 insertions, 9 deletions
diff --git a/composer.json b/composer.json
index 97741b0..2f9fe0b 100644
--- a/composer.json
+++ b/composer.json
@@ -15,15 +15,16 @@
"require": {
"php": "^5.5 || ^7.0",
"zendframework/zend-stdlib": "^2.7 || ^3.0",
- "zendframework/zend-json": "^2.5",
- "zendframework/zend-math": "^2.6"
+ "zendframework/zend-json": "^2.5"
},
"require-dev": {
+ "zendframework/zend-math": "^2.6",
"zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3",
"fabpot/php-cs-fixer": "1.7.*",
"phpunit/phpunit": "^4.5"
},
"suggest": {
+ "zendframework/zend-math": "(^2.6) To support Python Pickle serialization",
"zendframework/zend-servicemanager": "To support plugin manager support"
},
"minimum-stability": "dev",
diff --git a/php-zendframework-zend-serializer.spec b/php-zendframework-zend-serializer.spec
index 74ecef0..2adc8d2 100644
--- a/php-zendframework-zend-serializer.spec
+++ b/php-zendframework-zend-serializer.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 8b6ff840e19b5dd8eca40e20d635ff407053f7d8
+%global gh_commit 95385c2342fc335d5164eb95ac3ca230aa51223b
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-serializer
@@ -20,7 +20,7 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.7.1
+Version: 2.7.2
Release: 1%{?dist}
Summary: Zend Framework %{library} component
@@ -42,11 +42,12 @@ BuildRequires: php-simplexml
BuildRequires: php-spl
BuildRequires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7
BuildRequires: php-composer(%{gh_owner}/zend-json) >= 2.5
-BuildRequires: php-composer(%{gh_owner}/zend-math) >= 2.5
# From composer, "require-dev": {
+# "zendframework/zend-math": "^2.6",
# "zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3",
# "fabpot/php-cs-fixer": "1.7.*",
# "phpunit/PHPUnit": "^4.5"
+BuildRequires: php-composer(%{gh_owner}/zend-math) >= 2.6
BuildRequires: php-composer(%{gh_owner}/zend-servicemanager) >= 2.7.5
BuildRequires: php-composer(phpunit/phpunit) >= 4.5
# Autoloader
@@ -56,19 +57,17 @@ BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
# From composer, "require": {
# "php": "^5.5 || ^7.0",
# "zendframework/zend-stdlib": "^2.7 || ^3.0",
-# "zendframework/zend-json": "^2.5",
-# "zendframework/zend-math": "^2.6"
+# "zendframework/zend-json": "^2.5"
Requires: php(language) >= 5.5
%if ! %{bootstrap}
Requires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7
Requires: php-composer(%{gh_owner}/zend-stdlib) < 4
Requires: php-composer(%{gh_owner}/zend-json) >= 2.5
Requires: php-composer(%{gh_owner}/zend-json) < 3
-Requires: php-composer(%{gh_owner}/zend-math) >= 2.6
-Requires: php-composer(%{gh_owner}/zend-math) < 3
# From composer, "suggest": {
# "zendframework/zend-servicemanager": "To support plugin manager support"
%if 0%{?fedora} >= 21
+Suggests: php-composer(%{gh_owner}/zend-math)
Suggests: php-composer(%{gh_owner}/zend-servicemanager)
Suggests: php-pecl(igbinary)
Suggests: php-pecl(msgpack)
@@ -146,6 +145,10 @@ rm -rf %{buildroot}
%changelog
+* Wed May 11 2016 Remi Collet <remi@fedoraproject.org> - 2.7.2-1
+- update to 2.7.2
+- dependency to zend-math is now optional
+
* Tue Apr 19 2016 Remi Collet <remi@fedoraproject.org> - 2.7.1-1
- update to 2.7.1