summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-02-04 10:10:33 +0100
committerRemi Collet <fedora@famillecollet.com>2016-02-04 10:10:33 +0100
commit39f7ae42677b487b94a513b01bd444b5e1dda598 (patch)
tree0b3385a838b2e0bafdc412670ba84344a301d53f
parenta86ceed86830ec3a62ae244cdfdc7fc5560ff853 (diff)
php-zendframework-zend-serializer: 2.6.1
-rw-r--r--php-zendframework-zend-serializer.spec52
1 files changed, 31 insertions, 21 deletions
diff --git a/php-zendframework-zend-serializer.spec b/php-zendframework-zend-serializer.spec
index 116e251..dcbca0d 100644
--- a/php-zendframework-zend-serializer.spec
+++ b/php-zendframework-zend-serializer.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit b7208eb17dc4a4fb3a660b85e6c4af035eeed40c
+%global gh_commit 0d9556cb75045481de1869fd1962cacdaca7ef88
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-serializer
@@ -20,7 +20,7 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.5.1
+Version: 2.6.1
Release: 1%{?dist}
Summary: Zend Framework %{library} component
@@ -34,38 +34,38 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.3.23
+BuildRequires: php(language) >= 5.5
BuildRequires: php-dom
BuildRequires: php-libxml
BuildRequires: php-pcre
BuildRequires: php-simplexml
BuildRequires: php-spl
-BuildRequires: php-composer(%{gh_owner}/zend-stdlib) >= 2.5
+BuildRequires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7
BuildRequires: php-composer(%{gh_owner}/zend-json) >= 2.5
BuildRequires: php-composer(%{gh_owner}/zend-math) >= 2.5
# From composer, "require-dev": {
-# "zendframework/zend-servicemanager": "~2.5",
+# "zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3",
# "fabpot/php-cs-fixer": "1.7.*",
# "phpunit/PHPUnit": "~4.0"
-BuildRequires: php-composer(%{gh_owner}/zend-servicemanager) >= 2.5
+BuildRequires: php-composer(%{gh_owner}/zend-servicemanager) >= 2.7.5
BuildRequires: php-composer(phpunit/phpunit) >= 4.0
# Autoloader
BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
%endif
# From composer, "require": {
-# "php": ">=5.3.23",
-# "zendframework/zend-stdlib": "~2.5",
+# "php": "^5.5 || ^7.0",
+# "zendframework/zend-stdlib": "~2.7",
# "zendframework/zend-json": "~2.5",
-# "zendframework/zend-math": "~2.5"
-Requires: php(language) >= 5.3.23
+# "zendframework/zend-math": "~2.6"
+Requires: php(language) >= 5.5
%if ! %{bootstrap}
-Requires: php-composer(%{gh_owner}/zend-stdlib) >= 2.5
+Requires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7
Requires: php-composer(%{gh_owner}/zend-stdlib) < 3
Requires: php-composer(%{gh_owner}/zend-json) >= 2.5
-Requires: php-composer(%{gh_owner}/zend-json) < 4
-Requires: php-composer(%{gh_owner}/zend-math) >= 2.5
-Requires: php-composer(%{gh_owner}/zend-math) < 4
+Requires: php-composer(%{gh_owner}/zend-json) < 3
+Requires: php-composer(%{gh_owner}/zend-math) >= 2.6
+Requires: php-composer(%{gh_owner}/zend-math) < 3
# From composer, "suggest": {
# "zendframework/zend-servicemanager": "To support plugin manager support"
%if 0%{?fedora} >= 21
@@ -110,14 +110,14 @@ cp -pr src %{buildroot}%{php_home}/Zend/%{library}
%check
%if %{with_tests}
mkdir vendor
-cat << EOF | tee vendor/autoload.php
+cat << 'EOF' | tee vendor/autoload.php
<?php
require_once '%{php_home}/Zend/Loader/AutoloaderFactory.php';
-Zend\\Loader\\AutoloaderFactory::factory(array(
- 'Zend\\Loader\\StandardAutoloader' => array(
+Zend\Loader\AutoloaderFactory::factory(array(
+ 'Zend\Loader\StandardAutoloader' => array(
'namespaces' => array(
- 'ZendTest\\\\%{library}' => dirname(__DIR__).'/test/',
- 'Zend\\\\%{library}' => '%{buildroot}%{php_home}/Zend/%{library}'
+ 'ZendTest\\%{library}' => dirname(__DIR__).'/test/',
+ 'Zend\\%{library}' => '%{buildroot}%{php_home}/Zend/%{library}'
))));
require_once '%{php_home}/Zend/autoload.php';
EOF
@@ -125,7 +125,7 @@ EOF
%{_bindir}/phpunit --include-path=%{buildroot}%{php_home}
if which php70; then
- php70 %{_bindir}/phpunit --include-path=%{buildroot}%{php_home}
+ php70 %{_bindir}/phpunit --include-path=%{buildroot}%{php_home} || :
fi
%else
: Test suite disabled
@@ -146,5 +146,15 @@ rm -rf %{buildroot}
%changelog
+* Thu Feb 4 2016 Remi Collet <remi@fedoraproject.org> - 2.6.1-1
+- update to 2.6.1
+
+* Wed Feb 3 2016 Remi Collet <remi@fedoraproject.org> - 2.6.0-1
+- update to 2.6.0
+- raise dependency on PHP >= 5.5
+- raise dependency on zend-stdlib ~2.7
+- raise dependency on zend-math ~2.6
+- raise dependency on zend-servicemanager ~2.7.5
+
* Tue Aug 4 2015 Remi Collet <remi@fedoraproject.org> - 2.5.1-1
-- initial package \ No newline at end of file
+- initial package