summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json53
-rw-r--r--php-zendframework-zend-psr7bridge.spec62
-rw-r--r--test.patch24
3 files changed, 106 insertions, 33 deletions
diff --git a/composer.json b/composer.json
index f7ffa72..4a88bdc 100644
--- a/composer.json
+++ b/composer.json
@@ -1,33 +1,35 @@
{
"name": "zendframework/zend-psr7bridge",
- "description": "PSR-7 <-> Zend\\Http bridge",
- "type": "library",
+ "description": "PSR-7 &lt;-&gt; zend-http message conversions",
"license": "BSD-3-Clause",
"keywords": [
+ "zf",
"http",
"psr",
- "psr-7"
+ "psr-7",
+ "zend",
+ "zendframework"
],
- "homepage": "https://github.com/zendframework/zend-psr7bridge",
"support": {
+ "docs": "https://docs.zendframework.com/zend-psr7bridge/",
"issues": "https://github.com/zendframework/zend-psr7bridge/issues",
- "source": "https://github.com/zendframework/zend-psr7bridge"
- },
- "extra": {
- "branch-alias": {
- "dev-master": "1.0-dev",
- "dev-develop": "1.1-dev"
- }
+ "source": "https://github.com/zendframework/zend-psr7bridge",
+ "rss": "https://github.com/zendframework/zend-psr7bridge/releases.atom",
+ "slack": "https://zendframework-slack.herokuapp.com",
+ "forum": "https://discourse.zendframework.com/c/questions/components"
},
"require": {
- "php": ">=5.5",
- "zendframework/zend-http": "^2.5",
+ "php": "^5.6 || ^7.0",
"psr/http-message": "^1.0",
- "zendframework/zend-diactoros": "^1.1"
+ "zendframework/zend-diactoros": "^1.7 || ^2.0",
+ "zendframework/zend-http": "^2.7"
},
"require-dev": {
- "phpunit/phpunit": "^4.7",
- "squizlabs/php_codesniffer": "^2.3"
+ "phpunit/phpunit": "^5.7.15 || ^6.5.6",
+ "zendframework/zend-coding-standard": "~1.0.0"
+ },
+ "conflict": {
+ "zendframework/zend-stdlib": "< 3.2.1"
},
"autoload": {
"psr-4": {
@@ -38,5 +40,24 @@
"psr-4": {
"ZendTest\\Psr7Bridge\\": "test/"
}
+ },
+ "config": {
+ "sort-packages": true
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "1.2.x-dev",
+ "dev-develop": "1.3.x-dev"
+ }
+ },
+ "scripts": {
+ "check": [
+ "@cs-check",
+ "@test"
+ ],
+ "cs-check": "phpcs",
+ "cs-fix": "phpcbf",
+ "test": "phpunit --colors=always",
+ "test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
}
}
diff --git a/php-zendframework-zend-psr7bridge.spec b/php-zendframework-zend-psr7bridge.spec
index 7377005..29963fa 100644
--- a/php-zendframework-zend-psr7bridge.spec
+++ b/php-zendframework-zend-psr7bridge.spec
@@ -1,13 +1,13 @@
# remirepo/Fedora spec file for php-zendframework-zend-psr7bridge
#
-# Copyright (c) 2016-2017 Remi Collet
+# Copyright (c) 2016-2020 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 86c0b53b0c6381391c4add4a93a56e51d5c74605
+%global gh_commit 99c558f96be01d535fc9692250312342d76d4098
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-psr7bridge
@@ -20,27 +20,37 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 0.2.2
-Release: 4%{?dist}
+Version: 1.2.0
+Release: 1%{?dist}
Summary: Zend Framework %{library} component
-Group: Development/Libraries
License: BSD
URL: https://zendframework.github.io/%{gh_project}/
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
+# Need investigation
+Patch0: test.patch
+
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.5
+BuildRequires: php(language) >= 5.6
BuildRequires: php-reflection
BuildRequires: php-intl
BuildRequires: php-pcre
BuildRequires: php-spl
-BuildRequires: php-autoloader(%{gh_owner}/zend-http) >= 2.5
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (php-composer(psr/http-message) >= 1.0 with php-composer(psr/http-message) < 2)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-diactoros) >= 1.7 with php-autoloader(%{gh_owner}/zend-diactoros) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-http) >= 2.7 with php-autoloader(%{gh_owner}/zend-http) < 3)
+# remirepo:5
+%else
BuildRequires: php-composer(psr/http-message) >= 1.0
-BuildRequires: php-autoloader(%{gh_owner}/zend-diactoros) >= 1.1
+BuildRequires: php-autoloader(%{gh_owner}/zend-diactoros) >= 1.7
+BuildRequires: php-autoloader(%{gh_owner}/zend-http) >= 2.7
+%endif
# From composer, "require-dev": {
# "phpunit/phpunit": "^4.7",
# "squizlabs/php_codesniffer": "^2.3"
@@ -50,18 +60,26 @@ BuildRequires: php-composer(phpunit/phpunit) >= 4.7
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": ">=5.5",
-# "zendframework/zend-http": "^2.5",
+# "php": "^5.6 || ^7.0",
# "psr/http-message": "^1.0",
-# "zendframework/zend-diactoros": "^1.1"
-Requires: php(language) >= 5.5
+# "zendframework/zend-diactoros": "^1.7 || ^2.0",
+# "zendframework/zend-http": "^2.7"
+Requires: php(language) >= 5.6
%if ! %{bootstrap}
-Requires: php-autoloader(%{gh_owner}/zend-http) >= 2.5
-Requires: php-autoloader(%{gh_owner}/zend-http) < 3
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Requires: (php-composer(psr/http-message) >= 1.0 with php-composer(psr/http-message) < 2)
+Requires: (php-autoloader(%{gh_owner}/zend-diactoros) >= 1.7 with php-autoloader(%{gh_owner}/zend-diactoros) < 3)
+Requires: (php-autoloader(%{gh_owner}/zend-http) >= 2.7 with php-autoloader(%{gh_owner}/zend-http) < 3)
+# remirepo:8
+%else
Requires: php-composer(psr/http-message) >= 1.0
Requires: php-composer(psr/http-message) < 2
-Requires: php-autoloader(%{gh_owner}/zend-diactoros) >= 1.1
-Requires: php-autoloader(%{gh_owner}/zend-diactoros) < 2
+Requires: php-autoloader(%{gh_owner}/zend-diactoros) >= 1.7
+Requires: php-autoloader(%{gh_owner}/zend-diactoros) < 3
+Requires: php-autoloader(%{gh_owner}/zend-http) >= 2.7
+Requires: php-autoloader(%{gh_owner}/zend-http) < 3
+%endif
%endif
# Autoloader
Requires: php-composer(fedora/autoloader)
@@ -79,6 +97,7 @@ Documentation: https://zendframework.github.io/%{gh_project}/
%prep
%setup -q -n %{gh_project}-%{gh_commit}
+%patch0 -p0 -b .old
mv LICENSE.md LICENSE
@@ -90,7 +109,10 @@ cat << 'EOF' | tee -a src/autoload.php
\Fedora\Autoloader\Dependencies::required([
'%{php_home}/Zend/Http/autoload.php',
'%{php_home}/Psr/Http/Message/autoload.php',
- '%{php_home}/Zend/Diactoros/autoload.php',
+ [
+ '%{php_home}/Zend/Diactoros2/autoload.php',
+ '%{php_home}/Zend/Diactoros/autoload.php',
+ ]
]);
EOF
@@ -130,6 +152,12 @@ exit $ret
%changelog
+* Tue Jan 14 2020 Remi Collet <remi@remirepo.net> - 1.2.0-1
+- update to 1.2.0
+- raise dependency on PHP 5.6
+- raise dependency on zendframework/zend-diactoros 1.7
+- raise dependency on zendframework/http 2.7
+
* Sat Dec 9 2017 Remi Collet <remi@remirepo.net> - 0.2.2-4
- switch from zend-loader to fedora/autoloader
diff --git a/test.patch b/test.patch
new file mode 100644
index 0000000..380272f
--- /dev/null
+++ b/test.patch
@@ -0,0 +1,24 @@
+diff -up test/Psr7ResponseTest.php.old test/Psr7ResponseTest.php
+--- test/Psr7ResponseTest.php.old 2020-01-10 15:11:11.847467126 +0100
++++ test/Psr7ResponseTest.php 2020-01-10 15:11:34.953344291 +0100
+@@ -30,7 +30,7 @@ class Psr7ResponseTest extends TestCase
+ 'Content-Length' => [ '5' ]
+ ]],
+ [ 'Test!', 202, [
+- 'Content-Type' => [ 'text/html; level=1', 'text/html' ],
++ 'Content-Type' => [ 'text/html', 'text/html' ],
+ 'Content-Length' => [ '5' ]
+ ]],
+ ];
+diff -up test/Psr7ServerRequestTest.php.old test/Psr7ServerRequestTest.php
+--- test/Psr7ServerRequestTest.php.old 2020-01-10 15:10:52.018572544 +0100
++++ test/Psr7ServerRequestTest.php 2020-01-10 15:10:54.721558173 +0100
+@@ -401,7 +401,7 @@ class Psr7ServerRequestTest extends Test
+ 'POST', // http method
+ [
+ 'Content-Type' => 'application/x-www-form-urlencoded',
+- 'Cookie' => sprintf("PHPSESSID=%s;foo=bar", uniqid())
++ 'Cookie' => sprintf("PHPSESSID=%s", uniqid())
+ ], // headers
+ '', // body
+ [ 'foo' => 'bar' ], // query params