summaryrefslogtreecommitdiffstats
path: root/php-zendframework-zend-progressbar.spec
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-03-02 08:46:32 +0100
committerRemi Collet <fedora@famillecollet.com>2016-03-02 08:46:32 +0100
commitec74ad397ba002da4f228e5abaf67b9666dcb289 (patch)
tree4a19d5359149b413762e8e9a4e5e30d68539e2b9 /php-zendframework-zend-progressbar.spec
parentb629e255b439a4dfa1cb3bbc65617a8ab68029c9 (diff)
php-zendframework-zend-progressbar: 2.5.2
Diffstat (limited to 'php-zendframework-zend-progressbar.spec')
-rw-r--r--php-zendframework-zend-progressbar.spec43
1 files changed, 24 insertions, 19 deletions
diff --git a/php-zendframework-zend-progressbar.spec b/php-zendframework-zend-progressbar.spec
index bb0fdc9..6186817 100644
--- a/php-zendframework-zend-progressbar.spec
+++ b/php-zendframework-zend-progressbar.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 6f7784c9a6d7ea3198fa36aba1d28e6b9188832c
+%global gh_commit 0723a1f5f7c3f90cdde80ea68cb781e099c770bc
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-progressbar
@@ -20,7 +20,7 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.5.1
+Version: 2.5.2
Release: 1%{?dist}
Summary: Zend Framework %{library} component
@@ -34,30 +34,30 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.3.23
+BuildRequires: php(language) >= 5.5
BuildRequires: php-date
BuildRequires: php-pcre
BuildRequires: php-spl
-BuildRequires: php-composer(%{gh_owner}/zend-stdlib) >= 2.5
+BuildRequires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7
# From composer, "require-dev": {
-# "zendframework/zend-json": "~2.5",
-# "zendframework/zend-session": "~2.5",
+# "zendframework/zend-json": "^2.6.1",
+# "zendframework/zend-session": "^2.6.2",
# "fabpot/php-cs-fixer": "1.7.*",
# "phpunit/PHPUnit": "~4.0"
-BuildRequires: php-composer(%{gh_owner}/zend-json) >= 2.5
-BuildRequires: php-composer(%{gh_owner}/zend-session) >= 2.5
+BuildRequires: php-composer(%{gh_owner}/zend-json) >= 2.6.1
+BuildRequires: php-composer(%{gh_owner}/zend-session) >= 2.6.2
BuildRequires: php-composer(phpunit/phpunit) >= 4.0
# Autoloader
BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
%endif
# From composer, "require": {
-# "php": ">=5.3.23",
-# "zendframework/zend-stdlib": "~2.5"
-Requires: php(language) >= 5.3.23
+# "php": "^5.5 || ^7.0",
+# "zendframework/zend-stdlib": "^2.7 || ^3.0"
+Requires: php(language) >= 5.5
%if ! %{bootstrap}
-Requires: php-composer(%{gh_owner}/zend-stdlib) >= 2.5
-Requires: php-composer(%{gh_owner}/zend-stdlib) < 3
+Requires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7
+Requires: php-composer(%{gh_owner}/zend-stdlib) < 4
# From composer, "suggest": {
# "zendframework/zend-json": "Zend\\Json component",
# "zendframework/zend-session": "To support progressbar persistent"
@@ -104,14 +104,14 @@ cp -pr src %{buildroot}%{php_home}/Zend/%{library}
%check
%if %{with_tests}
mkdir vendor
-cat << EOF | tee vendor/autoload.php
+cat << 'EOF' | tee vendor/autoload.php
<?php
require_once '%{php_home}/Zend/Loader/AutoloaderFactory.php';
-Zend\\Loader\\AutoloaderFactory::factory(array(
- 'Zend\\Loader\\StandardAutoloader' => array(
+Zend\Loader\AutoloaderFactory::factory(array(
+ 'Zend\Loader\StandardAutoloader' => array(
'namespaces' => array(
- 'ZendTest\\\\%{library}' => dirname(__DIR__).'/test/',
- 'Zend\\\\%{library}' => '%{buildroot}%{php_home}/Zend/%{library}'
+ 'ZendTest\\%{library}' => dirname(__DIR__).'/test/',
+ 'Zend\\%{library}' => '%{buildroot}%{php_home}/Zend/%{library}'
))));
require_once '%{php_home}/Zend/autoload.php';
EOF
@@ -140,5 +140,10 @@ rm -rf %{buildroot}
%changelog
+* Wed Mar 2 2016 Remi Collet <remi@fedoraproject.org> - 2.5.2-1
+- update to 2.5.2
+- raise dependency on PHP >= 5.5
+- raise dependency on zend-stdlib >= 2.7
+
* Tue Aug 4 2015 Remi Collet <remi@fedoraproject.org> - 2.5.1-1
-- initial package \ No newline at end of file
+- initial package