summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-05-03 08:30:05 +0200
committerRemi Collet <remi@remirepo.net>2018-05-03 08:30:05 +0200
commit0e125cea8f9adaa98ce1d43b51829fd3326b618b (patch)
tree30fee84357a1823cb2477b0ef673045b45179723
parente5a6460bce0771083bd5b982ca8be797708854d2 (diff)
update to 2.6.0zend-loader
raise dependency on PHP 5.6
-rw-r--r--composer.json53
-rw-r--r--php-zendframework-zend-progressbar.spec31
2 files changed, 50 insertions, 34 deletions
diff --git a/composer.json b/composer.json
index 97a048f..3862ced 100644
--- a/composer.json
+++ b/composer.json
@@ -1,42 +1,61 @@
{
"name": "zendframework/zend-progressbar",
- "description": "component to create and update progressbars in different environments",
+ "description": "Create and update progress bars in different environments",
"license": "BSD-3-Clause",
"keywords": [
- "zf2",
+ "zf",
+ "zendframework",
"progressbar"
],
- "homepage": "https://github.com/zendframework/zend-progressbar",
- "autoload": {
- "psr-4": {
- "Zend\\ProgressBar\\": "src/"
- }
+ "support": {
+ "docs": "https://docs.zendframework.com/zend-progressbar/",
+ "issues": "https://github.com/zendframework/zend-progressbar/issues",
+ "source": "https://github.com/zendframework/zend-progressbar",
+ "rss": "https://github.com/zendframework/zend-progressbar/releases.atom",
+ "chat": "https://zendframework-slack.herokuapp.com",
+ "forum": "https://discourse.zendframework.com/c/questions/components"
},
"require": {
- "php": "^5.5 || ^7.0",
+ "php": "^5.6 || ^7.0",
"zendframework/zend-stdlib": "^2.7 || ^3.0"
},
"require-dev": {
+ "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.4",
+ "zendframework/zend-coding-standard": "~1.0.0",
"zendframework/zend-json": "^2.6.1",
- "zendframework/zend-session": "^2.6.2",
- "fabpot/php-cs-fixer": "1.7.*",
- "phpunit/PHPUnit": "~4.0"
+ "zendframework/zend-session": "^2.8.5"
},
"suggest": {
"zendframework/zend-json": "Zend\\Json component",
"zendframework/zend-session": "To support progressbar persistent"
},
- "minimum-stability": "dev",
- "prefer-stable": true,
- "extra": {
- "branch-alias": {
- "dev-master": "2.5-dev",
- "dev-develop": "2.6-dev"
+ "autoload": {
+ "psr-4": {
+ "Zend\\ProgressBar\\": "src/"
}
},
"autoload-dev": {
"psr-4": {
"ZendTest\\ProgressBar\\": "test/"
}
+ },
+ "config": {
+ "sort-packages": true
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "2.6.x-dev",
+ "dev-develop": "2.7.x-dev"
+ }
+ },
+ "scripts": {
+ "check": [
+ "@cs-check",
+ "@test"
+ ],
+ "cs-check": "phpcs",
+ "cs-fix": "phpcbf",
+ "test": "phpunit --colors=always",
+ "test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
}
}
diff --git a/php-zendframework-zend-progressbar.spec b/php-zendframework-zend-progressbar.spec
index 758e0b1..17be8fc 100644
--- a/php-zendframework-zend-progressbar.spec
+++ b/php-zendframework-zend-progressbar.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 0723a1f5f7c3f90cdde80ea68cb781e099c770bc
+%global gh_commit ae5565bbed54f9081d5695bc2f62fe3f27583bdd
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-progressbar
@@ -20,7 +20,7 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.5.2
+Version: 2.6.0
Release: 1%{?dist}
Summary: Zend Framework %{library} component
@@ -33,37 +33,30 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.5
+BuildRequires: php(language) >= 5.6
BuildRequires: php-date
BuildRequires: php-pcre
BuildRequires: php-spl
BuildRequires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7
# From composer, "require-dev": {
+# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.4",
+# "zendframework/zend-coding-standard": "~1.0.0",
# "zendframework/zend-json": "^2.6.1",
-# "zendframework/zend-session": "^2.6.2",
-# "fabpot/php-cs-fixer": "1.7.*",
-# "phpunit/PHPUnit": "~4.0"
+# "zendframework/zend-session": "^2.8.5"
BuildRequires: php-composer(%{gh_owner}/zend-json) >= 2.6.1
-BuildRequires: php-composer(%{gh_owner}/zend-session) >= 2.6.2
-BuildRequires: php-composer(phpunit/phpunit) >= 4.0
+BuildRequires: php-composer(%{gh_owner}/zend-session) >= 2.8
+BuildRequires: php-composer(phpunit/phpunit) >= 5.7
# Autoloader
BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
%endif
# From composer, "require": {
-# "php": "^5.5 || ^7.0",
+# "php": "^5.6 || ^7.0",
# "zendframework/zend-stdlib": "^2.7 || ^3.0"
-Requires: php(language) >= 5.5
+Requires: php(language) >= 5.6
%if ! %{bootstrap}
Requires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7
Requires: php-composer(%{gh_owner}/zend-stdlib) < 4
-# From composer, "suggest": {
-# "zendframework/zend-json": "Zend\\Json component",
-# "zendframework/zend-session": "To support progressbar persistent"
-%if 0%{?fedora} >= 21
-Suggests: php-composer(%{gh_owner}/zend-json)
-Suggests: php-composer(%{gh_owner}/zend-session)
-%endif
%endif
# From phpcompatinfo report for version 2.5.1
Requires: php-date
@@ -138,6 +131,10 @@ exit $ret
%changelog
+* Thu May 3 2018 Remi Collet <remi@remirepo.net> - 2.6.0-1
+- update to 2.6.0
+- raise dependency on PHP 5.6
+
* Wed Mar 2 2016 Remi Collet <remi@fedoraproject.org> - 2.5.2-1
- update to 2.5.2
- raise dependency on PHP >= 5.5