summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-12-11 12:40:39 +0100
committerRemi Collet <remi@remirepo.net>2017-12-11 12:40:39 +0100
commite068288b90c256ffc7c07b66e6236c8029deb74d (patch)
treedcc72c58ee742955fafb2f85828d24fe312c6f1b
parent4198264b0a13871ab26dac35b3c02d70e47fffd8 (diff)
clean
-rw-r--r--php-zendframework-zend-permissions-acl.spec20
1 files changed, 7 insertions, 13 deletions
diff --git a/php-zendframework-zend-permissions-acl.spec b/php-zendframework-zend-permissions-acl.spec
index ec1dee3..ccf1e1e 100644
--- a/php-zendframework-zend-permissions-acl.spec
+++ b/php-zendframework-zend-permissions-acl.spec
@@ -30,7 +30,6 @@ URL: https://zendframework.github.io/%{gh_project}/
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
# Tests
%if %{with_tests}
@@ -84,8 +83,6 @@ mv LICENSE.md LICENSE
%install
-rm -rf %{buildroot}
-
mkdir -p %{buildroot}%{php_home}/Zend/Permissions/
cp -pr src %{buildroot}%{php_home}/Zend/Permissions/%{library}
@@ -105,22 +102,19 @@ Zend\Loader\AutoloaderFactory::factory(array(
require_once '%{php_home}/Zend/autoload.php';
EOF
-%{_bindir}/phpunit --include-path=%{buildroot}%{php_home}
-
-if which php70; then
- php70 %{_bindir}/phpunit --include-path=%{buildroot}%{php_home}
-fi
+ret=0
+for cmd in php php56 php70 php71 php72; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit || ret=1
+ fi
+done
+exit $ret
%else
: Test suite disabled
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md