summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-02-24 07:12:38 +0100
committerRemi Collet <fedora@famillecollet.com>2016-02-24 07:12:38 +0100
commitcf19f8081822e0288cb9aada1c322de16d263e8d (patch)
treedee10e76436e273c0836047e0a1347e4eaab97fd
parentfc0a0b89cfd6fcf6dec4a0ad368c464a92c85cb4 (diff)
php-zendframework-zend-paginator: 2.6.0
-rw-r--r--php-zendframework-zend-paginator.spec65
1 files changed, 34 insertions, 31 deletions
diff --git a/php-zendframework-zend-paginator.spec b/php-zendframework-zend-paginator.spec
index 22a5a82..cedb95d 100644
--- a/php-zendframework-zend-paginator.spec
+++ b/php-zendframework-zend-paginator.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 79b946198737253c597ff2ac3fbe91a479bb8a7d
+%global gh_commit 15c82665abc668e6ddf955afc4b86cd3385efbad
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-paginator
@@ -20,7 +20,7 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.5.1
+Version: 2.6.0
Release: 1%{?dist}
Summary: Zend Framework %{library} component
@@ -34,40 +34,38 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.3.23
+BuildRequires: php(language) >= 5.5
BuildRequires: php-spl
-BuildRequires: php-composer(%{gh_owner}/zend-stdlib) >= 2.5
+BuildRequires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7
# From composer, "require-dev": {
-# "zendframework/zend-cache": "~2.5",
-# "zendframework/zend-config": "~2.5",
-# "zendframework/zend-db": "~2.5",
-# "zendframework/zend-filter": "~2.5",
-# "zendframework/zend-json": "~2.5",
-# "zendframework/zend-mvc": "~2.5",
-# "zendframework/zend-servicemanager": "~2.5",
-# "zendframework/zend-view": "~2.5",
+# "zendframework/zend-cache": "^2.6.1",
+# "zendframework/zend-config": "^2.6.0",
+# "zendframework/zend-db": "^2.7",
+# "zendframework/zend-filter": "^2.6.1",
+# "zendframework/zend-json": "^2.6.1",
+# "zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3",
+# "zendframework/zend-view": "^2.6.3",
# "fabpot/php-cs-fixer": "1.7.*",
# "phpunit/PHPUnit": "~4.0"
-BuildRequires: php-composer(%{gh_owner}/zend-cache) >= 2.5
-BuildRequires: php-composer(%{gh_owner}/zend-config) >= 2.5
-BuildRequires: php-composer(%{gh_owner}/zend-db) >= 2.5
-BuildRequires: php-composer(%{gh_owner}/zend-filter) >= 2.5
-BuildRequires: php-composer(%{gh_owner}/zend-json) >= 2.5
-BuildRequires: php-composer(%{gh_owner}/zend-mvc) >= 2.5
-BuildRequires: php-composer(%{gh_owner}/zend-servicemanager) >= 2.5
-BuildRequires: php-composer(%{gh_owner}/zend-view) >= 2.5
+BuildRequires: php-composer(%{gh_owner}/zend-cache) >= 2.6.1
+BuildRequires: php-composer(%{gh_owner}/zend-config) >= 2.6.0
+BuildRequires: php-composer(%{gh_owner}/zend-db) >= 2.7
+BuildRequires: php-composer(%{gh_owner}/zend-filter) >= 2.6.1
+BuildRequires: php-composer(%{gh_owner}/zend-json) >= 2.6.1
+BuildRequires: php-composer(%{gh_owner}/zend-servicemanager) >= 2.7.5
+BuildRequires: php-composer(%{gh_owner}/zend-view) >= 2.6.3
BuildRequires: php-composer(phpunit/phpunit) >= 4.0
# Autoloader
BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
%endif
# From composer, "require": {
-# "php": ">=5.3.23",
-# "zendframework/zend-stdlib": "~2.5"
-Requires: php(language) >= 5.3.23
+# "php": "^5.5 || ^7.0",
+# "zendframework/zend-stdlib": "^2.7 || ^3.0"
+Requires: php(language) >= 5.5
%if ! %{bootstrap}
-Requires: php-composer(%{gh_owner}/zend-stdlib) >= 2.5
-Requires: php-composer(%{gh_owner}/zend-stdlib) < 3
+Requires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7
+Requires: php-composer(%{gh_owner}/zend-stdlib) < 4
# From composer, "suggest": {
# "zendframework/zend-cache": "Zend\\Cache component to support cache features",
# "zendframework/zend-db": "Zend\\Db component",
@@ -115,14 +113,14 @@ cp -pr src %{buildroot}%{php_home}/Zend/%{library}
%check
%if %{with_tests}
mkdir vendor
-cat << EOF | tee vendor/autoload.php
+cat << 'EOF' | tee vendor/autoload.php
<?php
require_once '%{php_home}/Zend/Loader/AutoloaderFactory.php';
-Zend\\Loader\\AutoloaderFactory::factory(array(
- 'Zend\\Loader\\StandardAutoloader' => array(
+Zend\Loader\AutoloaderFactory::factory(array(
+ 'Zend\Loader\StandardAutoloader' => array(
'namespaces' => array(
- 'ZendTest\\\\%{library}' => dirname(__DIR__).'/test/',
- 'Zend\\\\%{library}' => '%{buildroot}%{php_home}/Zend/%{library}'
+ 'ZendTest\\%{library}' => dirname(__DIR__).'/test/',
+ 'Zend\\%{library}' => '%{buildroot}%{php_home}/Zend/%{library}'
))));
require_once '%{php_home}/Zend/autoload.php';
EOF
@@ -151,5 +149,10 @@ rm -rf %{buildroot}
%changelog
+* Wed Feb 24 2016 Remi Collet <remi@fedoraproject.org> - 2.6.0-1
+- update to 2.6.0
+- raise dependency on PHP >= 5.5
+- raise dependency on zend-stdlib >= 2.7
+
* Tue Aug 4 2015 Remi Collet <remi@fedoraproject.org> - 2.5.1-1
-- initial package \ No newline at end of file
+- initial package