summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-12-12 16:11:00 +0100
committerRemi Collet <remi@remirepo.net>2017-12-12 16:11:00 +0100
commit74f7d0085a32db321d69a67e93f89cbae827ccec (patch)
tree3fe9b2deb6a18721b921d63ec3ab0e5ebc892e88
parentbf9daf8d6e2078e0f3a5c44bbd7a79c8ff0c173e (diff)
Update to 2.8.0
raise dependency on PHP 5.6 use phpunit6 on F26+
-rw-r--r--composer.json72
-rw-r--r--php-zendframework-zend-paginator.spec48
2 files changed, 98 insertions, 22 deletions
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..a80bb61
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,72 @@
+{
+ "name": "zendframework/zend-paginator",
+ "description": "zend-paginator is a flexible component for paginating collections of data and presenting that data to users.",
+ "license": "BSD-3-Clause",
+ "keywords": [
+ "zf2",
+ "paginator"
+ ],
+ "homepage": "https://github.com/zendframework/zend-paginator",
+ "support": {
+ "docs": "https://docs.zendframework.com/zend-paginator",
+ "forum": "https://discourse.zendframework.com",
+ "issues": "https://github.com/zendframework/zend-paginator/issues",
+ "source": "https://github.com/zendframework/zend-paginator"
+ },
+ "autoload": {
+ "psr-4": {
+ "Zend\\Paginator\\": "src/"
+ }
+ },
+ "require": {
+ "php": "^7.0 || ^5.6",
+ "zendframework/zend-stdlib": "^2.7 || ^3.0"
+ },
+ "require-dev": {
+ "phpunit/phpunit": "^6.2.1 || ^5.7.15",
+ "zendframework/zend-cache": "^2.6.1",
+ "zendframework/zend-coding-standard": "~1.0.0",
+ "zendframework/zend-config": "^2.6.0",
+ "zendframework/zend-db": "^2.7",
+ "zendframework/zend-filter": "^2.6.1",
+ "zendframework/zend-json": "^2.6.1",
+ "zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3",
+ "zendframework/zend-view": "^2.6.3"
+ },
+ "suggest": {
+ "zendframework/zend-cache": "Zend\\Cache component to support cache features",
+ "zendframework/zend-db": "Zend\\Db component",
+ "zendframework/zend-filter": "Zend\\Filter component",
+ "zendframework/zend-json": "Zend\\Json component",
+ "zendframework/zend-servicemanager": "Zend\\ServiceManager component",
+ "zendframework/zend-view": "Zend\\View component"
+ },
+ "minimum-stability": "dev",
+ "prefer-stable": true,
+ "extra": {
+ "branch-alias": {
+ "dev-master": "2.8-dev",
+ "dev-develop": "2.9-dev"
+ },
+ "zf": {
+ "component": "Zend\\Paginator",
+ "config-provider": "Zend\\Paginator\\ConfigProvider"
+ }
+ },
+ "autoload-dev": {
+ "psr-4": {
+ "ZendTest\\Paginator\\": "test/"
+ }
+ },
+ "scripts": {
+ "check": [
+ "@cs-check",
+ "@test"
+ ],
+ "cs-check": "phpcs",
+ "cs-fix": "phpcbf",
+ "test": "phpunit --colors=always",
+ "test-coverage": "phpunit --colors=always --coverage-clover clover.xml",
+ "upload-coverage": "coveralls -v"
+ }
+}
diff --git a/php-zendframework-zend-paginator.spec b/php-zendframework-zend-paginator.spec
index 21809bc..2caae2e 100644
--- a/php-zendframework-zend-paginator.spec
+++ b/php-zendframework-zend-paginator.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 42211f3e1e8230953c641e91fec5aa9fe964eb95
+%global gh_commit 655b9ef28092b283e10e6c6a4f42c82db992b2ba
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-paginator
@@ -20,7 +20,7 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.7.0
+Version: 2.8.0
Release: 1%{?dist}
Summary: Zend Framework %{library} component
@@ -30,23 +30,22 @@ URL: https://zendframework.github.io/%{gh_project}/
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.5
+BuildRequires: php(language) >= 5.6
BuildRequires: php-spl
BuildRequires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7
# From composer, "require-dev": {
+# "phpunit/phpunit": "^6.2.1 || ^5.7.15",
# "zendframework/zend-cache": "^2.6.1",
+# "zendframework/zend-coding-standard": "~1.0.0",
# "zendframework/zend-config": "^2.6.0",
# "zendframework/zend-db": "^2.7",
# "zendframework/zend-filter": "^2.6.1",
# "zendframework/zend-json": "^2.6.1",
# "zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3",
-# "zendframework/zend-view": "^2.6.3",
-# "fabpot/php-cs-fixer": "1.7.*",
-# "phpunit/PHPUnit": "~4.0"
+# "zendframework/zend-view": "^2.6.3"
BuildRequires: php-composer(%{gh_owner}/zend-cache) >= 2.6.1
BuildRequires: php-composer(%{gh_owner}/zend-config) >= 2.6.0
BuildRequires: php-composer(%{gh_owner}/zend-db) >= 2.7
@@ -54,15 +53,19 @@ BuildRequires: php-composer(%{gh_owner}/zend-filter) >= 2.6.1
BuildRequires: php-composer(%{gh_owner}/zend-json) >= 2.6.1
BuildRequires: php-composer(%{gh_owner}/zend-servicemanager) >= 2.7.5
BuildRequires: php-composer(%{gh_owner}/zend-view) >= 2.6.3
-BuildRequires: php-composer(phpunit/phpunit) >= 4.0
+%if 0%{?fedora} >= 26
+%global phpunit %{_bindir}/phpunit6
+%else
+%global phpunit %{_bindir}/phpunit
+%endif
# Autoloader
BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
%endif
# From composer, "require": {
-# "php": "^5.5 || ^7.0",
+# "php": "^7.0 || ^5.6",
# "zendframework/zend-stdlib": "^2.7 || ^3.0"
-Requires: php(language) >= 5.5
+Requires: php(language) >= 5.6
%if ! %{bootstrap}
Requires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7
Requires: php-composer(%{gh_owner}/zend-stdlib) < 4
@@ -108,8 +111,6 @@ mv LICENSE.md LICENSE
%install
-rm -rf %{buildroot}
-
mkdir -p %{buildroot}%{php_home}/Zend/
cp -pr src %{buildroot}%{php_home}/Zend/%{library}
@@ -129,22 +130,20 @@ Zend\Loader\AutoloaderFactory::factory(array(
require_once '%{php_home}/Zend/autoload.php';
EOF
-%{_bindir}/phpunit --include-path=%{buildroot}%{php_home}
-
-if which php70; then
- php70 %{_bindir}/phpunit --include-path=%{buildroot}%{php_home}
-fi
+ret=0
+for cmdarg in "php %{phpunit}" "php56 %{_bindir}/phpunit" php70 php71 php72; do
+ if which $cmdarg; then
+ set $cmdarg
+ $1 ${2:-%{_bindir}/phpunit6} --verbose || ret=1
+ fi
+done
+exit $ret
%else
: Test suite disabled
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md
@@ -153,6 +152,11 @@ rm -rf %{buildroot}
%changelog
+* Thu Nov 2 2017 Remi Collet <remi@remirepo.net> - 2.8.0-1
+- Update to 2.8.0
+- raise dependency on PHP 5.6
+- use phpunit6 on F26+
+
* Tue Apr 12 2016 Remi Collet <remi@fedoraproject.org> - 2.7.0-1
- update to 2.7.0