summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-02-25 07:35:00 +0100
committerRemi Collet <fedora@famillecollet.com>2016-02-25 07:35:00 +0100
commit3bef134dddffa8097efa5b3c24b9204a6a3ad096 (patch)
tree6e363ede2d0afe901c9fb539bb24d2171ac9f587
parenta24a0fcf140228e3343d38c595cf8723e4f8d330 (diff)
php-zendframework-zend-navigation: 2.6.0
-rw-r--r--php-zendframework-zend-navigation.spec80
1 files changed, 41 insertions, 39 deletions
diff --git a/php-zendframework-zend-navigation.spec b/php-zendframework-zend-navigation.spec
index 092d927..109c7fb 100644
--- a/php-zendframework-zend-navigation.spec
+++ b/php-zendframework-zend-navigation.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 1afcd2ea2342ee5cc68e11e28b09d9b6365cac0f
+%global gh_commit 864f04447be937d3d0eb22a52fe492cdd27f18aa
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-navigation
@@ -20,7 +20,7 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.5.1
+Version: 2.6.0
Release: 1%{?dist}
Summary: Zend Framework %{library} component
@@ -34,49 +34,45 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.3.23
+BuildRequires: php(language) >= 5.5
BuildRequires: php-pcre
BuildRequires: php-spl
-BuildRequires: php-composer(%{gh_owner}/zend-stdlib) >= 2.5
+BuildRequires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7
# From composer, "require-dev": {
-# "zendframework/zend-config": "~2.5",
-# "zendframework/zend-console": "~2.5",
-# "zendframework/zend-http": "~2.5",
-# "zendframework/zend-i18n": "~2.5",
-# "zendframework/zend-log": "~2.5",
-# "zendframework/zend-modulemanager": "~2.5",
-# "zendframework/zend-mvc": "~2.5",
-# "zendframework/zend-permissions-acl": "~2.5",
-# "zendframework/zend-serializer": "~2.5",
-# "zendframework/zend-servicemanager": "~2.5",
-# "zendframework/zend-uri": "~2.5",
-# "zendframework/zend-view": "~2.5",
+# "zendframework/zend-config": "^2.6",
+# "zendframework/zend-console": "^2.6",
+# "zendframework/zend-http": "^2.5.4",
+# "zendframework/zend-i18n": "^2.6",
+# "zendframework/zend-log": "^2.7.1",
+# "zendframework/zend-mvc": "^2.6.3",
+# "zendframework/zend-permissions-acl": "^2.6",
+# "zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3",
+# "zendframework/zend-uri": "^2.5",
+# "zendframework/zend-view": "^2.6.3",
# "fabpot/php-cs-fixer": "1.7.*",
# "phpunit/PHPUnit": "~4.0"
-BuildRequires: php-composer(%{gh_owner}/zend-config) >= 2.5
-BuildRequires: php-composer(%{gh_owner}/zend-console) >= 2.5
-BuildRequires: php-composer(%{gh_owner}/zend-http) >= 2.5
-BuildRequires: php-composer(%{gh_owner}/zend-i18n) >= 2.5
-BuildRequires: php-composer(%{gh_owner}/zend-log) >= 2.5
-BuildRequires: php-composer(%{gh_owner}/zend-modulemanager) >= 2.5
-BuildRequires: php-composer(%{gh_owner}/zend-mvc) >= 2.5
-BuildRequires: php-composer(%{gh_owner}/zend-permissions-acl) >= 2.5
-BuildRequires: php-composer(%{gh_owner}/zend-serializer) >= 2.5
-BuildRequires: php-composer(%{gh_owner}/zend-servicemanager) >= 2.5
+BuildRequires: php-composer(%{gh_owner}/zend-config) >= 2.6
+BuildRequires: php-composer(%{gh_owner}/zend-console) >= 2.6
+BuildRequires: php-composer(%{gh_owner}/zend-http) >= 2.5.4
+BuildRequires: php-composer(%{gh_owner}/zend-i18n) >= 2.6
+BuildRequires: php-composer(%{gh_owner}/zend-log) >= 2.7.1
+BuildRequires: php-composer(%{gh_owner}/zend-mvc) >= 2.6.3
+BuildRequires: php-composer(%{gh_owner}/zend-permissions-acl) >= 2.6
+BuildRequires: php-composer(%{gh_owner}/zend-servicemanager) >= 2.7.5
BuildRequires: php-composer(%{gh_owner}/zend-uri) >= 2.5
-BuildRequires: php-composer(%{gh_owner}/zend-view) >= 2.5
+BuildRequires: php-composer(%{gh_owner}/zend-view) >= 2.6.3
BuildRequires: php-composer(phpunit/phpunit) >= 4.0
# Autoloader
BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
%endif
# From composer, "require": {
-# "php": ">=5.3.23",
-# "zendframework/zend-stdlib": "~2.5"
-Requires: php(language) >= 5.3.23
+# "php": "^5.5 || ^7.0",
+# "zendframework/zend-stdlib": "^2.7 || ^3.0"
+Requires: php(language) >= 5.5
%if ! %{bootstrap}
-Requires: php-composer(%{gh_owner}/zend-stdlib) >= 2.5
-Requires: php-composer(%{gh_owner}/zend-stdlib) < 3
+Requires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7
+Requires: php-composer(%{gh_owner}/zend-stdlib) < 4
# From composer, "suggest": {
# "zendframework/zend-config": "Zend\\Config component",
# "zendframework/zend-mvc": "Zend\\Mvc component",
@@ -91,8 +87,9 @@ Suggests: php-composer(%{gh_owner}/zend-servicemanager)
Suggests: php-composer(%{gh_owner}/zend-view)
%endif
%endif
-# From phpcompatinfo report for version 2.5.1
+# From phpcompatinfo report for version 2.6.0
Requires: php-pcre
+Requires: php-reflection
Requires: php-spl
Obsoletes: php-ZendFramework2-%{library} < 2.5
@@ -124,14 +121,14 @@ cp -pr src %{buildroot}%{php_home}/Zend/%{library}
%check
%if %{with_tests}
mkdir vendor
-cat << EOF | tee vendor/autoload.php
+cat << 'EOF' | tee vendor/autoload.php
<?php
require_once '%{php_home}/Zend/Loader/AutoloaderFactory.php';
-Zend\\Loader\\AutoloaderFactory::factory(array(
- 'Zend\\Loader\\StandardAutoloader' => array(
+Zend\Loader\AutoloaderFactory::factory(array(
+ 'Zend\Loader\StandardAutoloader' => array(
'namespaces' => array(
- 'ZendTest\\\\%{library}' => dirname(__DIR__).'/test/',
- 'Zend\\\\%{library}' => '%{buildroot}%{php_home}/Zend/%{library}'
+ 'ZendTest\\%{library}' => dirname(__DIR__).'/test/',
+ 'Zend\\%{library}' => '%{buildroot}%{php_home}/Zend/%{library}'
))));
require_once '%{php_home}/Zend/autoload.php';
EOF
@@ -160,5 +157,10 @@ rm -rf %{buildroot}
%changelog
+* Thu Feb 25 2016 Remi Collet <remi@fedoraproject.org> - 2.6.0-1
+- update to 2.6.0
+- raise dependency on PHP >= 5.5
+- raise dependency on zend-stdlib >= 2.7
+
* Tue Aug 4 2015 Remi Collet <remi@fedoraproject.org> - 2.5.1-1
-- initial package \ No newline at end of file
+- initial package