summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-05-02 07:58:02 +0200
committerRemi Collet <remi@remirepo.net>2017-05-02 07:58:02 +0200
commitb968424f622ed1028802f69409b4b23d908c3673 (patch)
tree468fc7ff95433b6df96166578eb7ea9f1aa2a7af
parent00f4e9ccd346007a15108eddb79946393194caf7 (diff)
v3.1.0
-rw-r--r--.gitignore7
-rw-r--r--composer.json36
-rw-r--r--php-zendframework-zend-mvc.spec64
3 files changed, 70 insertions, 37 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..1ab5c4f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/composer.json b/composer.json
index 9b47ae2..983bfa5 100644
--- a/composer.json
+++ b/composer.json
@@ -13,6 +13,7 @@
}
},
"require": {
+ "container-interop/container-interop": "^1.1",
"php": "^5.6 || ^7.0",
"zendframework/zend-eventmanager": "^3.0",
"zendframework/zend-http": "^2.5.4",
@@ -20,46 +21,55 @@
"zendframework/zend-router": "^3.0.1",
"zendframework/zend-servicemanager": "^3.0.3",
"zendframework/zend-stdlib": "^3.0",
- "zendframework/zend-view": "^2.6.7",
- "container-interop/container-interop": "^1.1"
+ "zendframework/zend-view": "^2.6.7"
},
"require-dev": {
+ "phpunit/phpunit": "^6.0.7 || ^5.7.14",
+ "zendframework/zend-coding-standard": "~1.0.0",
"zendframework/zend-json": "^2.6.1 || ^3.0",
"zendframework/zend-psr7bridge": "^0.2",
- "fabpot/php-cs-fixer": "1.7.*",
- "phpunit/phpunit": "^4.5"
+ "zendframework/zend-stratigility": "^2.0.1"
},
"suggest": {
"zendframework/zend-json": "(^2.6.1 || ^3.0) To auto-deserialize JSON body content in AbstractRestfulController extensions, when json_decode is unavailable",
+ "zendframework/zend-log": "^2.9.1 To provide log functionality via LogFilterManager, LogFormatterManager, and LogProcessorManager",
"zendframework/zend-mvc-console": "zend-mvc-console provides the ability to expose zend-mvc as a console application",
"zendframework/zend-mvc-i18n": "zend-mvc-i18n provides integration with zend-i18n, including a translation bridge and translatable route segments",
"zendframework/zend-mvc-plugin-fileprg": "To provide Post/Redirect/Get functionality around forms that container file uploads",
"zendframework/zend-mvc-plugin-flashmessenger": "To provide flash messaging capabilities between requests",
"zendframework/zend-mvc-plugin-identity": "To access the authenticated identity (per zend-authentication) in controllers",
"zendframework/zend-mvc-plugin-prg": "To provide Post/Redirect/Get functionality within controllers",
+ "zendframework/zend-paginator": "^2.7 To provide pagination functionality via PaginatorPluginManager",
"zendframework/zend-psr7bridge": "(^0.2) To consume PSR-7 middleware within the MVC workflow",
- "zendframework/zend-servicemanager-di": "zend-servicemanager-di provides utilities for integrating zend-di and zend-servicemanager in your zend-mvc application"
+ "zendframework/zend-servicemanager-di": "zend-servicemanager-di provides utilities for integrating zend-di and zend-servicemanager in your zend-mvc application",
+ "zendframework/zend-stratigility": "zend-stratigility is required to use middleware pipes in the MiddlewareListener"
+ },
+ "config": {
+ "sort-packages": true
},
"extra": {
"branch-alias": {
- "dev-master": "3.0-dev",
- "dev-develop": "3.1-dev"
+ "dev-master": "3.1-dev",
+ "dev-develop": "3.2-dev"
}
},
"autoload-dev": {
"psr-4": {
"ZendTest\\Mvc\\": "test/"
- }
+ },
+ "files": [
+ "test/_autoload.php"
+ ]
},
"scripts": {
"check": [
"@cs-check",
"@test"
],
- "upload-coverage": "coveralls -v",
- "cs-check": "php-cs-fixer --version && php-cs-fixer fix -v --diff --dry-run",
- "cs-fix": "php-cs-fixer fix -v",
- "test": "phpunit",
- "test-coverage": "phpunit --coverage-clover clover.xml"
+ "cs-check": "phpcs",
+ "cs-fix": "phpcbf",
+ "test": "phpunit --colors=always",
+ "test-coverage": "phpunit --colors=always --coverage-clover clover.xml",
+ "upload-coverage": "coveralls -v"
}
}
diff --git a/php-zendframework-zend-mvc.spec b/php-zendframework-zend-mvc.spec
index 8eeb459..49e6b50 100644
--- a/php-zendframework-zend-mvc.spec
+++ b/php-zendframework-zend-mvc.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit e25f04a71b70985620f5ff3e762475848d049025
+%global gh_commit ba40f2c795403ce8b95f9251657cc2b96c40c417
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-mvc
@@ -20,7 +20,7 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 3.0.4
+Version: 3.1.0
Release: 1%{?dist}
Summary: Zend Framework %{library} component
@@ -39,6 +39,7 @@ BuildRequires: php-reflection
BuildRequires: php-intl
BuildRequires: php-pcre
BuildRequires: php-spl
+BuildRequires: php-composer(container-interop/container-interop) >= 1.1
BuildRequires: php-composer(%{gh_owner}/zend-eventmanager) >= 3.0
BuildRequires: php-composer(%{gh_owner}/zend-http) >= 2.5.4
BuildRequires: php-composer(%{gh_owner}/zend-modulemanager) >= 2.7.1
@@ -46,15 +47,22 @@ BuildRequires: php-composer(%{gh_owner}/zend-router) >= 3.0.1
BuildRequires: php-composer(%{gh_owner}/zend-servicemanager) >= 3.0.3
BuildRequires: php-composer(%{gh_owner}/zend-stdlib) >= 3.0
BuildRequires: php-composer(%{gh_owner}/zend-view) >= 2.6.7
-BuildRequires: php-composer(container-interop/container-interop) >= 1.1
# From composer, "require-dev": {
+# "phpunit/phpunit": "^6.0.7 || ^5.7.14",
+# "zendframework/zend-coding-standard": "~1.0.0",
# "zendframework/zend-json": "^2.6.1 || ^3.0",
# "zendframework/zend-psr7bridge": "^0.2",
-# "fabpot/php-cs-fixer": "1.7.*",
-# "phpunit/phpunit": "^4.5"
+# "zendframework/zend-stratigility": "^2.0.1"
BuildRequires: php-composer(%{gh_owner}/zend-json) >= 2.6.1
BuildRequires: php-composer(%{gh_owner}/zend-psr7bridge) >= 0.2
-BuildRequires: php-composer(phpunit/phpunit) >= 4.5
+# ignore min version (and skip test relying on it)
+BuildRequires: php-composer(%{gh_owner}/zend-stratigility)
+%if 0%{?fedora} >= 26
+%global phpunit %{_bindir}/phpunit6
+%else
+%global phpunit %{_bindir}/phpunit
+%endif
+BuildRequires: %{phpunit}
# Autoloader
BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
# For dependencies autoloader
@@ -62,6 +70,7 @@ BuildRequires: php-zendframework-zend-loader >= 2.5.1-3
%endif
# From composer, "require": {
+# "container-interop/container-interop": "^1.1",
# "php": "^5.6 || ^7.0",
# "zendframework/zend-eventmanager": "^3.0",
# "zendframework/zend-http": "^2.5.4",
@@ -69,9 +78,11 @@ BuildRequires: php-zendframework-zend-loader >= 2.5.1-3
# "zendframework/zend-router": "^3.0.1",
# "zendframework/zend-servicemanager": "^3.0.3",
# "zendframework/zend-stdlib": "^3.0",
-# "zendframework/zend-view": "^2.6.7",
+# "zendframework/zend-view": "^2.6.7"
Requires: php(language) >= 5.6
%if ! %{bootstrap}
+Requires: php-composer(container-interop/container-interop) >= 1.1
+Requires: php-composer(container-interop/container-interop) < 2
Requires: php-composer(%{gh_owner}/zend-eventmanager) >= 3.0
Requires: php-composer(%{gh_owner}/zend-eventmanager) < 4
Requires: php-composer(%{gh_owner}/zend-http) >= 2.5.4
@@ -86,28 +97,32 @@ Requires: php-composer(%{gh_owner}/zend-stdlib) >= 3.0
Requires: php-composer(%{gh_owner}/zend-stdlib) < 4
Requires: php-composer(%{gh_owner}/zend-view) >= 2.6.7
Requires: php-composer(%{gh_owner}/zend-http) < 3
-Requires: php-composer(container-interop/container-interop) >= 1.1
-Requires: php-composer(container-interop/container-interop) < 2
# From composer, "suggest": {
# "zendframework/zend-json": "(^2.6.1 || ^3.0) To auto-deserialize JSON body content in AbstractRestfulController extensions, when json_decode is unavailable",
+# "zendframework/zend-log": "^2.9.1 To provide log functionality via LogFilterManager, LogFormatterManager, and LogProcessorManager",
# "zendframework/zend-mvc-console": "zend-mvc-console provides the ability to expose zend-mvc as a console application",
# "zendframework/zend-mvc-i18n": "zend-mvc-i18n provides integration with zend-i18n, including a translation bridge and translatable route segments",
# "zendframework/zend-mvc-plugin-fileprg": "To provide Post/Redirect/Get functionality around forms that container file uploads",
# "zendframework/zend-mvc-plugin-flashmessenger": "To provide flash messaging capabilities between requests",
# "zendframework/zend-mvc-plugin-identity": "To access the authenticated identity (per zend-authentication) in controllers",
# "zendframework/zend-mvc-plugin-prg": "To provide Post/Redirect/Get functionality within controllers",
+# "zendframework/zend-paginator": "^2.7 To provide pagination functionality via PaginatorPluginManager",
# "zendframework/zend-psr7bridge": "(^0.2) To consume PSR-7 middleware within the MVC workflow",
-# "zendframework/zend-servicemanager-di": "zend-servicemanager-di provides utilities for integrating zend-di and zend-servicemanager in your zend-mvc application"
+# "zendframework/zend-servicemanager-di": "zend-servicemanager-di provides utilities for integrating zend-di and zend-servicemanager in your zend-mvc application",
+# "zendframework/zend-stratigility": "zend-stratigility is required to use middleware pipes in the MiddlewareListener"
%if 0%{?fedora} >= 21
Suggests: php-composer(%{gh_owner}/zend-json)
+Suggests: php-composer(%{gh_owner}/zend-log)
Suggests: php-composer(%{gh_owner}/zend-mvc-console)
Suggests: php-composer(%{gh_owner}/zend-mvc-i18n)
Suggests: php-composer(%{gh_owner}/zend-mvc-plugin-fileprg)
Suggests: php-composer(%{gh_owner}/zend-mvc-plugin-flashmessenger)
Suggests: php-composer(%{gh_owner}/zend-mvc-plugin-identity)
Suggests: php-composer(%{gh_owner}/zend-mvc-plugin-prg)
+Suggests: php-composer(%{gh_owner}/zend-paginator)
Suggests: php-composer(%{gh_owner}/zend-psr7bridge)
Suggests: php-composer(%{gh_owner}/zend-servicemanager-di)
+Suggests: php-composer(%{gh_owner}/zend-stratigility)
%endif
# Autoloader
Requires: php-composer(%{gh_owner}/zend-loader) >= 2.5
@@ -171,6 +186,9 @@ install -m644 autoload.php %{buildroot}%{php_home}/Zend/%{library}-autoload.php
%check
%if %{with_tests}
+# Skip test relying on statigility 2.0.1
+rm test/MiddlewareListenerTest.php
+
mkdir vendor
cat << 'EOF' | tee vendor/autoload.php
<?php
@@ -184,23 +202,17 @@ Zend\Loader\AutoloaderFactory::factory(array(
'Zend\\%{library}' => '%{buildroot}%{php_home}/Zend/%{library}'
))));
require_once '%{php_home}/Zend/autoload.php';
+require_once 'test/_autoload.php';
EOF
-# remirepo:11
-run=0
ret=0
-if which php56; then
- php56 %{_bindir}/phpunit --include-path=%{buildroot}%{php_home} || ret=1
- run=1
-fi
-if which php71; then
- php71 %{_bindir}/phpunit --include-path=%{buildroot}%{php_home} || ret=1
- run=1
-fi
-if [ $run -eq 0 ]; then
-%{_bindir}/phpunit --include-path=%{buildroot}%{php_home} --verbose
-# remirepo:2
-fi
+# 7.2: https://github.com/zendframework/zend-form/issues/157
+for cmdarg in "php %{phpunit}" "php56 %{_bindir}/phpunit" php70 php71 php72; do
+ if which $cmdarg; then
+ set $cmdarg
+ $1 ${2:-%{_bindir}/phpunit6} --verbose || ret=1
+ fi
+done
exit $ret
%else
: Test suite disabled
@@ -222,6 +234,10 @@ rm -rf %{buildroot}
%changelog
+* Tue May 2 2017 Remi Collet <remi@remirepo.net> - 3.1.0-1
+- Update to 3.1.0
+- use phpunit6
+
* Wed Dec 21 2016 Remi Collet <remi@fedoraproject.org> - 3.0.4-1
- update to 3.0.4