summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-09-24 10:55:31 +0200
committerRemi Collet <fedora@famillecollet.com>2015-09-24 10:55:31 +0200
commit98ade899037486227746fc33fb6deecadca397a6 (patch)
tree10f09bcd6f2896f7e3a8893dbc9dc52387b54d1d
parentc6c1e373381edbf1b37f823600041068ca3baeef (diff)
php-zendframework-zend-mvc: 2.5.3
-rwxr-xr-xmakesrc.sh1
-rw-r--r--php-zendframework-zend-mvc.spec13
2 files changed, 9 insertions, 5 deletions
diff --git a/makesrc.sh b/makesrc.sh
index 24fbf81..e9a1ec5 100755
--- a/makesrc.sh
+++ b/makesrc.sh
@@ -16,6 +16,7 @@ git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT
echo "Getting commit..."
pushd $PROJECT-$COMMIT
git checkout $COMMIT
+cp composer.json ../composer-$VERSION.json
popd
echo "Archiving..."
diff --git a/php-zendframework-zend-mvc.spec b/php-zendframework-zend-mvc.spec
index 736e69a..560f67f 100644
--- a/php-zendframework-zend-mvc.spec
+++ b/php-zendframework-zend-mvc.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 076b0c8cef37da91427aa43957e9e93fb67370e1
+%global gh_commit bae0da8318323da7dd71d64aa8054f91f782951b
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-mvc
@@ -20,7 +20,7 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.5.2
+Version: 2.5.3
Release: 1%{?dist}
Summary: Zend Framework %{library} component
@@ -92,7 +92,7 @@ BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
# "zendframework/zend-eventmanager": "~2.5",
# "zendframework/zend-servicemanager": "~2.5",
# "zendframework/zend-form": "~2.5",
-# "zendframework/zend-stdlib": "~2.5"
+# "zendframework/zend-stdlib": ">=2.5.0,<2.7.0"
Requires: php(language) >= 5.5
%if ! %{bootstrap}
Requires: php-composer(%{gh_owner}/zend-eventmanager) >= 2.5
@@ -101,8 +101,8 @@ Requires: php-composer(%{gh_owner}/zend-servicemanager) >= 2.5
Requires: php-composer(%{gh_owner}/zend-servicemanager) < 3
Requires: php-composer(%{gh_owner}/zend-form) >= 2.5
Requires: php-composer(%{gh_owner}/zend-form) < 3
-Requires: php-composer(%{gh_owner}/zend-stdlib) >= 2.5
-Requires: php-composer(%{gh_owner}/zend-stdlib) < 3
+Requires: php-composer(%{gh_owner}/zend-stdlib) >= 2.5.0
+Requires: php-composer(%{gh_owner}/zend-stdlib) < 2.7
# From composer, "suggest": {
# "zendframework/zend-authentication": "Zend\\Authentication component for Identity plugin",
# "zendframework/zend-config": "Zend\\Config component",
@@ -222,6 +222,9 @@ rm -rf %{buildroot}
%changelog
+* Thu Sep 24 2015 Remi Collet <remi@fedoraproject.org> - 2.5.3-1
+- version 2.5.3
+
* Tue Sep 15 2015 Remi Collet <remi@fedoraproject.org> - 2.5.2-1
- version 2.5.2