summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-06-29 13:15:58 +0200
committerRemi Collet <fedora@famillecollet.com>2016-06-29 13:15:58 +0200
commit9a4128665632ef7d18f6d0eb8a0845c925c210a4 (patch)
tree0513dc466d440f3d69d43fffdce2adcb3e5fc621
php-zendframework-zend-mvc-plugins: 1.0.1 (New package)
-rw-r--r--Makefile3
-rw-r--r--composer.json32
-rw-r--r--php-zendframework-zend-mvc-plugins.spec88
3 files changed, 123 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..a2cd659
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,3 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..ce9b624
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,32 @@
+{
+ "name": "zendframework/zend-mvc-plugins",
+ "description": "Collection of all stable zend-mvc plugins served via separate packages.",
+ "type": "metapackage",
+ "license": "BSD-3-Clause",
+ "keywords": [
+ "zf2",
+ "mvc",
+ "plugins"
+ ],
+ "homepage": "https://github.com/zendframework/zend-mvc-plugins",
+ "extra": {
+ "branch-alias": {
+ "dev-master": "1.0-dev"
+ },
+ "zf": {
+ "component": [
+ "Zend\\Mvc\\Plugin\\FilePrg",
+ "Zend\\Mvc\\Plugin\\FlashMessenger",
+ "Zend\\Mvc\\Plugin\\Identity",
+ "Zend\\Mvc\\Plugin\\Prg"
+ ]
+ }
+ },
+ "require": {
+ "php": "^5.6 || ^7.0",
+ "zendframework/zend-mvc-plugin-fileprg": "^1.0",
+ "zendframework/zend-mvc-plugin-flashmessenger": "^1.0",
+ "zendframework/zend-mvc-plugin-identity": "^1.0",
+ "zendframework/zend-mvc-plugin-prg": "^1.0"
+ }
+}
diff --git a/php-zendframework-zend-mvc-plugins.spec b/php-zendframework-zend-mvc-plugins.spec
new file mode 100644
index 0000000..3d14218
--- /dev/null
+++ b/php-zendframework-zend-mvc-plugins.spec
@@ -0,0 +1,88 @@
+# remirepo/Fedora spec file for php-zendframework-zend-mvc-plugins
+#
+# Copyright (c) 2016 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%global gh_commit b00cda46b0a95cbd32ea0743d6d7dc3fd2263f1b
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner zendframework
+%global gh_project zend-mvc-plugins
+
+Name: php-%{gh_owner}-%{gh_project}
+Version: 1.0.1
+Release: 1%{?dist}
+Summary: Zend Framework Mvc-%{library} component
+
+Group: Development/Libraries
+License: BSD
+URL: http://framework.zend.com/
+Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{version}-%{gh_short}.tar.gz
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
+BuildArch: noarch
+
+# From composer, "require": {
+# "php": "^5.6 || ^7.0",
+# "zendframework/zend-mvc-plugin-fileprg": "^1.0",
+# "zendframework/zend-mvc-plugin-flashmessenger": "^1.0",
+# "zendframework/zend-mvc-plugin-identity": "^1.0",
+# "zendframework/zend-mvc-plugin-prg": "^1.0"
+Requires: php(language) >= 5.6
+Requires: php-composer(%{gh_owner}/zend-mvc-plugin-fileprg) >= 1.0
+Requires: php-composer(%{gh_owner}/zend-mvc-plugin-fileprg) < 2
+Requires: php-composer(%{gh_owner}/zend-mvc-plugin-flashmessenger) >= 1.0
+Requires: php-composer(%{gh_owner}/zend-mvc-plugin-flashmessenger) < 2
+Requires: php-composer(%{gh_owner}/zend-mvc-plugin-identity) >= 1.0
+Requires: php-composer(%{gh_owner}/zend-mvc-plugin-identity) < 2
+Requires: php-composer(%{gh_owner}/zend-mvc-plugin-prg) >= 1.0
+Requires: php-composer(%{gh_owner}/zend-mvc-plugin-prg) < 2
+
+Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+
+
+%description
+zend-mvc-form is a metapackage that provides a single package for installing
+all packages necessary to fully use zend-form under zend-mvc, including:
+
+* zendframework/zend-code
+* zendframework/zend-form
+* zendframework/zend-i18n
+
+i18n integration: this package only requires zend-i18n, and not zend-mvc-i18n.
+This is to allow providing the bare minimum required to use zend-form, as its
+base view helper extends from the base zend-i18n view helper. If you want to
+provide translations for your form elements, please install zend-mvc-i18n as
+well.
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+
+%build
+# Empty build section, nothing required
+
+
+%install
+# Nothing
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%files
+%defattr(-,root,root,-)
+%{!?_licensedir:%global license %%doc}
+%license LICENSE.md
+%doc CHANGELOG.md README.md
+%doc composer.json
+
+
+%changelog
+* Wed Jun 29 2016 Remi Collet <remi@fedoraproject.org> - 1.0.1-1
+- initial package
+