summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-05-03 13:42:05 +0200
committerRemi Collet <remi@remirepo.net>2018-05-03 13:42:05 +0200
commitc56c8615623d00d85fc383cb1e5c6ae7e56b4430 (patch)
treec93715928754129b0dfa6d515fcbaed4b67934b1
parent85b3d023ee4d2dced35392e3b13b9624989a3e0b (diff)
update to 1.1.0
use range dependencies on F27+ switch to phpunit6 or phpunit7
-rw-r--r--composer.json61
-rw-r--r--php-zendframework-zend-mvc-plugin-identity.spec69
2 files changed, 86 insertions, 44 deletions
diff --git a/composer.json b/composer.json
index 352c559..bc6be02 100644
--- a/composer.json
+++ b/composer.json
@@ -1,19 +1,33 @@
{
"name": "zendframework/zend-mvc-plugin-identity",
- "description": " ",
+ "description": "Plugin for retrieving the current authenticated identity within zend-mvc controllers",
"license": "BSD-3-Clause",
"keywords": [
- "zf2",
+ "zf",
+ "zendframework",
"mvc"
],
- "homepage": "https://github.com/zendframework/zend-mvc-plugin-identity",
- "extra": {
- "branch-alias": {
- "dev-master": "1.0-dev"
- },
- "zf": {
- "component": "Zend\\Mvc\\Plugin\\Identity"
- }
+ "support": {
+ "docs": "https://docs.zendframework.com/zend-mvc-plugin-identity/",
+ "issues": "https://github.com/zendframework/zend-mvc-plugin-identity/issues",
+ "source": "https://github.com/zendframework/zend-mvc-plugin-identity",
+ "rss": "https://github.com/zendframework/zend-mvc-plugin-identity/releases.atom",
+ "chat": "https://zendframework-slack.herokuapp.com",
+ "forum": "https://discourse.zendframework.com/c/questions/components"
+ },
+ "require": {
+ "php": "^5.6 || ^7.0",
+ "container-interop/container-interop": "^1.1",
+ "zendframework/zend-authentication": "^2.5.3",
+ "zendframework/zend-mvc": "^3.0",
+ "zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3"
+ },
+ "require-dev": {
+ "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.4",
+ "zendframework/zend-coding-standard": "~1.0.0"
+ },
+ "conflict": {
+ "zendframework/zend-mvc": "<3.0.0"
},
"autoload": {
"psr-4": {
@@ -25,29 +39,26 @@
"ZendTest\\Mvc\\Plugin\\Identity\\": "test/"
}
},
- "require": {
- "php": "^5.6 || ^7.0",
- "container-interop/container-interop": "^1.1",
- "zendframework/zend-mvc": "^3.0",
- "zendframework/zend-authentication": "^2.5.3",
- "zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3"
- },
- "require-dev": {
- "phpunit/PHPUnit": "^4.5",
- "squizlabs/php_codesniffer": "^2.3.1"
+ "config": {
+ "sort-packages": true
},
- "conflict": {
- "zendframework/zend-mvc": "< 3.0.0"
+ "extra": {
+ "branch-alias": {
+ "dev-master": "1.1.x-dev",
+ "dev-develop": "1.2.x-dev"
+ },
+ "zf": {
+ "component": "Zend\\Mvc\\Plugin\\Identity"
+ }
},
"scripts": {
"check": [
"@cs-check",
"@test"
],
- "upload-coverage": "coveralls",
"cs-check": "phpcs",
"cs-fix": "phpcbf",
- "test": "phpunit",
- "test-coverage": "phpunit --coverage-clover clover.xml"
+ "test": "phpunit --colors=always",
+ "test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
}
}
diff --git a/php-zendframework-zend-mvc-plugin-identity.spec b/php-zendframework-zend-mvc-plugin-identity.spec
index 2f87a38..285ada7 100644
--- a/php-zendframework-zend-mvc-plugin-identity.spec
+++ b/php-zendframework-zend-mvc-plugin-identity.spec
@@ -1,13 +1,13 @@
# remirepo/Fedora spec file for php-zendframework-zend-mvc-plugin-identity
#
-# Copyright (c) 2016-2017 Remi Collet
+# Copyright (c) 2016-2018 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 7677ef175e4ce5e15dbe0c1cd520bbe381a31460
+%global gh_commit 4073192d875d6f7ae90adadd21d7e980faaac4a1
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-mvc-plugin-identity
@@ -20,8 +20,8 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 1.0.0
-Release: 4%{?dist}
+Version: 1.1.0
+Release: 1%{?dist}
Summary: Zend Framework Mvc-Plugin-%{library} component
Group: Development/Libraries
@@ -34,15 +34,31 @@ BuildArch: noarch
# Tests
%if %{with_tests}
BuildRequires: php(language) >= 5.6
+BuildRequires: php-spl
+# From composer, "require-dev": {
+# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.4",
+# "zendframework/zend-coding-standard": "~1.0.0"
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (php-composer(container-interop/container-interop) >= 1.1 with php-composer(container-interop/container-interop) < 2)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-authentication) >= 2.5.3 with php-autoloader(%{gh_owner}/zend-authentication) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-mvc) >= 3.0 with php-autoloader(%{gh_owner}/zend-mvc) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-servicemanager) >= 2.7.5 with php-autoloader(%{gh_owner}/zend-servicemanager) < 4)
+%global phpunit %{_bindir}/phpunit7
+BuildRequires: phpunit7 >= 7.1.4
+# remirepo:12
+%else
+BuildRequires: php-composer(container-interop/container-interop) < 2
BuildRequires: php-composer(container-interop/container-interop) >= 1.1
-BuildRequires: php-autoloader(%{gh_owner}/zend-mvc) >= 3.0
+BuildRequires: php-autoloader(%{gh_owner}/zend-authentication) < 3
BuildRequires: php-autoloader(%{gh_owner}/zend-authentication) >= 2.5.3
+BuildRequires: php-autoloader(%{gh_owner}/zend-mvc) < 4
+BuildRequires: php-autoloader(%{gh_owner}/zend-mvc) >= 3.0
+BuildRequires: php-autoloader(%{gh_owner}/zend-servicemanager) < 4
BuildRequires: php-autoloader(%{gh_owner}/zend-servicemanager) >= 2.7.5
-BuildRequires: php-spl
-# From composer, "require-dev": {
-# "phpunit/PHPUnit": "^4.5",
-# "squizlabs/php_codesniffer": "^2.3.1"
-BuildRequires: php-composer(phpunit/phpunit) >= 4.5
+%global phpunit %{_bindir}/phpunit6
+BuildRequires: phpunit6 >= 6.5.8
+%endif
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
@@ -50,18 +66,27 @@ BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
# "php": "^5.6 || ^7.0",
# "container-interop/container-interop": "^1.1",
-# "zendframework/zend-mvc": "^3.0",
# "zendframework/zend-authentication": "^2.5.3",
+# "zendframework/zend-mvc": "^3.0",
# "zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3"
Requires: php(language) >= 5.6
-Requires: php-composer(container-interop/container-interop) >= 1.1
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Requires: (php-composer(container-interop/container-interop) >= 1.1 with php-composer(container-interop/container-interop) < 2)
+Requires: (php-autoloader(%{gh_owner}/zend-authentication) >= 2.5.3 with php-autoloader(%{gh_owner}/zend-authentication) < 3)
+Requires: (php-autoloader(%{gh_owner}/zend-mvc) >= 3.0 with php-autoloader(%{gh_owner}/zend-mvc) < 4)
+Requires: (php-autoloader(%{gh_owner}/zend-servicemanager) >= 2.7.5 with php-autoloader(%{gh_owner}/zend-servicemanager) < 4)
+# remirepo:10
+%else
Requires: php-composer(container-interop/container-interop) < 2
-Requires: php-autoloader(%{gh_owner}/zend-mvc) >= 3.0
-Requires: php-autoloader(%{gh_owner}/zend-mvc) < 4
-Requires: php-autoloader(%{gh_owner}/zend-authentication) >= 2.5.3
+Requires: php-composer(container-interop/container-interop) >= 1.1
Requires: php-autoloader(%{gh_owner}/zend-authentication) < 3
-Requires: php-autoloader(%{gh_owner}/zend-servicemanager) >= 2.7.5
+Requires: php-autoloader(%{gh_owner}/zend-authentication) >= 2.5.3
+Requires: php-autoloader(%{gh_owner}/zend-mvc) < 4
+Requires: php-autoloader(%{gh_owner}/zend-mvc) >= 3.0
Requires: php-autoloader(%{gh_owner}/zend-servicemanager) < 4
+Requires: php-autoloader(%{gh_owner}/zend-servicemanager) >= 2.7.5
+%endif
# Autoloader
Requires: php-composer(fedora/autoloader)
# From phpcompatinfo report for version 1.0.0
@@ -121,9 +146,10 @@ require_once '%{buildroot}%{php_home}/Zend/Mvc/Plugin/%{library}/autoload.php';
EOF
ret=0
-for cmd in php php56 php70 php71 php72; do
- if which $cmd; then
- $cmd %{_bindir}/phpunit || ret=1
+for cmdarg in "php %{phpunit}" "php70 %{_bindir}/phpunit6" php71 php72; do
+ if which $cmdarg; then
+ set $cmdarg
+ $1 ${2:-%{_bindir}/phpunit7} --verbose || ret=1
fi
done
exit $ret
@@ -142,6 +168,11 @@ exit $ret
%changelog
+* Thu May 3 2018 Remi Collet <remi@remirepo.net> - 1.1.0-1
+- update to 1.1.0
+- use range dependencies on F27+
+- switch to phpunit6 or phpunit7
+
* Wed Dec 13 2017 Remi Collet <remi@remirepo.net> - 1.0.0-4
- switch from zend-loader to fedora/autoloader