summaryrefslogtreecommitdiffstats
path: root/php-zendframework-zend-mvc-i18n.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-zendframework-zend-mvc-i18n.spec')
-rw-r--r--php-zendframework-zend-mvc-i18n.spec87
1 files changed, 63 insertions, 24 deletions
diff --git a/php-zendframework-zend-mvc-i18n.spec b/php-zendframework-zend-mvc-i18n.spec
index a7be943..5ab6926 100644
--- a/php-zendframework-zend-mvc-i18n.spec
+++ b/php-zendframework-zend-mvc-i18n.spec
@@ -1,13 +1,13 @@
# remirepo/Fedora spec file for php-zendframework-zend-mvc-i18n
#
-# Copyright (c) 2016-2017 Remi Collet
+# Copyright (c) 2016-2018 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 5a7068160d3884263932c919c2250cb4a4a66501
+%global gh_commit 90e64d1304385cfcf19447b6449514e8a720adfc
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-mvc-i18n
@@ -20,8 +20,8 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 1.0.0
-Release: 4%{?dist}
+Version: 1.1.0
+Release: 1%{?dist}
Summary: Zend Framework Mvc-%{library} component
Group: Development/Libraries
@@ -34,20 +34,42 @@ BuildArch: noarch
# Tests
%if %{with_tests}
BuildRequires: php(language) >= 5.6
+BuildRequires: php-intl
+BuildRequires: php-spl
+# From composer, "require-dev": {
+# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.5",
+# "zendframework/zend-cache": "^2.6.1",
+# "zendframework/zend-coding-standard": "~1.0.0"
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (php-composer(container-interop/container-interop) >= 1.1 with php-composer(container-interop/container-interop) < 2)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-i18n) >= 2.7 with php-autoloader(%{gh_owner}/zend-i18n) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-router) >= 3.0 with php-autoloader(%{gh_owner}/zend-router) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-servicemanager) >= 2.7.10 with php-autoloader(%{gh_owner}/zend-servicemanager) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7.6 with php-autoloader(%{gh_owner}/zend-stdlib) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-validator) >= 2.6 with php-autoloader(%{gh_owner}/zend-validator) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-cache) >= 2.6.1 with php-autoloader(%{gh_owner}/zend-cache) < 3)
+%global phpunit %{_bindir}/phpunit7
+BuildRequires: phpunit7 >= 7.1.4
+# remirepo:18
+%else
+BuildRequires: php-composer(container-interop/container-interop) < 2
BuildRequires: php-composer(container-interop/container-interop) >= 1.1
+BuildRequires: php-autoloader(%{gh_owner}/zend-i18n) < 3
BuildRequires: php-autoloader(%{gh_owner}/zend-i18n) >= 2.7
+BuildRequires: php-autoloader(%{gh_owner}/zend-router) < 4
BuildRequires: php-autoloader(%{gh_owner}/zend-router) >= 3.0
-BuildRequires: php-autoloader(%{gh_owner}/zend-servicemanager) >= 2.7.5
+BuildRequires: php-autoloader(%{gh_owner}/zend-servicemanager) < 4
+BuildRequires: php-autoloader(%{gh_owner}/zend-servicemanager) >= 2.7.10
+BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) < 4
BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7.6
+BuildRequires: php-autoloader(%{gh_owner}/zend-validator) < 3
BuildRequires: php-autoloader(%{gh_owner}/zend-validator) >= 2.6
-BuildRequires: php-intl
-BuildRequires: php-spl
-# From composer, "require-dev": {
-# "phpunit/phpunit": "^4.5",
-# "squizlabs/php_codesniffer": "^2.3.1",
-# "zendframework/zend-cache": "^2.6.1"
-BuildRequires: php-composer(phpunit/phpunit) >= 4.5
+BuildRequires: php-autoloader(%{gh_owner}/zend-cache) < 3
BuildRequires: php-autoloader(%{gh_owner}/zend-cache) >= 2.6.1
+%global phpunit %{_bindir}/phpunit6
+BuildRequires: phpunit6 >= 6.5.8
+%endif
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
@@ -57,22 +79,34 @@ BuildRequires: php-fedora-autoloader-devel
# "container-interop/container-interop": "^1.1",
# "zendframework/zend-i18n": "^2.7",
# "zendframework/zend-router": "^3.0",
-# "zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3",
+# "zendframework/zend-servicemanager": "^2.7.10 || ^3.0.3",
# "zendframework/zend-stdlib": "^2.7.6 || ^3.0",
# "zendframework/zend-validator": "^2.6"
Requires: php(language) >= 5.6
-Requires: php-composer(container-interop/container-interop) >= 1.1
+Requires: php(language) >= 5.6
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Requires: (php-composer(container-interop/container-interop) >= 1.1 with php-composer(container-interop/container-interop) < 2)
+Requires: (php-autoloader(%{gh_owner}/zend-i18n) >= 2.7 with php-autoloader(%{gh_owner}/zend-i18n) < 3)
+Requires: (php-autoloader(%{gh_owner}/zend-router) >= 3.0 with php-autoloader(%{gh_owner}/zend-router) < 4)
+Requires: (php-autoloader(%{gh_owner}/zend-servicemanager) >= 2.7.10 with php-autoloader(%{gh_owner}/zend-servicemanager) < 4)
+Requires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7.6 with php-autoloader(%{gh_owner}/zend-stdlib) < 4)
+Requires: (php-autoloader(%{gh_owner}/zend-validator) >= 2.6 with php-autoloader(%{gh_owner}/zend-validator) < 3)
+# remirepo:14
+%else
Requires: php-composer(container-interop/container-interop) < 2
-Requires: php-autoloader(%{gh_owner}/zend-i18n) >= 2.7
+Requires: php-composer(container-interop/container-interop) >= 1.1
Requires: php-autoloader(%{gh_owner}/zend-i18n) < 3
-Requires: php-autoloader(%{gh_owner}/zend-router) >= 3.0
+Requires: php-autoloader(%{gh_owner}/zend-i18n) >= 2.7
Requires: php-autoloader(%{gh_owner}/zend-router) < 4
-Requires: php-autoloader(%{gh_owner}/zend-servicemanager) >= 2.7.5
+Requires: php-autoloader(%{gh_owner}/zend-router) >= 3.0
Requires: php-autoloader(%{gh_owner}/zend-servicemanager) < 4
-Requires: php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7.6
+Requires: php-autoloader(%{gh_owner}/zend-servicemanager) >= 2.7.10
Requires: php-autoloader(%{gh_owner}/zend-stdlib) < 4
-Requires: php-autoloader(%{gh_owner}/zend-validator) >= 2.6
+Requires: php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7.6
Requires: php-autoloader(%{gh_owner}/zend-validator) < 3
+Requires: php-autoloader(%{gh_owner}/zend-validator) >= 2.6
+%endif
# Autoloader
Requires: php-composer(fedora/autoloader)
# From phpcompatinfo report for version 1.0.0
@@ -81,10 +115,8 @@ Requires: php-spl
%if ! %{bootstrap}
# From composer, "suggest": {
# "zendframework/zend-cache": "To enable caching of translation strings"
-%if 0%{?fedora} >= 21
Suggests: php-autoloader(%{gh_owner}/zend-cache)
%endif
-%endif
Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
Provides: php-autoloader(%{gh_owner}/%{gh_project}) = %{version}
@@ -152,9 +184,10 @@ require_once '%{buildroot}%{php_home}/Zend/Mvc/%{library}/autoload.php';
EOF
ret=0
-for cmd in php php56 php70 php71 php72; do
- if which $cmd; then
- $cmd %{_bindir}/phpunit || ret=1
+for cmdarg in "php %{phpunit}" "php70 %{_bindir}/phpunit6" php71 php72; do
+ if which $cmdarg; then
+ set $cmdarg
+ $1 ${2:-%{_bindir}/phpunit7} --verbose || ret=1
fi
done
exit $ret
@@ -173,6 +206,12 @@ exit $ret
%changelog
+* Thu May 3 2018 Remi Collet <remi@remirepo.net> - 1.1.0-1
+- update to 1.1.0
+- use range dependencies on F27+
+- switch to phpunit6 or phpunit7
+- raise dependency on zend-servicemanager 2.7.10
+
* Mon Dec 11 2017 Remi Collet <remi@remirepo.net> - 1.1.10-4
- switch from zend-loader to fedora/autoloader