summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-09-06 13:49:50 +0200
committerRemi Collet <remi@remirepo.net>2019-09-06 13:49:50 +0200
commite35e92e248354df51fd3840aa91082631496fb2c (patch)
tree4b8cd2f990d4aae65cce79bf74f926b2f9e9e8b8
parent5fc7b9fde8c32624e6d7d963cab8232dfca14871 (diff)
update to 1.1.1 (no change)HEADmaster
-rw-r--r--composer.json1
-rw-r--r--php-zendframework-zend-mvc-i18n.spec16
2 files changed, 10 insertions, 7 deletions
diff --git a/composer.json b/composer.json
index 99f6b5d..d6a31d9 100644
--- a/composer.json
+++ b/composer.json
@@ -31,6 +31,7 @@
"zendframework/zend-coding-standard": "~1.0.0"
},
"conflict": {
+ "phpspec/prophecy": "<1.8.0",
"zendframework/zend-mvc": "<3.0.0"
},
"suggest": {
diff --git a/php-zendframework-zend-mvc-i18n.spec b/php-zendframework-zend-mvc-i18n.spec
index 5ab6926..7a1996f 100644
--- a/php-zendframework-zend-mvc-i18n.spec
+++ b/php-zendframework-zend-mvc-i18n.spec
@@ -1,13 +1,13 @@
# remirepo/Fedora spec file for php-zendframework-zend-mvc-i18n
#
-# Copyright (c) 2016-2018 Remi Collet
+# Copyright (c) 2016-2019 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 90e64d1304385cfcf19447b6449514e8a720adfc
+%global gh_commit 7a1b3aca3a8874adb32390d34794cdc525c1c909
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-mvc-i18n
@@ -20,11 +20,10 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 1.1.0
+Version: 1.1.1
Release: 1%{?dist}
Summary: Zend Framework Mvc-%{library} component
-Group: Development/Libraries
License: BSD
URL: https://zendframework.github.io/%{gh_project}/
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
@@ -50,7 +49,7 @@ BuildRequires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7.6 with
BuildRequires: (php-autoloader(%{gh_owner}/zend-validator) >= 2.6 with php-autoloader(%{gh_owner}/zend-validator) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/zend-cache) >= 2.6.1 with php-autoloader(%{gh_owner}/zend-cache) < 3)
%global phpunit %{_bindir}/phpunit7
-BuildRequires: phpunit7 >= 7.1.4
+BuildRequires: phpunit7 >= 7.1.5
# remirepo:18
%else
BuildRequires: php-composer(container-interop/container-interop) < 2
@@ -83,7 +82,6 @@ BuildRequires: php-fedora-autoloader-devel
# "zendframework/zend-stdlib": "^2.7.6 || ^3.0",
# "zendframework/zend-validator": "^2.6"
Requires: php(language) >= 5.6
-Requires: php(language) >= 5.6
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-composer(container-interop/container-interop) >= 1.1 with php-composer(container-interop/container-interop) < 2)
@@ -184,7 +182,7 @@ require_once '%{buildroot}%{php_home}/Zend/Mvc/%{library}/autoload.php';
EOF
ret=0
-for cmdarg in "php %{phpunit}" "php70 %{_bindir}/phpunit6" php71 php72; do
+for cmdarg in "php %{phpunit}" php71 php72 php73 php74; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit7} --verbose || ret=1
@@ -197,6 +195,7 @@ exit $ret
%files
+# remirepo:1
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md
@@ -206,6 +205,9 @@ exit $ret
%changelog
+* Fri Sep 6 2019 Remi Collet <remi@remirepo.net> - 1.1.1-1
+- update to 1.1.1 (no change)
+
* Thu May 3 2018 Remi Collet <remi@remirepo.net> - 1.1.0-1
- update to 1.1.0
- use range dependencies on F27+