summaryrefslogtreecommitdiffstats
path: root/php-zendframework-zend-modulemanager.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-zendframework-zend-modulemanager.spec')
-rw-r--r--php-zendframework-zend-modulemanager.spec50
1 files changed, 16 insertions, 34 deletions
diff --git a/php-zendframework-zend-modulemanager.spec b/php-zendframework-zend-modulemanager.spec
index 8b395f5..543597d 100644
--- a/php-zendframework-zend-modulemanager.spec
+++ b/php-zendframework-zend-modulemanager.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 2a59ab9a0dd7699a55050dff659ab0f28272b46e
+%global gh_commit 248cf20a5ea08727d84ad7c122110d70c62b48df
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-modulemanager
@@ -20,8 +20,8 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.7.2
-Release: 2%{?dist}
+Version: 2.7.3
+Release: 1%{?dist}
Summary: Zend Framework %{library} component
Group: Development/Libraries
@@ -30,10 +30,6 @@ URL: https://zendframework.github.io/%{gh_project}/
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
-# https://github.com/zendframework/zend-modulemanager/pull/55
-Patch0: %{name}-pr55.patch
-
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
# Tests
%if %{with_tests}
@@ -48,8 +44,8 @@ BuildRequires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7
# "zendframework/zend-loader": "^2.5",
# "zendframework/zend-mvc": "^2.7",
# "zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3",
-# "fabpot/php-cs-fixer": "1.7.*",
-# "phpunit/PHPUnit": "~4.0"
+# "phpunit/PHPUnit": "~4.0",
+# "zendframework/zend-coding-standard": "~1.0.0"
BuildRequires: php-composer(%{gh_owner}/zend-console) >= 2.6
BuildRequires: php-composer(%{gh_owner}/zend-di) >= 2.6
BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
@@ -64,13 +60,13 @@ BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
# From composer, "require": {
# "php": "^5.5 || ^7.0",
-# "zendframework/zend-config": "^2.6",
+# "zendframework/zend-config": "^2.6 || ^3.1",
# "zendframework/zend-eventmanager": "^2.6.2 || ^3.0",
# "zendframework/zend-stdlib": "^2.7 || ^3.0"
Requires: php(language) >= 5.5
%if ! %{bootstrap}
Requires: php-composer(%{gh_owner}/zend-config) >= 2.6
-Requires: php-composer(%{gh_owner}/zend-config) < 3
+Requires: php-composer(%{gh_owner}/zend-config) < 4
Requires: php-composer(%{gh_owner}/zend-eventmanager) >= 2.6.2
Requires: php-composer(%{gh_owner}/zend-eventmanager) < 4
Requires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7
@@ -111,7 +107,6 @@ Documentation: https://zendframework.github.io/%{gh_project}/
%prep
%setup -q -n %{gh_project}-%{gh_commit}
-%patch0 -p1
mv LICENSE.md LICENSE
@@ -121,8 +116,6 @@ mv LICENSE.md LICENSE
%install
-rm -rf %{buildroot}
-
mkdir -p %{buildroot}%{php_home}/Zend/
cp -pr src %{buildroot}%{php_home}/Zend/%{library}
@@ -142,33 +135,19 @@ Zend\Loader\AutoloaderFactory::factory(array(
require_once '%{php_home}/Zend/autoload.php';
EOF
-# remirepo:11
-run=0
ret=0
-if which php56; then
- php56 %{_bindir}/phpunit || ret=1
- run=1
-fi
-if which php71; then
- php71 %{_bindir}/phpunit || ret=1
- run=1
-fi
-if [ $run -eq 0 ]; then
-%{_bindir}/phpunit --verbose
-# remirepo:2
-fi
+for cmd in php php56 php70 php71 php72; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit --verbose || ret=1
+ fi
+done
exit $ret
%else
: Test suite disabled
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md
@@ -177,7 +156,10 @@ rm -rf %{buildroot}
%changelog
-* Thu Feb 22 2017 Remi Collet <remi@fedoraproject.org> - 2.7.2-2
+* Wed Jul 12 2017 Remi Collet <remi@remirepo.net> - 2.7.3-1
+- Update to 2.7.3
+
+* Wed Feb 22 2017 Remi Collet <remi@fedoraproject.org> - 2.7.2-2
- add fix for tests against PHP 7.1, fix FTBFS #1424086
from https://github.com/zendframework/zend-modulemanager/pull/55