summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-10-17 08:17:45 +0200
committerRemi Collet <remi@remirepo.net>2019-10-17 08:17:45 +0200
commit7d4a57f235e1e0293ef8a4dc7282fc3495dda416 (patch)
treefd4479e98bb6636ff9efb724e3f2ed6fa8e76255
parent54f9c283bcf2fcf9371fbb867ad75a85680f21ab (diff)
-rw-r--r--composer.json11
-rw-r--r--php-zendframework-zend-mime.spec12
2 files changed, 12 insertions, 11 deletions
diff --git a/composer.json b/composer.json
index 356e974..3911429 100644
--- a/composer.json
+++ b/composer.json
@@ -12,7 +12,7 @@
"issues": "https://github.com/zendframework/zend-mime/issues",
"source": "https://github.com/zendframework/zend-mime",
"rss": "https://github.com/zendframework/zend-mime/releases.atom",
- "slack": "https://zendframework-slack.herokuapp.com",
+ "chat": "https://zendframework-slack.herokuapp.com",
"forum": "https://discourse.zendframework.com/c/questions/components"
},
"require": {
@@ -21,7 +21,7 @@
},
"require-dev": {
"zendframework/zend-mail": "^2.6",
- "phpunit/PHPUnit": "^5.7.21 || ^6.3",
+ "phpunit/phpunit": "^5.7.21 || ^6.3",
"zendframework/zend-coding-standard": "~1.0.0"
},
"suggest": {
@@ -42,8 +42,8 @@
},
"extra": {
"branch-alias": {
- "dev-master": "2.7-dev",
- "dev-develop": "2.8-dev"
+ "dev-master": "2.7.x-dev",
+ "dev-develop": "2.8.x-dev"
}
},
"scripts": {
@@ -55,6 +55,5 @@
"cs-fix": "phpcbf",
"test": "phpunit --colors=always",
"test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
- },
- "homepage": "https://github.com/zendframework/zend-mime"
+ }
}
diff --git a/php-zendframework-zend-mime.spec b/php-zendframework-zend-mime.spec
index dfb0bb7..0a4ced6 100644
--- a/php-zendframework-zend-mime.spec
+++ b/php-zendframework-zend-mime.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 52ae5fa9f12845cae749271034a2d594f0e4c6f2
+%global gh_commit c91e0350be53cc9d29be15563445eec3b269d7c1
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-mime
@@ -20,11 +20,10 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.7.1
+Version: 2.7.2
Release: 2%{?dist}
Summary: Zend Framework %{library} component
-Group: Development/Libraries
License: BSD
URL: https://zendframework.github.io/%{gh_project}/
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
@@ -39,7 +38,7 @@ BuildRequires: php-pcre
BuildRequires: php-spl
# From composer, "require-dev": {
# "zendframework/zend-mail": "^2.6"",
-# "phpunit/PHPUnit": "^5.7.21 || ^6.3",
+# "phpunit/phpunit": "^5.7.21 || ^6.3",
# "zendframework/zend-coding-standard": "~1.0.0"
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
@@ -135,7 +134,7 @@ require_once '%{buildroot}%{php_home}/Zend/%{library}/autoload.php';
EOF
ret=0
-for cmd in "php %{phpunit}" "php56 %{_bindir}/phpunit" php70 php71 php72; do
+for cmd in "php %{phpunit}" "php56 %{_bindir}/phpunit" php70 php71 php72 php73 php74; do
if which $cmd; then
set $cmd
$1 ${2:-%{_bindir}/phpunit6} --verbose || ret=1
@@ -156,6 +155,9 @@ exit $ret
%changelog
+* Thu Oct 17 2019 Remi Collet <remi@remirepo.net> - 2.7.2-1
+- update to 2.7.2
+
* Tue May 15 2018 Remi Collet <remi@remirepo.net> - 2.7.1-2
- update to 2.7.1
- use range dependencies on F27+