summaryrefslogtreecommitdiffstats
path: root/php-zendframework-zend-memory.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-zendframework-zend-memory.spec')
-rw-r--r--php-zendframework-zend-memory.spec18
1 files changed, 11 insertions, 7 deletions
diff --git a/php-zendframework-zend-memory.spec b/php-zendframework-zend-memory.spec
index ad4b737..8340771 100644
--- a/php-zendframework-zend-memory.spec
+++ b/php-zendframework-zend-memory.spec
@@ -1,13 +1,13 @@
# remirepo/Fedora spec file for php-zendframework-zend-memory
#
-# Copyright (c) 2015-2017 Remi Collet
+# Copyright (c) 2015-2018 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit bbf8b9509660b2a97f2d6ccfefabffac3cca6a5c
+%global gh_commit a01d5eb74012c2a170e1ea1e18486152d2eea5f7
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-memory
@@ -20,7 +20,7 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.5.2
+Version: 2.6.0
Release: 1%{?dist}
Summary: Zend Framework %{library} component
@@ -33,7 +33,7 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.5
+BuildRequires: php(language) >= 5.6
BuildRequires: php-spl
# From composer, "require-dev": {
# "zendframework/zend-cache": "^2.7",
@@ -46,8 +46,8 @@ BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
%endif
# From composer, "require": {
-# "php": "^5.5 || ^7.0"
-Requires: php(language) >= 5.5
+# "php": "^5.6 || ^7.0"
+Requires: php(language) >= 5.6
%if ! %{bootstrap}
# From composer, "suggest": {
# "zendframework/zend-cache": "To support swapping memory objects into and out of non-memory cache storage"
@@ -111,7 +111,7 @@ require_once '%{php_home}/Zend/autoload.php';
EOF
ret=0
-for cmd in php php70 php71 php72; do
+for cmd in php php56 php70 php71 php72; do
if which $cmd; then
$cmd %{_bindir}/phpunit --verbose || ret=1
fi
@@ -131,6 +131,10 @@ exit $ret
%changelog
+* Thu May 3 2018 Remi Collet <remi@remirepo.net> - 2.6.0-1
+- update to 2.6.0
+- raise dependency on PHP 5.6
+
* Wed May 11 2016 Remi Collet <remi@fedoraproject.org> - 2.5.2-1
- update to 2.5.2
- raise dependency on PHP >= 5.5