summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-07-11 06:44:47 +0200
committerRemi Collet <remi@remirepo.net>2018-07-11 06:44:47 +0200
commit6cca7ee5caff02628c8babecfd54cb6fe6859c1d (patch)
treeccbf5ee67b9a5f96fdd63456bf131a76249ceed8
parent886b94168c5304d642908b5f3e04b98ecf48f0bc (diff)
v3.1.1
-rw-r--r--composer.json5
-rw-r--r--php-zendframework-zend-math.spec10
2 files changed, 11 insertions, 4 deletions
diff --git a/composer.json b/composer.json
index a8d1abf..324eac2 100644
--- a/composer.json
+++ b/composer.json
@@ -36,7 +36,10 @@
"autoload-dev": {
"psr-4": {
"ZendTest\\Math\\": "test/"
- }
+ },
+ "files" : [
+ "test/TestAsset/random_bytes.php"
+ ]
},
"config": {
"sort-packages": true
diff --git a/php-zendframework-zend-math.spec b/php-zendframework-zend-math.spec
index da5e260..9f15f29 100644
--- a/php-zendframework-zend-math.spec
+++ b/php-zendframework-zend-math.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 558806e338ee68575fbe69489c9dcb6d57a1dae0
+%global gh_commit 0aa5ec1b3132dd7d749d4673d7bdc7ab6b2d202a
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-math
@@ -20,7 +20,7 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 3.1.0
+Version: 3.1.1
Release: 1%{?dist}
Summary: Zend Framework %{library} component
@@ -139,10 +139,11 @@ cat << 'EOF' | tee vendor/autoload.php
<?php
require_once '%{buildroot}%{php_home}/Zend/%{library}/autoload.php';
\Fedora\Autoloader\Autoload::addPsr4('ZendTest\\%{library}\\', dirname(__DIR__) . '/test');
+require_once dirname(__DIR__) . '/test/TestAsset/random_bytes.php';
EOF
ret=0
-for cmdarg in "php %{phpunit}" "php56 %{_bindir}/phpunit" "php70 %{_bindir}/phpunit6" php71 php72; do
+for cmdarg in "php %{phpunit}" "php56 %{_bindir}/phpunit" "php70 %{_bindir}/phpunit6" php71 php72 php73; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit7} --verbose || ret=1
@@ -165,6 +166,9 @@ exit $ret
%changelog
+* Wed Jul 11 2018 Remi Collet <remi@remirepo.net> - 3.1.1-1
+- update to 3.1.1
+
* Fri Apr 27 2018 Remi Collet <remi@remirepo.net> - 3.1.0-1
- update to 3.1.0
- raise dependency on PHP 5.6