summaryrefslogtreecommitdiffstats
path: root/php-zendframework-zend-mail.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-zendframework-zend-mail.spec')
-rw-r--r--php-zendframework-zend-mail.spec72
1 files changed, 44 insertions, 28 deletions
diff --git a/php-zendframework-zend-mail.spec b/php-zendframework-zend-mail.spec
index 56221ff..0a97aaa 100644
--- a/php-zendframework-zend-mail.spec
+++ b/php-zendframework-zend-mail.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 067248425f285dec0bdb74256a8f67f9092f115e
+%global gh_commit d7beb63d5f7144a21ac100072c453e63860cdab8
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-mail
@@ -20,8 +20,8 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.9.0
-Release: 1%{?dist}
+Version: 2.10.0
+Release: 2%{?dist}
Summary: Zend Framework %{library} component
License: BSD
@@ -32,19 +32,20 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 7.1
+BuildRequires: php(language) >= 5.6
BuildRequires: php-ctype
BuildRequires: php-date
BuildRequires: php-iconv
BuildRequires: php-pcre
BuildRequires: php-spl
# remirepo:1
-%if 0%{fedora} >= 27
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-autoloader(%{gh_owner}/zend-loader) >= 2.5 with php-autoloader(%{gh_owner}/zend-loader) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/zend-mime) >= 2.5 with php-autoloader(%{gh_owner}/zend-mime) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7 with php-autoloader(%{gh_owner}/zend-stdlib) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/zend-validator) >= 2.10.2 with php-autoloader(%{gh_owner}/zend-validator) < 3)
-# remirepo:10
+BuildRequires: (php-composer(true/punycode) >= 2.1 with php-composer(true/punycode) < 3)
+# remirepo:12
%else
BuildRequires: php-autoloader(%{gh_owner}/zend-loader) < 3
BuildRequires: php-autoloader(%{gh_owner}/zend-loader) >= 2.5
@@ -54,49 +55,55 @@ BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) < 4
BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7
BuildRequires: php-autoloader(%{gh_owner}/zend-validator) < 3
BuildRequires: php-autoloader(%{gh_owner}/zend-validator) >= 2.10.2
+BuildRequires: php-composer(true/punycode) >= 2.1
+BuildRequires: php-composer(true/punycode) < 3
%endif
# From composer, "require-dev": {
+# "phpunit/phpunit": "^5.7.25 || ^6.4.4 || ^7.1.4",
+# "zendframework/zend-coding-standard": "~1.0.0",
# "zendframework/zend-config": "^2.6",
-# "zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3",
-# ignore and allow v3
-# "zendframework/zend-crypt": "^2.6",
-# "phpunit/phpunit": "^6.0.8 || ^5.7.15",
-# "zendframework/zend-coding-standard": "~1.0.0"
+# "zendframework/zend-crypt": "^2.6 || ^3.0",
+# "zendframework/zend-servicemanager": "^2.7.10 || ^3.3.1"
# remirepo:1
-%if 0%{fedora} >= 27
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-autoloader(%{gh_owner}/zend-config) >= 2.6 with php-autoloader(%{gh_owner}/zend-config) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/zend-servicemanager) >= 2.7.5 with php-autoloader(%{gh_owner}/zend-servicemanager) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/zend-crypt) >= 2.6 with php-autoloader(%{gh_owner}/zend-crypt) < 4)
-# remirepo:8
+BuildRequires: (php-autoloader(%{gh_owner}/zend-servicemanager) >= 2.7.10 with php-autoloader(%{gh_owner}/zend-servicemanager) < 4)
+BuildRequires: phpunit7 >= 7.1.4
+%global phpunit %{_bindir}/phpunit7
+# remirepo:10
%else
BuildRequires: php-autoloader(%{gh_owner}/zend-config) < 3
BuildRequires: php-autoloader(%{gh_owner}/zend-config) >= 2.6
-BuildRequires: php-autoloader(%{gh_owner}/zend-servicemanager) < 4
-BuildRequires: php-autoloader(%{gh_owner}/zend-servicemanager) >= 2.7.5
BuildRequires: php-autoloader(%{gh_owner}/zend-crypt) < 4
BuildRequires: php-autoloader(%{gh_owner}/zend-crypt) >= 2.6
+BuildRequires: php-autoloader(%{gh_owner}/zend-servicemanager) < 4
+BuildRequires: php-autoloader(%{gh_owner}/zend-servicemanager) >= 2.7.10
+BuildRequires: phpunit6 >= 6.4.4
+%global phpunit %{_bindir}/phpunit6
%endif
-BuildRequires: phpunit6
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^7.1",
+# "php": "^5.6 || ^7.0",
# "ext-iconv": "*",
# "zendframework/zend-loader": "^2.5",
# "zendframework/zend-mime": "^2.5",
# "zendframework/zend-stdlib": "^2.7 || ^3.0",
-# "zendframework/zend-validator": "^2.10.2"
-Requires: php(language) >= 7.1
+# "zendframework/zend-validator": "^2.10.2",
+# "true/punycode": "^2.1"
+Requires: php(language) >= 5.6
Requires: php-iconv
%if ! %{bootstrap}
# remirepo:1
-%if 0%{fedora} >= 27
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-autoloader(%{gh_owner}/zend-loader) >= 2.5 with php-autoloader(%{gh_owner}/zend-loader) < 3)
Requires: (php-autoloader(%{gh_owner}/zend-mime) >= 2.5 with php-autoloader(%{gh_owner}/zend-mime) < 3)
Requires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7 with php-autoloader(%{gh_owner}/zend-stdlib) < 4)
Requires: (php-autoloader(%{gh_owner}/zend-validator) >= 2.10.2 with php-autoloader(%{gh_owner}/zend-validator) < 3)
+Requires: (php-composer(true/punycode) >= 2.1 with php-composer(true/punycode) < 3)
# remirepo:10
%else
Requires: php-autoloader(%{gh_owner}/zend-loader) >= 2.5
@@ -107,15 +114,17 @@ Requires: php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7
Requires: php-autoloader(%{gh_owner}/zend-stdlib) < 4
Requires: php-autoloader(%{gh_owner}/zend-validator) >= 2.10.2
Requires: php-autoloader(%{gh_owner}/zend-validator) < 3
+Requires: php-composer(true/punycode) >= 2.1
+Requires: php-composer(true/punycode) < 3
%endif
# From composer, "suggest": {
# "ext-intl": "Handle IDN in AddressList hostnames",
-# "zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3 when using SMTP to deliver messages"
-# "zendframework/zend-crypt": "^2.6",
-%if 0%{?fedora} >= 21
+# "zendframework/zend-crypt": "Crammd5 support in SMTP Auth",
+# "zendframework/zend-servicemanager": "^2.7.10 || ^3.3.1 when using SMTP to deliver messages"
+%if 0%{?fedora} >= 21 || 0%{?rhel} >= 8
Suggests: php-intl
-Suggests: php-autoloader(%{gh_owner}/zend-servicemanager)
Suggests: php-autoloader(%{gh_owner}/zend-crypt)
+Suggests: php-autoloader(%{gh_owner}/zend-servicemanager)
%endif
%endif
# Autoloader
@@ -157,6 +166,7 @@ cat << 'EOF' | tee -a src/autoload.php
'%{php_home}/Zend/Mime/autoload.php',
'%{php_home}/Zend/Stdlib/autoload.php',
'%{php_home}/Zend/Validator/autoload.php',
+ '%{php_home}/TrueBV/autoload.php',
]);
\Fedora\Autoloader\Dependencies::optional([
'%{php_home}/Zend/ServiceManager/autoload.php',
@@ -183,9 +193,10 @@ require_once '%{buildroot}%{php_home}/Zend/%{library}/autoload.php';
EOF
ret=0
-for cmd in php php71 php72; do
- if which $cmd; then
- $cmd %{_bindir}/phpunit6 \
+for cmdarg in "php %{phpunit}" "php70 %{_bindir}/phpunit6" php71 php72 php73; do
+ if which $cmdarg; then
+ set $cmdarg
+ $1 ${2:-%{_bindir}/phpunit7} \
--verbose || ret=1
fi
done
@@ -204,6 +215,11 @@ exit $ret
%changelog
+* Thu Jun 7 2018 Remi Collet <remi@remirepo.net> - 2.10.0-2
+- update to 2.10.0
+- lower dependency on PHP 5.6
+- add dependency on true/punycode
+
* Fri Mar 2 2018 Remi Collet <remi@remirepo.net> - 2.9.0-1
- Update to 2.9.0
- raise dependency on PHP 7.1