summaryrefslogtreecommitdiffstats
path: root/php-zendframework-zend-mail.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-zendframework-zend-mail.spec')
-rw-r--r--php-zendframework-zend-mail.spec58
1 files changed, 35 insertions, 23 deletions
diff --git a/php-zendframework-zend-mail.spec b/php-zendframework-zend-mail.spec
index 4734ace..1e8483d 100644
--- a/php-zendframework-zend-mail.spec
+++ b/php-zendframework-zend-mail.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 248230940ab1453b2a532a8fde76c5a6470d7aad
+%global gh_commit d7beb63d5f7144a21ac100072c453e63860cdab8
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-mail
@@ -20,8 +20,8 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.8.0
-Release: 3%{?dist}
+Version: 2.10.0
+Release: 1%{?dist}
Summary: Zend Framework %{library} component
Group: Development/Libraries
@@ -30,8 +30,6 @@ URL: https://zendframework.github.io/%{gh_project}/
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
-Patch0: https://patch-diff.githubusercontent.com/raw/zendframework/zend-mail/pull/174.patch
-
BuildArch: noarch
# Tests
%if %{with_tests}
@@ -44,33 +42,32 @@ BuildRequires: php-spl
BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
BuildRequires: php-composer(%{gh_owner}/zend-mime) >= 2.5
BuildRequires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7
-BuildRequires: php-composer(%{gh_owner}/zend-validator) >= 2.6
+BuildRequires: php-composer(%{gh_owner}/zend-validator) >= 2.10.2
+BuildRequires: php-composer(true/punycode) >= 2.1
+BuildRequires: php-composer(true/punycode) < 3
# From composer, "require-dev": {
+# "phpunit/phpunit": "^5.7.25 || ^6.4.4 || ^7.1.4",
+# "zendframework/zend-coding-standard": "~1.0.0",
# "zendframework/zend-config": "^2.6",
-# "zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3",
-# "zendframework/zend-crypt": "^2.6",
-# "phpunit/phpunit": "^6.0.8 || ^5.7.15",
-# "zendframework/zend-coding-standard": "~1.0.0"
+# "zendframework/zend-crypt": "^2.6 || ^3.0",
+# "zendframework/zend-servicemanager": "^2.7.10 || ^3.3.1"
BuildRequires: php-composer(%{gh_owner}/zend-config) >= 2.6
-BuildRequires: php-composer(%{gh_owner}/zend-servicemanager) >= 2.7.5
+BuildRequires: php-composer(%{gh_owner}/zend-servicemanager) >= 2.7.10
BuildRequires: php-composer(%{gh_owner}/zend-crypt) >= 2.6
-%if 0%{?fedora} >= 26
-%global phpunit %{_bindir}/phpunit6
-%else
+BuildRequires: php-composer(phpunit/phpunit) >= 5.7.25
%global phpunit %{_bindir}/phpunit
-%endif
-BuildRequires: %{phpunit}
# Autoloader
BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
%endif
# From composer, "require": {
-# "php": "^7.0 || ^5.6",
+# "php": "^5.6 || ^7.0",
# "ext-iconv": "*",
# "zendframework/zend-loader": "^2.5",
# "zendframework/zend-mime": "^2.5",
# "zendframework/zend-stdlib": "^2.7 || ^3.0",
-# "zendframework/zend-validator": "^2.6"
+# "zendframework/zend-validator": "^2.10.2",
+# "true/punycode": "^2.1"
Requires: php(language) >= 5.6
Requires: php-iconv
%if ! %{bootstrap}
@@ -80,8 +77,10 @@ Requires: php-composer(%{gh_owner}/zend-mime) >= 2.5
Requires: php-composer(%{gh_owner}/zend-mime) < 3
Requires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7
Requires: php-composer(%{gh_owner}/zend-stdlib) < 4
-Requires: php-composer(%{gh_owner}/zend-validator) >= 2.6
+Requires: php-composer(%{gh_owner}/zend-validator) >= 2.10.2
Requires: php-composer(%{gh_owner}/zend-validator) < 3
+Requires: php-composer(true/punycode) >= 2.1
+Requires: php-composer(true/punycode) < 3
# From composer, "suggest": {
# "ext-intl": "Handle IDN in AddressList hostnames",
# "zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3 when using SMTP to deliver messages"
@@ -115,25 +114,32 @@ Documentation: https://zendframework.github.io/%{gh_project}/
%prep
%setup -q -n %{gh_project}-%{gh_commit}
-%patch0 -p1
mv LICENSE.md LICENSE
%build
-# Empty build section, nothing required
+: Create dependency autoloader
+cat << 'EOF' | tee autoload.php
+<?php
+require_once '%{php_home}/TrueBV/autoload.php';
+EOF
%install
mkdir -p %{buildroot}%{php_home}/Zend/
cp -pr src %{buildroot}%{php_home}/Zend/%{library}
+install -m644 autoload.php %{buildroot}%{php_home}/Zend/%{library}-autoload.php
+
%check
%if %{with_tests}
mkdir vendor
cat << 'EOF' | tee vendor/autoload.php
<?php
+define('RPM_BUILDROOT', '%{buildroot}%{php_home}/Zend');
+
require_once '%{php_home}/Zend/Loader/AutoloaderFactory.php';
Zend\Loader\AutoloaderFactory::factory(array(
'Zend\Loader\StandardAutoloader' => array(
@@ -145,10 +151,10 @@ require_once '%{php_home}/Zend/autoload.php';
EOF
ret=0
-for cmd in "php %{phpunit}" "php56 %{_bindir}/phpunit" php70 php71 php72; do
+for cmd in "php %{phpunit}" php70 php71 php72 php73; do
if which $cmd; then
set $cmd
- $1 ${2:-%{_bindir}/phpunit6} --verbose || ret=1
+ $1 ${2:-%{_bindir}/phpunit6}
fi
done
exit $ret
@@ -163,9 +169,15 @@ exit $ret
%doc *.md
%doc composer.json
%{php_home}/Zend/%{library}
+%{php_home}/Zend/%{library}-autoload.php
%changelog
+* Thu Jun 7 2018 Remi Collet <remi@remirepo.net> - 2.10.0-1
+- update to 2.10.0
+- raise dependency on zend-validator 2.10.2
+- add dependency on true/punycode
+
* Fri Oct 20 2017 Remi Collet <remi@remirepo.net> - 2.8.0-3
- fix FTBFS from Koschei
- add patch for latest PHPUnit from