summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json15
-rw-r--r--php-zendframework-zend-mail.spec11
2 files changed, 20 insertions, 6 deletions
diff --git a/composer.json b/composer.json
index 48224a8..cb3d69f 100644
--- a/composer.json
+++ b/composer.json
@@ -23,8 +23,8 @@
"zendframework/zend-config": "^2.6",
"zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3",
"zendframework/zend-crypt": "^2.6",
- "squizlabs/php_codesniffer": "^2.3.1",
- "phpunit/phpunit": "^4.8"
+ "phpunit/phpunit": "^4.8",
+ "zendframework/zend-coding-standard": "~1.0.0"
},
"suggest": {
"zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3 when using SMTP to deliver messages",
@@ -46,5 +46,16 @@
"psr-4": {
"ZendTest\\Mail\\": "test/"
}
+ },
+ "scripts": {
+ "check": [
+ "@cs-check",
+ "@test"
+ ],
+ "cs-check": "phpcs",
+ "cs-fix": "phpcbf",
+ "test": "phpunit --colors=always",
+ "test-coverage": "phpunit --colors=always --coverage-clover clover.xml",
+ "upload-coverage": "coveralls -v"
}
}
diff --git a/php-zendframework-zend-mail.spec b/php-zendframework-zend-mail.spec
index a576265..e654034 100644
--- a/php-zendframework-zend-mail.spec
+++ b/php-zendframework-zend-mail.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 8210faa6865f94962f9a5c76269703bfdcf2fa4c
+%global gh_commit e92b4bc1cf6fe0fdad571bd7b4af2762414d58ff
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-mail
@@ -20,7 +20,7 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.7.2
+Version: 2.7.3
Release: 1%{?dist}
Summary: Zend Framework %{library} component
@@ -48,8 +48,8 @@ BuildRequires: php-composer(%{gh_owner}/zend-validator) >= 2.6
# "zendframework/zend-config": "^2.6",
# "zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3",
# "zendframework/zend-crypt": "^2.6",
-# "squizlabs/php_codesniffer": "^2.3.1",
-# "phpunit/phpunit": "^4.8"
+# "phpunit/phpunit": "^4.8",
+# "zendframework/zend-coding-standard": "~1.0.0"
BuildRequires: php-composer(%{gh_owner}/zend-config) >= 2.6
BuildRequires: php-composer(%{gh_owner}/zend-servicemanager) >= 2.7.5
BuildRequires: php-composer(%{gh_owner}/zend-crypt) >= 2.6
@@ -171,6 +171,9 @@ rm -rf %{buildroot}
%changelog
+* Wed Feb 15 2017 Remi Collet <remi@fedoraproject.org> - 2.7.3-1
+- update to 2.7.3
+
* Wed Dec 21 2016 Remi Collet <remi@fedoraproject.org> - 2.7.2-1
- update to 2.7.2