summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-06-09 07:30:19 +0200
committerRemi Collet <remi@remirepo.net>2017-06-09 07:30:19 +0200
commit74ff11013fed2a45ddd1ce5512bb8d927881eaf8 (patch)
tree1b188dcd58c82735ab93aa46a8a71dd2ba0c9e67
parent3a99cf22c3baa0654d0d32c9e1a4628557204e59 (diff)
v2.8.0
-rw-r--r--.gitignore7
-rw-r--r--composer.json10
-rw-r--r--php-zendframework-zend-mail.spec63
3 files changed, 45 insertions, 35 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..1ab5c4f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/composer.json b/composer.json
index cb3d69f..dbfca53 100644
--- a/composer.json
+++ b/composer.json
@@ -13,7 +13,8 @@
}
},
"require": {
- "php": "^5.5 || ^7.0",
+ "php": "^7.0 || ^5.6",
+ "ext-iconv": "*",
"zendframework/zend-loader": "^2.5",
"zendframework/zend-mime": "^2.5",
"zendframework/zend-stdlib": "^2.7 || ^3.0",
@@ -23,10 +24,11 @@
"zendframework/zend-config": "^2.6",
"zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3",
"zendframework/zend-crypt": "^2.6",
- "phpunit/phpunit": "^4.8",
+ "phpunit/phpunit": "^6.0.8 || ^5.7.15",
"zendframework/zend-coding-standard": "~1.0.0"
},
"suggest": {
+ "ext-intl": "Handle IDN in AddressList hostnames",
"zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3 when using SMTP to deliver messages",
"zendframework/zend-crypt": "Crammd5 support in SMTP Auth"
},
@@ -34,8 +36,8 @@
"prefer-stable": true,
"extra": {
"branch-alias": {
- "dev-master": "2.7-dev",
- "dev-develop": "2.8-dev"
+ "dev-master": "2.8-dev",
+ "dev-develop": "2.9-dev"
},
"zf": {
"component": "Zend\\Mail",
diff --git a/php-zendframework-zend-mail.spec b/php-zendframework-zend-mail.spec
index e654034..eca8185 100644
--- a/php-zendframework-zend-mail.spec
+++ b/php-zendframework-zend-mail.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit e92b4bc1cf6fe0fdad571bd7b4af2762414d58ff
+%global gh_commit 248230940ab1453b2a532a8fde76c5a6470d7aad
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-mail
@@ -20,7 +20,7 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.7.3
+Version: 2.8.0
Release: 1%{?dist}
Summary: Zend Framework %{library} component
@@ -30,11 +30,10 @@ URL: https://zendframework.github.io/%{gh_project}/
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.5
+BuildRequires: php(language) >= 5.6
BuildRequires: php-ctype
BuildRequires: php-date
BuildRequires: php-iconv
@@ -48,23 +47,30 @@ BuildRequires: php-composer(%{gh_owner}/zend-validator) >= 2.6
# "zendframework/zend-config": "^2.6",
# "zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3",
# "zendframework/zend-crypt": "^2.6",
-# "phpunit/phpunit": "^4.8",
+# "phpunit/phpunit": "^6.0.8 || ^5.7.15",
# "zendframework/zend-coding-standard": "~1.0.0"
BuildRequires: php-composer(%{gh_owner}/zend-config) >= 2.6
BuildRequires: php-composer(%{gh_owner}/zend-servicemanager) >= 2.7.5
BuildRequires: php-composer(%{gh_owner}/zend-crypt) >= 2.6
-BuildRequires: php-composer(phpunit/phpunit) >= 4.8
+%if 0%{?fedora} >= 26
+%global phpunit %{_bindir}/phpunit6
+%else
+%global phpunit %{_bindir}/phpunit
+%endif
+BuildRequires: %{phpunit}
# Autoloader
BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
%endif
# From composer, "require": {
-# "php": "^5.5 || ^7.0",
+# "php": "^7.0 || ^5.6",
+# "ext-iconv": "*",
# "zendframework/zend-loader": "^2.5",
# "zendframework/zend-mime": "^2.5",
# "zendframework/zend-stdlib": "^2.7 || ^3.0",
# "zendframework/zend-validator": "^2.6"
-Requires: php(language) >= 5.5
+Requires: php(language) >= 5.6
+Requires: php-iconv
%if ! %{bootstrap}
Requires: php-composer(%{gh_owner}/zend-loader) >= 2.5
Requires: php-composer(%{gh_owner}/zend-loader) < 3
@@ -75,17 +81,18 @@ Requires: php-composer(%{gh_owner}/zend-stdlib) < 4
Requires: php-composer(%{gh_owner}/zend-validator) >= 2.6
Requires: php-composer(%{gh_owner}/zend-validator) < 3
# From composer, "suggest": {
+# "ext-intl": "Handle IDN in AddressList hostnames",
# "zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3 when using SMTP to deliver messages"
# "zendframework/zend-crypt": "^2.6",
%if 0%{?fedora} >= 21
+Suggests: php-intl
Suggests: php-composer(%{gh_owner}/zend-servicemanager)
Suggests: php-composer(%{gh_owner}/zend-crypt)
%endif
%endif
-# From phpcompatinfo report for version 2.6.1
+# From phpcompatinfo report for version 2.8.0
Requires: php-ctype
Requires: php-date
-Requires: php-iconv
Requires: php-pcre
Requires: php-spl
@@ -115,8 +122,6 @@ mv LICENSE.md LICENSE
%install
-rm -rf %{buildroot}
-
mkdir -p %{buildroot}%{php_home}/Zend/
cp -pr src %{buildroot}%{php_home}/Zend/%{library}
@@ -136,33 +141,20 @@ Zend\Loader\AutoloaderFactory::factory(array(
require_once '%{php_home}/Zend/autoload.php';
EOF
-# remirepo:11
-run=0
ret=0
-if which php56; then
- php56 %{_bindir}/phpunit --include-path=%{buildroot}%{php_home} || ret=1
- run=1
-fi
-if which php71; then
- php70 %{_bindir}/phpunit --include-path=%{buildroot}%{php_home} || ret=1
- run=1
-fi
-if [ $run -eq 0 ]; then
-%{_bindir}/phpunit --include-path=%{buildroot}%{php_home} --verbose
-# remirepo:2
-fi
+for cmd in "php %{phpunit}" "php56 %{_bindir}/phpunit" php70 php71 php72; do
+ if which $cmd; then
+ set $cmd
+ $1 ${2:-%{_bindir}/phpunit6} --verbose || ret=1
+ fi
+done
exit $ret
%else
: Test suite disabled
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md
@@ -171,6 +163,15 @@ rm -rf %{buildroot}
%changelog
+* Fri Jun 9 2017 Remi Collet <remi@remirepo.net> - 2.8.0-1
+- Update to 2.8.0
+- raise dependency on PHP 5.6
+- use phpunit6 on F26+
+
+* Wed Apr 12 2017 Remi Collet <remi@fedoraproject.org> - 2.7.3-2
+- add upstream patch to fix FTBFS (from Koschei)
+ https://github.com/zendframework/zend-mail/issues/136
+
* Wed Feb 15 2017 Remi Collet <remi@fedoraproject.org> - 2.7.3-1
- update to 2.7.3