summaryrefslogtreecommitdiffstats
path: root/php-zendframework-zend-log.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-zendframework-zend-log.spec')
-rw-r--r--php-zendframework-zend-log.spec85
1 files changed, 65 insertions, 20 deletions
diff --git a/php-zendframework-zend-log.spec b/php-zendframework-zend-log.spec
index 89f9616..aff9e02 100644
--- a/php-zendframework-zend-log.spec
+++ b/php-zendframework-zend-log.spec
@@ -1,13 +1,13 @@
# remirepo/Fedora spec file for php-zendframework-zend-log
#
-# Copyright (c) 2015-2017 Remi Collet
+# Copyright (c) 2015-2019 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 9cec3b092acb39963659c2f32441cccc56b3f430
+%global gh_commit cb278772afdacb1924342248a069330977625ae6
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-log
@@ -20,11 +20,10 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.10.0
+Version: 2.11.0
Release: 2%{?dist}
Summary: Zend Framework %{library} component
-Group: Development/Libraries
License: BSD
URL: https://zendframework.github.io/%{gh_project}/
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
@@ -40,27 +39,59 @@ BuildRequires: php-dom
BuildRequires: php-json
BuildRequires: php-pcre
BuildRequires: php-spl
-BuildRequires: php-autoloader(%{gh_owner}/zend-servicemanager) >= 2.5
-BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) >= 2.5
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (php-autoloader(%{gh_owner}/zend-servicemanager) >= 2.7.5 with php-autoloader(%{gh_owner}/zend-servicemanager) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7 with php-autoloader(%{gh_owner}/zend-stdlib) < 4)
+BuildRequires: (php-composer(psr/log) >= 1.0 with php-composer(psr/log) < 2)
+# remirepo:8
+%else
+BuildRequires: php-autoloader(%{gh_owner}/zend-servicemanager) < 4
+BuildRequires: php-autoloader(%{gh_owner}/zend-servicemanager) >= 2.7.5
+BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) < 4
+BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7
+BuildRequires: php-composer(psr/log) < 2
BuildRequires: php-composer(psr/log) >= 1.0
+%endif
# From composer, "require-dev": {
-# "mikey179/vfsStream": "^1.6",
-# "phpunit/phpunit": "^5.7.15 || ^6.0.8",
+# "mikey179/vfsstream": "^1.6.7",
+# "phpunit/phpunit": "^5.7.27 || ^6.5.14 || ^7.5.15,
# "zendframework/zend-coding-standard": "~1.0.0",
# "zendframework/zend-db": "^2.6",
# "zendframework/zend-escaper": "^2.5",
# "zendframework/zend-filter": "^2.5",
# "zendframework/zend-mail": "^2.6.1",
# "zendframework/zend-validator": "^2.10.1"
-BuildRequires: php-composer(mikey179/vfsStream) >= 1.6
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (php-composer(mikey179/vfsstream) >= 1.6.7 with php-composer(mikey179/vfsstream) < 2)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-console) >= 2.5 with php-autoloader(%{gh_owner}/zend-console) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-db) >= 2.6 with php-autoloader(%{gh_owner}/zend-db) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-escaper) >= 2.5 with php-autoloader(%{gh_owner}/zend-escaper) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-filter) >= 2.5 with php-autoloader(%{gh_owner}/zend-filter) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-mail) >= 2.6.1 with php-autoloader(%{gh_owner}/zend-mail) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-validator) >= 2.10.1 with php-autoloader(%{gh_owner}/zend-validator) < 3)
+%global phpunit %{_bindir}/phpunit7
+BuildRequires: phpunit7 >= 7.5.15
+# remirepo:18
+%else
+BuildRequires: php-composer(mikey179/vfsstream) < 2
+BuildRequires: php-composer(mikey179/vfsstream) >= 1.6.7
+BuildRequires: php-autoloader(%{gh_owner}/zend-console) < 3
BuildRequires: php-autoloader(%{gh_owner}/zend-console) >= 2.5
+BuildRequires: php-autoloader(%{gh_owner}/zend-db) < 3
BuildRequires: php-autoloader(%{gh_owner}/zend-db) >= 2.6
+BuildRequires: php-autoloader(%{gh_owner}/zend-escaper) < 3
BuildRequires: php-autoloader(%{gh_owner}/zend-escaper) >= 2.5
+BuildRequires: php-autoloader(%{gh_owner}/zend-filter) < 3
BuildRequires: php-autoloader(%{gh_owner}/zend-filter) >= 2.5
+BuildRequires: php-autoloader(%{gh_owner}/zend-mail) < 3
BuildRequires: php-autoloader(%{gh_owner}/zend-mail) >= 2.6.1
+BuildRequires: php-autoloader(%{gh_owner}/zend-validator) < 3
BuildRequires: php-autoloader(%{gh_owner}/zend-validator) >= 2.10.1
-%global phpunit %{_bindir}/phpunit6
-BuildRequires: %{phpunit}
+%global phpunit %{_bindir}/phpunit
+BuildRequires: php-phpunit-PHPUnit >= 5.7.27
+%endif
# Optional dep
BuildRequires: php-autoloader(%{gh_owner}/zend-mime) >= 2.5
%endif
@@ -74,12 +105,11 @@ BuildRequires: php-fedora-autoloader-devel
# "zendframework/zend-stdlib": "^2.7 || ^3.0"
Requires: php(language) >= 5.6
%if ! %{bootstrap}
-Requires: php-composer(psr/log) >= 1.0
-Requires: php-composer(psr/log) < 2
-Requires: php-autoloader(%{gh_owner}/zend-servicemanager) >= 2.7.5
-Requires: php-autoloader(%{gh_owner}/zend-servicemanager) < 4
-Requires: php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7
-Requires: php-autoloader(%{gh_owner}/zend-stdlib) < 4
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Requires: (php-autoloader(%{gh_owner}/zend-servicemanager) >= 2.7.5 with php-autoloader(%{gh_owner}/zend-servicemanager) < 4)
+Requires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7 with php-autoloader(%{gh_owner}/zend-stdlib) < 4)
+Requires: (php-composer(psr/log) >= 1.0 with php-composer(psr/log) < 2)
# From composer, "suggest": {
# "ext-mongo": "mongo extension to use Mongo writer",
# "ext-mongodb": "mongodb extension to use MongoDB writer",
@@ -95,6 +125,15 @@ Suggests: php-autoloader(%{gh_owner}/zend-db)
Suggests: php-autoloader(%{gh_owner}/zend-escaper)
Suggests: php-autoloader(%{gh_owner}/zend-mail)
Suggests: php-autoloader(%{gh_owner}/zend-validator)
+# remirepo:8
+%else
+Requires: php-autoloader(%{gh_owner}/zend-servicemanager) < 4
+Requires: php-autoloader(%{gh_owner}/zend-servicemanager) >= 2.7.5
+Requires: php-autoloader(%{gh_owner}/zend-stdlib) < 4
+Requires: php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7
+Requires: php-composer(psr/log) < 2
+Requires: php-composer(psr/log) >= 1.0
+%endif
%endif
# Autoloader
Requires: php-composer(fedora/autoloader)
@@ -164,7 +203,7 @@ require_once '%{buildroot}%{php_home}/Zend/%{library}/autoload.php';
]);
\Fedora\Autoloader\Autoload::addPsr4('ZendTest\\%{library}\\', dirname(__DIR__) . '/test');
-require __DIR__ . '/../autoload/phpunit.php';
+require __DIR__ . '/../test/autoload.php';
require __DIR__ . '/../test/Writer/TestAsset/chmod.php';
EOF
@@ -172,10 +211,10 @@ EOF
rm test/Writer/MongoDBTest.php
ret=0
-for cmdarg in "php %{phpunit}" php70 php71 php72; do
+for cmdarg in "php %{phpunit}" "php71 %{_bindir}/phpunit6" php72 php73 php74; do
if which $cmdarg; then
set $cmdarg
- $1 ${2:-%{_bindir}/phpunit6} --verbose || ret=1
+ $1 ${2:-%{_bindir}/phpunit7} || ret=1
fi
done
exit $ret
@@ -185,6 +224,7 @@ exit $ret
%files
+# remirepo:1
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md
@@ -193,6 +233,11 @@ exit $ret
%changelog
+* Mon Aug 26 2019 Remi Collet <remi@remirepo.net> - 2.11.0-2
+- update to 2.11.0
+- use range dependencies
+- use phpunit7
+
* Wed Apr 11 2018 Remi Collet <remi@remirepo.net> - 2.10.0-2
- update to 2.10.0