summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-04-07 07:19:02 +0200
committerRemi Collet <fedora@famillecollet.com>2016-04-07 07:19:02 +0200
commit18d4b41c7f4d37c38d8f23f14db000cd15f22efc (patch)
tree8a67e5b2550850d5b43a312820f85745a0f117e2
parent160284fd04195c90d0fa51faed38876d18efe6ad (diff)
php-zendframework-zend-log: 2.8.1
-rw-r--r--php-zendframework-zend-log.spec23
1 files changed, 14 insertions, 9 deletions
diff --git a/php-zendframework-zend-log.spec b/php-zendframework-zend-log.spec
index c534bd6..4ec5679 100644
--- a/php-zendframework-zend-log.spec
+++ b/php-zendframework-zend-log.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit fa6805bb6695d7b9542386600881b8fc81f82103
+%global gh_commit 8a8cac425763b705ee95014cfc776081b789f5eb
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-log
@@ -20,7 +20,7 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.7.1
+Version: 2.8.1
Release: 1%{?dist}
Summary: Zend Framework %{library} component
@@ -46,20 +46,20 @@ BuildRequires: php-composer(%{gh_owner}/zend-stdlib) >= 2.5
BuildRequires: php-composer(psr/log) >= 1.0
# From composer, "require-dev": {
# "zendframework/zend-console": "^2.6",
-# "zendframework/zend-db": "^2.5",
+# "zendframework/zend-db": "^2.6",
# "zendframework/zend-escaper": "^2.5",
# "zendframework/zend-filter": "^2.5",
-# "zendframework/zend-mail": "^2.5",
-# "zendframework/zend-validator": "^2.5",
+# "zendframework/zend-mail": "^2.6.1",
+# "zendframework/zend-validator": "^2.6",
# "fabpot/php-cs-fixer": "1.7.*",
# "phpunit/PHPUnit": "~4.0",
# "mikey179/vfsStream": "^1.6"
BuildRequires: php-composer(%{gh_owner}/zend-console) >= 2.5
-BuildRequires: php-composer(%{gh_owner}/zend-db) >= 2.5
+BuildRequires: php-composer(%{gh_owner}/zend-db) >= 2.6
BuildRequires: php-composer(%{gh_owner}/zend-escaper) >= 2.5
BuildRequires: php-composer(%{gh_owner}/zend-filter) >= 2.5
-BuildRequires: php-composer(%{gh_owner}/zend-mail) >= 2.5
-BuildRequires: php-composer(%{gh_owner}/zend-validator) >= 2.5
+BuildRequires: php-composer(%{gh_owner}/zend-mail) >= 2.6.1
+BuildRequires: php-composer(%{gh_owner}/zend-validator) >= 2.6
BuildRequires: php-composer(phpunit/phpunit) >= 4.0
BuildRequires: php-composer(mikey179/vfsStream) >= 1.6
# Optional dep
@@ -145,6 +145,8 @@ Zend\Loader\AutoloaderFactory::factory(array(
'Zend\\%{library}' => '%{buildroot}%{php_home}/Zend/%{library}'
))));
require_once '%{php_home}/Zend/autoload.php';
+
+require __DIR__ . '/../test/Writer/TestAsset/chmod.php';
EOF
%{_bindir}/phpunit --include-path=%{buildroot}%{php_home}
@@ -171,6 +173,9 @@ rm -rf %{buildroot}
%changelog
+* Thu Apr 7 2016 Remi Collet <remi@fedoraproject.org> - 2.8.1-1
+- update to 2.8.1
+
* Fri Feb 19 2016 Remi Collet <remi@fedoraproject.org> - 2.7.1-1
- update to 2.7.1
@@ -184,4 +189,4 @@ rm -rf %{buildroot}
- add dependency on psr/log
* Tue Aug 4 2015 Remi Collet <remi@fedoraproject.org> - 2.5.2-1
-- initial package \ No newline at end of file
+- initial package