summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-08-04 14:18:53 +0200
committerRemi Collet <fedora@famillecollet.com>2015-08-04 14:18:53 +0200
commitc2bd5a534cf53d76e1f207c60105911418d34824 (patch)
tree48fab81452d0b0318bd30d4ccf950546f78bb6a4
php-zendframework-zend-loader: 2.5.1 (new, wip)
-rw-r--r--Makefile3
-rw-r--r--php-zendframework-zend-loader-autoload.php15
-rw-r--r--php-zendframework-zend-loader.spec100
3 files changed, 118 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..a2cd659
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,3 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
diff --git a/php-zendframework-zend-loader-autoload.php b/php-zendframework-zend-loader-autoload.php
new file mode 100644
index 0000000..659144a
--- /dev/null
+++ b/php-zendframework-zend-loader-autoload.php
@@ -0,0 +1,15 @@
+<?php
+/*
+Simple autoloader for Zend Framework
+Inspired from https://github.com/zendframework/ZendSkeletonApplication
+
+Set autoregister_zf for Zend Framework
+Set fallback_autoloader for dependencies which are PSR-0 compliant
+*/
+require_once __DIR__ . '/Loader/AutoloaderFactory.php';
+Zend\Loader\AutoloaderFactory::factory(array(
+ 'Zend\Loader\StandardAutoloader' => array(
+ 'fallback_autoloader' => true,
+ 'autoregister_zf' => true
+ )
+));
diff --git a/php-zendframework-zend-loader.spec b/php-zendframework-zend-loader.spec
new file mode 100644
index 0000000..52f57db
--- /dev/null
+++ b/php-zendframework-zend-loader.spec
@@ -0,0 +1,100 @@
+# remirepo spec/Fedora file for php-zendframework-zend-loader
+#
+# Copyright (c) 2015 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%global gh_commit c5fd2f071bde071f4363def7dea8dec7393e135c
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner zendframework
+%global gh_project zend-loader
+%global php_home %{_datadir}/php
+%global library Loader
+%global with_tests 0%{!?_without_tests:1}
+
+Name: php-%{gh_owner}-%{gh_project}
+Version: 2.5.1
+Release: 1%{?dist}
+Summary: Zend Framework %{library} component
+
+Group: Development/Libraries
+License: BSD
+URL: http://framework.zend.com/
+Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{version}-%{gh_short}.tar.gz
+Source1: %{name}-autoload.php
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
+BuildArch: noarch
+# Tests
+%if %{with_tests}
+BuildRequires: php(language) >= 5.3.23
+BuildRequires: php-cli
+%endif
+
+# From composer, "require": {
+# "php": ">=5.3.23"
+Requires: php(language) >= 5.3.23
+# From phpcompatinfo report for version 2.5.1
+Requires: php-pcre
+Requires: php-spl
+
+Obsoletes: php-ZendFramework2-%{library} < 2.5
+Provides: php-ZendFramework2-%{library} = %{version}
+Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+
+
+%description
+Zend\Loader provides different strategies for autoloading PHP classes.
+
+You can include %{php_home}/Zend/autoload.php from
+your application to use the Zend Framework.
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+
+%build
+# Empty build section, nothing required
+
+
+%install
+rm -rf %{buildroot}
+
+mkdir -p %{buildroot}%{php_home}/Zend
+install -pm 644 %{SOURCE1} %{buildroot}%{php_home}/Zend/autoload.php
+
+cp -pr src %{buildroot}%{php_home}/Zend/%{library}
+
+
+%check
+%if %{with_tests}
+%{_bindir}/php -r '
+ require "%{buildroot}%{php_home}/Zend/autoload.php";
+ exit (class_exists("Zend\\Loader\\PluginClassLoader" ? 0 : 1));
+'
+%else
+: Test suite disabled
+%endif
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%files
+%defattr(-,root,root,-)
+%{!?_licensedir:%global license %%doc}
+%license LICENSE.md
+%doc CONTRIBUTING.md README.md
+%doc composer.json
+%dir %{php_home}/Zend
+ %{php_home}/Zend/autoload.php
+ %{php_home}/Zend/%{library}
+
+
+%changelog
+* Tue Aug 4 2015 Remi Collet <remi@fedoraproject.org> - 2.5.1-1
+- initial package \ No newline at end of file