summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-05-25 10:13:38 +0200
committerRemi Collet <fedora@famillecollet.com>2016-05-25 10:13:38 +0200
commitfc61460a24c66e7066f94ff94f3edd27a7310c35 (patch)
treed5aad53816f63d4b36749f8fa9b632c2d2785169
parent7a4fcbc963e278387a4289cb6f22cc5afaed020a (diff)
php-zendframework-zend-ldap: 2.7.1
-rw-r--r--composer.json23
-rw-r--r--php-zendframework-zend-ldap.spec7
2 files changed, 22 insertions, 8 deletions
diff --git a/composer.json b/composer.json
index 6a72b43..5d1a796 100644
--- a/composer.json
+++ b/composer.json
@@ -13,15 +13,15 @@
}
},
"require": {
- "php": ">=5.5",
- "ext-ldap": "*",
- "zendframework/zend-stdlib": "~2.5"
+ "php": "^5.5 || ^7.0",
+ "ext-ldap": "*"
},
"require-dev": {
- "zendframework/zend-config": "~2.5",
- "zendframework/zend-eventmanager": "~2.5",
+ "zendframework/zend-config": "^2.5",
+ "zendframework/zend-eventmanager": "^2.6.3 || ^3.0.1",
+ "zendframework/zend-stdlib": "^2.7 || ^3.0",
"fabpot/php-cs-fixer": "1.7.*",
- "phpunit/PHPUnit": "~4.0",
+ "phpunit/PHPUnit": "^4.5",
"php-mock/php-mock-phpunit": "~0.3"
},
"suggest": {
@@ -39,5 +39,16 @@
"psr-4": {
"ZendTest\\Ldap\\": "test/"
}
+ },
+ "scripts": {
+ "check": [
+ "@cs-check",
+ "@test"
+ ],
+ "upload-coverage": "coveralls -v",
+ "cs-check": "php-cs-fixer --version && php-cs-fixer fix -v --diff --dry-run",
+ "cs-fix": "php-cs-fixer fix -v",
+ "test": "phpunit",
+ "test-coverage": "phpunit --coverage-clover clover.xml"
}
}
diff --git a/php-zendframework-zend-ldap.spec b/php-zendframework-zend-ldap.spec
index d24067f..79f95b9 100644
--- a/php-zendframework-zend-ldap.spec
+++ b/php-zendframework-zend-ldap.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit c9b5a383adff5f200afc81530908d22e46b803c7
+%global gh_commit 14c5b862899ad8bb6cd02c567f394ec5dadc039d
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-ldap
@@ -20,7 +20,7 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.7.0
+Version: 2.7.1
Release: 1%{?dist}
Summary: Zend Framework %{library} component
@@ -147,6 +147,9 @@ rm -rf %{buildroot}
%changelog
+* Wed May 25 2016 Remi Collet <remi@fedoraproject.org> - 2.7.1-1
+- update to 2.7.1
+
* Fri Apr 22 2016 Remi Collet <remi@fedoraproject.org> - 2.7.0-1
- update to 2.7.0
- dependency on zend-stdlib is now optional