summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-02-12 09:31:07 +0100
committerRemi Collet <fedora@famillecollet.com>2016-02-12 09:31:07 +0100
commit6a5fa8569494fc3254f9632e1417f132b6b66ff9 (patch)
tree5860fd8487a10a3b9500e16cb9970e7893243905
parent23ca47de239ef27cb131031adbdba7310a114d35 (diff)
php-zendframework-zend-ldap: 2.6.0
-rw-r--r--php-zendframework-zend-ldap.spec29
1 files changed, 18 insertions, 11 deletions
diff --git a/php-zendframework-zend-ldap.spec b/php-zendframework-zend-ldap.spec
index 225cb09..6443083 100644
--- a/php-zendframework-zend-ldap.spec
+++ b/php-zendframework-zend-ldap.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit c647a86224030543401634dbafd514074b49b2b6
+%global gh_commit 920863c447f167f7f1e90f982bdc2532e7a8bf24
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-ldap
@@ -20,7 +20,7 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.5.1
+Version: 2.6.0
Release: 1%{?dist}
Summary: Zend Framework %{library} component
@@ -34,7 +34,7 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.3.23
+BuildRequires: php(language) >= 5.5
BuildRequires: php-ldap
BuildRequires: php-date
BuildRequires: php-iconv
@@ -47,7 +47,8 @@ BuildRequires: php-composer(%{gh_owner}/zend-stdlib) >= 2.5
# "zendframework/zend-config": "~2.5",
# "zendframework/zend-eventmanager": "~2.5",
# "fabpot/php-cs-fixer": "1.7.*",
-# "phpunit/PHPUnit": "~4.0"
+# "phpunit/PHPUnit": "~4.0",
+# "php-mock/php-mock-phpunit": "~0.3"
BuildRequires: php-composer(%{gh_owner}/zend-config) >= 2.5
BuildRequires: php-composer(%{gh_owner}/zend-eventmanager) >= 2.5
BuildRequires: php-composer(phpunit/phpunit) >= 4.0
@@ -56,10 +57,10 @@ BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
%endif
# From composer, "require": {
-# "php": ">=5.3.23",
+# "php": ">=5.5",
# "ext-ldap": "*",
# "zendframework/zend-stdlib": "~2.5"
-Requires: php(language) >= 5.3.23
+Requires: php(language) >= 5.5
Requires: php-ldap
%if ! %{bootstrap}
Requires: php-composer(%{gh_owner}/zend-stdlib) >= 2.5
@@ -105,15 +106,18 @@ cp -pr src %{buildroot}%{php_home}/Zend/%{library}
%check
%if %{with_tests}
+# Temporary, ignore test using PHPMock
+rm test/OfflineTest.php
+
mkdir vendor
-cat << EOF | tee vendor/autoload.php
+cat << 'EOF' | tee vendor/autoload.php
<?php
require_once '%{php_home}/Zend/Loader/AutoloaderFactory.php';
-Zend\\Loader\\AutoloaderFactory::factory(array(
- 'Zend\\Loader\\StandardAutoloader' => array(
+Zend\Loader\AutoloaderFactory::factory(array(
+ 'Zend\Loader\StandardAutoloader' => array(
'namespaces' => array(
- 'ZendTest\\\\%{library}' => dirname(__DIR__).'/test/',
- 'Zend\\\\%{library}' => '%{buildroot}%{php_home}/Zend/%{library}'
+ 'ZendTest\\%{library}' => dirname(__DIR__).'/test/',
+ 'Zend\\%{library}' => '%{buildroot}%{php_home}/Zend/%{library}'
))));
require_once '%{php_home}/Zend/autoload.php';
EOF
@@ -142,5 +146,8 @@ rm -rf %{buildroot}
%changelog
+* Fri Feb 12 2016 Remi Collet <remi@fedoraproject.org> - 2.6.0-1
+- update to 2.6.0
+
* Tue Aug 4 2015 Remi Collet <remi@fedoraproject.org> - 2.5.1-1
- initial package \ No newline at end of file