summaryrefslogtreecommitdiffstats
path: root/php-zendframework-zend-json.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-zendframework-zend-json.spec')
-rw-r--r--php-zendframework-zend-json.spec16
1 files changed, 5 insertions, 11 deletions
diff --git a/php-zendframework-zend-json.spec b/php-zendframework-zend-json.spec
index 5ce7cf4..c08e9d4 100644
--- a/php-zendframework-zend-json.spec
+++ b/php-zendframework-zend-json.spec
@@ -43,12 +43,7 @@ BuildRequires: php-spl
# "phpunit/phpunit": "^5.7.23 || ^6.4.3",
# "zendframework/zend-coding-standard": "~1.0.0",
# "zendframework/zend-stdlib": "^2.7.7 || ^3.1"
-%if 0%{?fedora} >= 26
-%global phpunit %{_bindir}/phpunit6
-%else
-%global phpunit %{_bindir}/phpunit
-%endif
-BuildRequires: %{phpunit}
+BuildRequires: phpunit6 >= 6.4.3
BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7.7
%endif
# Autoloader
@@ -66,7 +61,7 @@ Suggests: php-composer(%{gh_owner}/zend-json-server)
Suggests: php-composer(%{gh_owner}/zend-xml2json)
%endif
%endif
-# From phpcompatinfo report for version 3.0.0
+# From phpcompatinfo report for version 3.1.0
Requires: php-json
Requires: php-mbstring
Requires: php-pcre
@@ -122,10 +117,9 @@ require_once '%{buildroot}%{php_home}/Zend/%{library}/autoload.php';
EOF
ret=0
-for cmdarg in "php %{phpunit}" "php56 %{_bindir}/phpunit" php70 php71 php72; do
- if which $cmdarg; then
- set $cmdarg
- $1 ${2:-%{_bindir}/phpunit6} --verbose || ret=1
+for cmd in php php70 php71 php72; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit6 --verbose || ret=1
fi
done
exit $ret