summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-01-05 09:50:53 +0100
committerRemi Collet <remi@remirepo.net>2018-01-05 09:50:53 +0100
commitb74ad6ebbf9b6ec877b8beb2a49d475fa4d8ed06 (patch)
treec927e19c49576e0bdc9e20093d13634617a910de
parent85bac060ce28e20aabd4b100e5fbef3be6d581f9 (diff)
v3.1.0
-rw-r--r--composer.json40
-rw-r--r--php-zendframework-zend-json.spec45
2 files changed, 52 insertions, 33 deletions
diff --git a/composer.json b/composer.json
index 15d1962..c2a582b 100644
--- a/composer.json
+++ b/composer.json
@@ -3,23 +3,25 @@
"description": "provides convenience methods for serializing native PHP to JSON and decoding JSON to native PHP",
"license": "BSD-3-Clause",
"keywords": [
- "zf2",
+ "zf",
+ "zendframework",
"json"
],
- "homepage": "https://github.com/zendframework/zend-json",
- "extra": {
- "branch-alias": {
- "dev-master": "3.0-dev",
- "dev-develop": "3.1-dev"
- }
+ "support": {
+ "docs": "https://docs.zendframework.com/zend-json/",
+ "issues": "https://github.com/zendframework/zend-json/issues",
+ "source": "https://github.com/zendframework/zend-json",
+ "rss": "https://github.com/zendframework/zend-json/releases.atom",
+ "slack": "https://zendframework-slack.herokuapp.com",
+ "forum": "https://discourse.zendframework.com/c/questions/components"
},
"require": {
- "php": "^5.5 || ^7.0"
+ "php": "^5.6 || ^7.0"
},
"require-dev": {
- "zendframework/zend-stdlib": "^2.7 || ^3.0",
- "squizlabs/php_codesniffer": "^2.3",
- "phpunit/PHPUnit": "~4.0"
+ "phpunit/phpunit": "^5.7.23 || ^6.4.3",
+ "zendframework/zend-coding-standard": "~1.0.0",
+ "zendframework/zend-stdlib": "^2.7.7 || ^3.1"
},
"suggest": {
"zendframework/zend-json-server": "For implementing JSON-RPC servers",
@@ -35,15 +37,23 @@
"ZendTest\\Json\\": "test/"
}
},
+ "config": {
+ "sort-packages": true
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "3.1.x-dev",
+ "dev-develop": "3.2.x-dev"
+ }
+ },
"scripts": {
"check": [
"@cs-check",
"@test"
],
- "upload-coverage": "coveralls",
"cs-check": "phpcs",
- "cs-fix": "phpcbf fix -v",
- "test": "phpunit",
- "test-coverage": "phpunit --coverage-clover clover.xml"
+ "cs-fix": "phpcbf",
+ "test": "phpunit --colors=always",
+ "test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
}
}
diff --git a/php-zendframework-zend-json.spec b/php-zendframework-zend-json.spec
index d6c2d04..5ce7cf4 100644
--- a/php-zendframework-zend-json.spec
+++ b/php-zendframework-zend-json.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit f42a1588e75c2a3e338cd94c37906231e616daab
+%global gh_commit 4dd940e8e6f32f1d36ea6b0677ea57c540c7c19c
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-json
@@ -20,8 +20,8 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 3.0.0
-Release: 5%{?dist}
+Version: 3.1.0
+Release: 1%{?dist}
Summary: Zend Framework %{library} component
Group: Development/Libraries
@@ -30,30 +30,33 @@ URL: https://zendframework.github.io/%{gh_project}/
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
-Patch0: https://patch-diff.githubusercontent.com/raw/zendframework/zend-json/pull/33.patch
-
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.5
+BuildRequires: php(language) >= 5.6
BuildRequires: php-json
BuildRequires: php-mbstring
BuildRequires: php-pcre
BuildRequires: php-reflection
BuildRequires: php-spl
# From composer, "require-dev": {
-# "zendframework/zend-stdlib": "^2.7 || ^3.0",
-# "squizlabs/php_codesniffer": "^2.3",
-# "phpunit/PHPUnit": "~4.0"
-BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7
-BuildRequires: php-composer(phpunit/phpunit) >= 4.0
+# "phpunit/phpunit": "^5.7.23 || ^6.4.3",
+# "zendframework/zend-coding-standard": "~1.0.0",
+# "zendframework/zend-stdlib": "^2.7.7 || ^3.1"
+%if 0%{?fedora} >= 26
+%global phpunit %{_bindir}/phpunit6
+%else
+%global phpunit %{_bindir}/phpunit
+%endif
+BuildRequires: %{phpunit}
+BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7.7
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^5.5 || ^7.0",
-Requires: php(language) >= 5.5
+# "php": "^5.6 || ^7.0",
+Requires: php(language) >= 5.6
%if ! %{bootstrap}
# From composer, "suggest": {
# "zendframework/zend-json-server": "For implementing JSON-RPC servers",
@@ -87,7 +90,6 @@ Documentation: https://zendframework.github.io/%{gh_project}/
%prep
%setup -q -n %{gh_project}-%{gh_commit}
-%patch0 -p1
mv LICENSE.md LICENSE
@@ -120,9 +122,10 @@ require_once '%{buildroot}%{php_home}/Zend/%{library}/autoload.php';
EOF
ret=0
-for cmd in php php56 php70 php71 php72; do
- if which $cmd; then
- $cmd %{_bindir}/phpunit --verbose || ret=1
+for cmdarg in "php %{phpunit}" "php56 %{_bindir}/phpunit" php70 php71 php72; do
+ if which $cmdarg; then
+ set $cmdarg
+ $1 ${2:-%{_bindir}/phpunit6} --verbose || ret=1
fi
done
exit $ret
@@ -136,10 +139,16 @@ exit $ret
%license LICENSE
%doc *.md
%doc composer.json
-%{php_home}/Zend/%{library}
+%dir %{php_home}/Zend
+ %{php_home}/Zend/%{library}
%changelog
+* Fri Jan 5 2018 Remi Collet <remi@remirepo.net> - 3.1.0-1
+- Update to 3.1.0
+- raise dependency on PHP 5.6
+- use phpunit6 on F26+
+
* Thu Nov 23 2017 Remi Collet <remi@remirepo.net> - 3.0.0-5
- switch from zend-loader to fedora/autoloader