summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-11-19 08:29:42 +0100
committerRemi Collet <fedora@famillecollet.com>2015-11-19 08:29:42 +0100
commit28bb3df5647ace3338f00f1120ffb34d6d6afc18 (patch)
tree87b0157b3f6fab64a4fbda6b4ddecb684021c5d3
parentf157e6314ee12dc268aa6cdf0371907c7b509f2c (diff)
php-zendframework-zend-*: run test suite with PHP 7 when available
-rw-r--r--php-zendframework-zend-json.spec6
1 files changed, 5 insertions, 1 deletions
diff --git a/php-zendframework-zend-json.spec b/php-zendframework-zend-json.spec
index 3605df6..20c1496 100644
--- a/php-zendframework-zend-json.spec
+++ b/php-zendframework-zend-json.spec
@@ -118,8 +118,12 @@ Zend\\Loader\\AutoloaderFactory::factory(array(
))));
require_once '%{php_home}/Zend/autoload.php';
EOF
-%{_bindir}/php -r 'require "vendor/autoload.php"; var_dump(Zend\Loader\AutoloaderFactory::getRegisteredAutoloaders());'
+
%{_bindir}/phpunit --include-path=%{buildroot}%{php_home}
+
+if which php70; then
+ php70 %{_bindir}/phpunit --include-path=%{buildroot}%{php_home}
+fi
%else
: Test suite disabled
%endif