summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-12-09 09:22:05 +0100
committerRemi Collet <remi@remirepo.net>2017-12-09 09:22:05 +0100
commit715e20c523e3dc7395961896fa4d2beb99dc1b98 (patch)
tree46dabc4c221aa2395ad336c338bb88b43de3027b
parent22d0213bd8f8f132e923654a534296c64ba2a324 (diff)
-rw-r--r--.gitignore8
-rw-r--r--php-zendframework-zend-json-server.spec32
2 files changed, 17 insertions, 23 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..fc9aa8c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+clog
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/php-zendframework-zend-json-server.spec b/php-zendframework-zend-json-server.spec
index 0c8605f..02c55f6 100644
--- a/php-zendframework-zend-json-server.spec
+++ b/php-zendframework-zend-json-server.spec
@@ -21,7 +21,7 @@
Name: php-%{gh_owner}-%{gh_project}
Version: 3.0.0
-Release: 1%{?dist}
+Release: 4%{?dist}
Summary: Zend Json-Server is a JSON-RPC server implementation
Group: Development/Libraries
@@ -30,7 +30,6 @@ URL: https://zendframework.github.io/%{gh_project}/
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
# Tests
%if %{with_tests}
@@ -88,8 +87,6 @@ mv LICENSE.md LICENSE
%install
-rm -rf %{buildroot}
-
mkdir -p %{buildroot}%{php_home}/Zend/Json
cp -pr src %{buildroot}%{php_home}/Zend/Json/%{library}
@@ -110,33 +107,19 @@ require_once '%{php_home}/Zend/autoload.php';
require_once __DIR__ . '/../test/TestAsset/FooFunc.php';
EOF
-# remirepo:11
-run=0
ret=0
-if which php56; then
- php56 %{_bindir}/phpunit --include-path=%{buildroot}%{php_home} || ret=1
- run=1
-fi
-if which php71; then
- php70 %{_bindir}/phpunit --include-path=%{buildroot}%{php_home} || ret=1
- run=1
-fi
-if [ $run -eq 0 ]; then
-%{_bindir}/phpunit --include-path=%{buildroot}%{php_home} --verbose
-# remirepo:2
-fi
+for cmd in php php56 php70 php71 php72; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit || ret=1
+ fi
+done
exit $ret
%else
: Test suite disabled
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md
@@ -145,5 +128,8 @@ rm -rf %{buildroot}
%changelog
+* Sat Dec 9 2017 Remi Collet <remi@remirepo.net> - 3.0.0-4
+- switch from zend-loader to fedora/autoloader
+
* Wed Jun 29 2016 Remi Collet <remi@fedoraproject.org> - 3.0.0-1
- initial package