summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json11
-rwxr-xr-xmakesrc.sh2
-rw-r--r--php-zendframework-zend-inputfilter.spec7
3 files changed, 17 insertions, 3 deletions
diff --git a/composer.json b/composer.json
index f8ec98d..2e16d97 100644
--- a/composer.json
+++ b/composer.json
@@ -42,5 +42,16 @@
"psr-4": {
"ZendTest\\InputFilter\\": "test/"
}
+ },
+ "scripts": {
+ "check": [
+ "@cs-check",
+ "@test"
+ ],
+ "upload-coverage": "coveralls -v",
+ "cs-check": "php-cs-fixer --version && php-cs-fixer fix -v --diff --dry-run",
+ "cs-fix": "php-cs-fixer fix -v",
+ "test": "phpunit",
+ "test-coverage": "phpunit --coverage-clover clover.xml"
}
}
diff --git a/makesrc.sh b/makesrc.sh
index e9a1ec5..87d223d 100755
--- a/makesrc.sh
+++ b/makesrc.sh
@@ -16,7 +16,7 @@ git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT
echo "Getting commit..."
pushd $PROJECT-$COMMIT
git checkout $COMMIT
-cp composer.json ../composer-$VERSION.json
+cp composer.json ../composer.json
popd
echo "Archiving..."
diff --git a/php-zendframework-zend-inputfilter.spec b/php-zendframework-zend-inputfilter.spec
index 24e83c6..3de69d0 100644
--- a/php-zendframework-zend-inputfilter.spec
+++ b/php-zendframework-zend-inputfilter.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit e717d6e87e5bb4fedd4e3b0547f0e9cf90025353
+%global gh_commit 5630ef49e8c16a6fe0c2bd0d2a519869b14d5b12
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-inputfilter
@@ -20,7 +20,7 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.7.1
+Version: 2.7.2
Release: 1%{?dist}
Summary: Zend Framework %{library} component
@@ -147,6 +147,9 @@ rm -rf %{buildroot}
%changelog
+* Sun Jun 12 2016 Remi Collet <remi@fedoraproject.org> - 2.7.2-1
+- update to 2.7.2
+
* Tue Apr 19 2016 Remi Collet <remi@fedoraproject.org> - 2.7.1-1
- update to 2.7.1